summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-wireless
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/crackle/crackle-9999.ebuild3
-rw-r--r--net-wireless/gnuradio/gnuradio-3.7.13.5.ebuild1
-rw-r--r--net-wireless/gnuradio/gnuradio-3.7.9999.ebuild3
-rw-r--r--net-wireless/gnuradio/gnuradio-9999.ebuild3
-rw-r--r--net-wireless/pyrit/pyrit-0.4.0-r1.ebuild3
-rw-r--r--net-wireless/pyrit/pyrit-0.5.0.ebuild3
-rw-r--r--net-wireless/uhd/uhd-3.11.0.0.ebuild3
-rw-r--r--net-wireless/uhd/uhd-3.12.0.0.ebuild3
-rw-r--r--net-wireless/uhd/uhd-3.13.0.1.ebuild3
-rw-r--r--net-wireless/uhd/uhd-3.13.1.0.ebuild1
-rw-r--r--net-wireless/uhd/uhd-3.14.0.0.ebuild1
-rw-r--r--net-wireless/uhd/uhd-3.14.1.1.ebuild1
12 files changed, 20 insertions, 8 deletions
diff --git a/net-wireless/crackle/crackle-9999.ebuild b/net-wireless/crackle/crackle-9999.ebuild
index 429a9ca3700e..08e2559fd789 100644
--- a/net-wireless/crackle/crackle-9999.ebuild
+++ b/net-wireless/crackle/crackle-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="net-libs/libpcap"
DEPEND="${RDEPEND}
diff --git a/net-wireless/gnuradio/gnuradio-3.7.13.5.ebuild b/net-wireless/gnuradio/gnuradio-3.7.13.5.ebuild
index 687926509464..1261b2d25207 100644
--- a/net-wireless/gnuradio/gnuradio-3.7.13.5.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.7.13.5.ebuild
@@ -27,6 +27,7 @@ if [[ ${PV} == "3.7.9999" ]]; then
fi
IUSE="+audio +alsa atsc +analog +digital channels doc dtv examples fcd fec +filter grc jack log noaa oss pager performance-counters portaudio +qt5 sdl test trellis uhd vocoder +utils wavelet wxwidgets zeromq"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
audio? ( || ( alsa oss jack portaudio ) )
diff --git a/net-wireless/gnuradio/gnuradio-3.7.9999.ebuild b/net-wireless/gnuradio/gnuradio-3.7.9999.ebuild
index d9ecae20f231..7ad0616bdf93 100644
--- a/net-wireless/gnuradio/gnuradio-3.7.9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.7.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,7 @@ if [[ ${PV} == "3.7.9999" ]]; then
fi
IUSE="+audio +alsa atsc +analog +digital channels doc dtv examples fcd fec +filter grc jack log noaa oss pager performance-counters portaudio sdl test trellis uhd vocoder +utils wavelet wxwidgets zeromq"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
audio? ( || ( alsa oss jack portaudio ) )
diff --git a/net-wireless/gnuradio/gnuradio-9999.ebuild b/net-wireless/gnuradio/gnuradio-9999.ebuild
index d5a75330aee0..d91e936e43bf 100644
--- a/net-wireless/gnuradio/gnuradio-9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,7 @@ if [[ ${PV} == "3.7.9999" ]]; then
fi
IUSE="+audio +alsa atsc +analog +digital channels doc dtv examples fcd fec +filter grc jack log noaa oss pager performance-counters portaudio +qt5 sdl test trellis uhd vocoder +utils wavelet wxwidgets zeromq"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
audio? ( || ( alsa oss jack portaudio ) )
diff --git a/net-wireless/pyrit/pyrit-0.4.0-r1.ebuild b/net-wireless/pyrit/pyrit-0.4.0-r1.ebuild
index 96a742ac8138..81a725a49490 100644
--- a/net-wireless/pyrit/pyrit-0.4.0-r1.ebuild
+++ b/net-wireless/pyrit/pyrit-0.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,6 +16,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cuda opencl test"
+RESTRICT="!test? ( test )"
DEPEND="dev-libs/openssl
net-libs/libpcap
diff --git a/net-wireless/pyrit/pyrit-0.5.0.ebuild b/net-wireless/pyrit/pyrit-0.5.0.ebuild
index 483bf06f9188..0ed8d1961bda 100644
--- a/net-wireless/pyrit/pyrit-0.5.0.ebuild
+++ b/net-wireless/pyrit/pyrit-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,7 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cuda opencl test"
+RESTRICT="!test? ( test )"
DEPEND="dev-libs/openssl
net-libs/libpcap
diff --git a/net-wireless/uhd/uhd-3.11.0.0.ebuild b/net-wireless/uhd/uhd-3.11.0.0.ebuild
index c3489e4e0be5..f24e3c0eb34d 100644
--- a/net-wireless/uhd/uhd-3.11.0.0.ebuild
+++ b/net-wireless/uhd/uhd-3.11.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(get_version_component_range 1).$(get_version_component_range 2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )
diff --git a/net-wireless/uhd/uhd-3.12.0.0.ebuild b/net-wireless/uhd/uhd-3.12.0.0.ebuild
index 18e5ddf13060..35c0d6bfeb77 100644
--- a/net-wireless/uhd/uhd-3.12.0.0.ebuild
+++ b/net-wireless/uhd/uhd-3.12.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(get_version_component_range 1).$(get_version_component_range 2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )
diff --git a/net-wireless/uhd/uhd-3.13.0.1.ebuild b/net-wireless/uhd/uhd-3.13.0.1.ebuild
index 18e5ddf13060..35c0d6bfeb77 100644
--- a/net-wireless/uhd/uhd-3.13.0.1.ebuild
+++ b/net-wireless/uhd/uhd-3.13.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(get_version_component_range 1).$(get_version_component_range 2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )
diff --git a/net-wireless/uhd/uhd-3.13.1.0.ebuild b/net-wireless/uhd/uhd-3.13.1.0.ebuild
index 3d955335e62c..c0012fc33e0d 100644
--- a/net-wireless/uhd/uhd-3.13.1.0.ebuild
+++ b/net-wireless/uhd/uhd-3.13.1.0.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(get_version_component_range 1).$(get_version_component_range 2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )
diff --git a/net-wireless/uhd/uhd-3.14.0.0.ebuild b/net-wireless/uhd/uhd-3.14.0.0.ebuild
index 3d955335e62c..c0012fc33e0d 100644
--- a/net-wireless/uhd/uhd-3.14.0.0.ebuild
+++ b/net-wireless/uhd/uhd-3.14.0.0.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(get_version_component_range 1).$(get_version_component_range 2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )
diff --git a/net-wireless/uhd/uhd-3.14.1.1.ebuild b/net-wireless/uhd/uhd-3.14.1.1.ebuild
index 8f61652cc090..3d733a2b4f07 100644
--- a/net-wireless/uhd/uhd-3.14.1.1.ebuild
+++ b/net-wireless/uhd/uhd-3.14.1.1.ebuild
@@ -20,6 +20,7 @@ LICENSE="GPL-3"
SLOT="0/$(ver_cut 1-3)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="b100 b200 doc e300 examples mpmd octoclock n230 test usb usrp1 usrp2 +utils x300"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
b100? ( usb )
b200? ( usb )