summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-15 15:46:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-15 15:48:32 +0200
commit087a79f51d9ff452de9f3ac6d7d98bdc4e18c1aa (patch)
tree3276855a6c0ea71d22fb7192d5db05c5a40f23be /net-wireless
parentnet-wireless/liblms7002m: add github upstream metadata (diff)
downloadgentoo-087a79f51d9ff452de9f3ac6d7d98bdc4e18c1aa.tar.gz
gentoo-087a79f51d9ff452de9f3ac6d7d98bdc4e18c1aa.tar.bz2
gentoo-087a79f51d9ff452de9f3ac6d7d98bdc4e18c1aa.zip
net-wireless/liblms7002m: enable py3.{9,10}, ebuild cleanup
python is used during compilation only, for running a code generation script. Therefore we can use python-any-r1. Works for python 3.9 and python 3.10. Update DESCRIPTION, HOMEPAGE, LICENSE for github repo Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/liblms7002m/liblms7002m-0.0_p20200518-r1.ebuild (renamed from net-wireless/liblms7002m/liblms7002m-0.0_p20200518.ebuild)27
-rw-r--r--net-wireless/liblms7002m/liblms7002m-9999.ebuild21
2 files changed, 27 insertions, 21 deletions
diff --git a/net-wireless/liblms7002m/liblms7002m-0.0_p20200518.ebuild b/net-wireless/liblms7002m/liblms7002m-0.0_p20200518-r1.ebuild
index 06521a3518a2..d8e16b9374a8 100644
--- a/net-wireless/liblms7002m/liblms7002m-0.0_p20200518.ebuild
+++ b/net-wireless/liblms7002m/liblms7002m-0.0_p20200518-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-inherit cmake python-single-r1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake python-any-r1
-DESCRIPTION="Toolkit that provides signal processing blocks to implement software radios"
-HOMEPAGE="https://www.gnuradio.org/"
-LICENSE="GPL-3"
+DESCRIPTION="Compact LMS7002M library suitable for resource-limited MCUs"
+HOMEPAGE="https://github.com/xtrx-sdr/liblms7002m"
+LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-if [[ ${PV} =~ "9999" ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/xtrx-sdr/liblms7002m.git"
inherit git-r3
else
@@ -21,12 +21,15 @@ else
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ ')
+"
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/cheetah3[${PYTHON_USEDEP}]')"
-DEPEND="${RDEPEND}"
+python_check_deps() {
+ has_version "dev-python/cheetah3[${PYTHON_USEDEP}]"
+}
src_configure() {
mycmakeargs=(
diff --git a/net-wireless/liblms7002m/liblms7002m-9999.ebuild b/net-wireless/liblms7002m/liblms7002m-9999.ebuild
index edd808aede06..d8e16b9374a8 100644
--- a/net-wireless/liblms7002m/liblms7002m-9999.ebuild
+++ b/net-wireless/liblms7002m/liblms7002m-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-inherit cmake python-single-r1
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake python-any-r1
DESCRIPTION="Compact LMS7002M library suitable for resource-limited MCUs"
HOMEPAGE="https://github.com/xtrx-sdr/liblms7002m"
LICENSE="LGPL-2.1"
SLOT="0/${PV}"
-if [[ ${PV} =~ "9999" ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/xtrx-sdr/liblms7002m.git"
inherit git-r3
else
@@ -21,12 +21,15 @@ else
KEYWORDS="~amd64 ~x86"
fi
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+BDEPEND="
+ $(python_gen_any_dep '
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ ')
+"
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/cheetah3[${PYTHON_USEDEP}]')"
-DEPEND="${RDEPEND}"
+python_check_deps() {
+ has_version "dev-python/cheetah3[${PYTHON_USEDEP}]"
+}
src_configure() {
mycmakeargs=(