summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-17 20:17:06 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-08-17 20:17:24 +0000
commit3297657be06567733f245e48fed7fccb6164c224 (patch)
treee121ac9eafb619148bffc42faf1e3fd5ce018d99 /net-wireless
parentlicenses: Remove unused. (diff)
downloadgentoo-3297657be06567733f245e48fed7fccb6164c224.tar.gz
gentoo-3297657be06567733f245e48fed7fccb6164c224.tar.bz2
gentoo-3297657be06567733f245e48fed7fccb6164c224.zip
net-wireless/portapack-havoc: initial commit
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/portapack-havoc/Manifest1
-rw-r--r--net-wireless/portapack-havoc/metadata.xml11
-rw-r--r--net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/net-wireless/portapack-havoc/Manifest b/net-wireless/portapack-havoc/Manifest
new file mode 100644
index 000000000000..4e4cc5ad6378
--- /dev/null
+++ b/net-wireless/portapack-havoc/Manifest
@@ -0,0 +1 @@
+DIST portapack-havoc-0.0_p20180612.tar.gz 74244267 BLAKE2B 7a6b632cd3766681e691cb0e8405e9493d4d4b46008c9905192f492715238378713da6a305383855b50935f5ffa943e5134677ab1580275a645b46e0e025c561 SHA512 b8ea6a4aa6682793a69cefb2815fcaf51a5f6f253bea2c34e00d76fba15f9d700f45f1a36c1ac7e1d7c640ac19ee64dc835c76c3d9964d73d18443299a2d6fdd
diff --git a/net-wireless/portapack-havoc/metadata.xml b/net-wireless/portapack-havoc/metadata.xml
new file mode 100644
index 000000000000..379b11c6216c
--- /dev/null
+++ b/net-wireless/portapack-havoc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">furrtek/portapack-havoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild b/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild
new file mode 100644
index 000000000000..59b7f30080d1
--- /dev/null
+++ b/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Custom firmware for the HackRF SDR + PortaPack H1 addon"
+HOMEPAGE="https://github.com/furrtek/portapack-havoc/wiki"
+COMMIT="609235b19f55d0bf278c0e7c4b9f9b6b15136247"
+SRC_URI="https://github.com/furrtek/portapack-havoc/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+ >=app-mobilephone/dfu-util-0.7"
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ insinto /usr/share/hackrf
+ newins firmware/portapack-h1-havoc.bin portapack-h1-havoc-${PV}.bin
+ ln -s portapack-h1-havoc-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-havoc.bin"
+
+ cat << EOF > switch_to_havoc
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/portapack-h1-havoc.bin
+EOF
+ dobin switch_to_havoc
+}