summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-04-24 11:48:37 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-04-24 11:48:54 -0400
commit3d4a17a9afd328cbd49998124cb919409263060b (patch)
tree12d7a6c6b36a08bf5d5be18ff991fa19d7326fb1 /net-wireless
parentnet-irc/quassel: Release switch (diff)
downloadgentoo-3d4a17a9afd328cbd49998124cb919409263060b.tar.gz
gentoo-3d4a17a9afd328cbd49998124cb919409263060b.tar.bz2
gentoo-3d4a17a9afd328cbd49998124cb919409263060b.zip
net-wireless/kismet: add mostly required python support
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet/files/fix-setuptools.patch73
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild12
2 files changed, 81 insertions, 4 deletions
diff --git a/net-wireless/kismet/files/fix-setuptools.patch b/net-wireless/kismet/files/fix-setuptools.patch
new file mode 100644
index 000000000000..a86f66b4447c
--- /dev/null
+++ b/net-wireless/kismet/files/fix-setuptools.patch
@@ -0,0 +1,73 @@
+commit e31263b50acd960f7bb0c34c0396383319d7da30
+Author: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
+Date: Tue Apr 24 11:38:17 2018 -0400
+
+ make setuptools respect DESTDIR
+
+ thanks to mgorny for pointint it out
+
+diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
+index 75c85da9..980c417a 100644
+--- a/capture_freaklabs_zigbee/Makefile.in
++++ b/capture_freaklabs_zigbee/Makefile.in
+@@ -6,7 +6,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+
+ clean:
+diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
+index 23446edc..babc63f4 100644
+--- a/capture_sdr_rtl433/Makefile.in
++++ b/capture_sdr_rtl433/Makefile.in
+@@ -7,7 +7,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MQTTMONITOR_BIN) $(BIN)/$(MQTTMONITOR_BIN)
+
+diff --git a/python_modules/KismetExternal/Makefile b/python_modules/KismetExternal/Makefile
+index 036541a0..fc660dfe 100644
+--- a/python_modules/KismetExternal/Makefile
++++ b/python_modules/KismetExternal/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ protobuf:
+ $(PROTOCBIN) -I ../../protobuf_definitions --python_out=./KismetExternal ../../protobuf_definitions/*.proto
+diff --git a/python_modules/KismetLog/Makefile b/python_modules/KismetLog/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetLog/Makefile
++++ b/python_modules/KismetLog/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean
+diff --git a/python_modules/KismetRest/Makefile b/python_modules/KismetRest/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetRest/Makefile
++++ b/python_modules/KismetRest/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 2b1292aff57d..60b19468d9eb 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=6
-inherit autotools eutils multilib user
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib user python-single-r1
MY_P=${P/\./-}
MY_P=${MY_P/./-R}
@@ -28,6 +30,7 @@ SLOT="0/${PV}"
IUSE="+pcre speech selinux +suid"
CDEPEND="
+ ${PYTHON_DEPS}
net-misc/networkmanager:=
dev-libs/glib:=
dev-libs/elfutils:=
@@ -64,14 +67,15 @@ src_prepare() {
sed -i -e 's| -s||g' \
-e 's|@mangrp@|root|g' Makefile.in
+ eapply "${FILESDIR}/fix-setuptools.patch"
eapply_user
eautoreconf
}
src_configure() {
econf \
- $(use_enable pcre) \
- --disable-python-tools
+ $(use_enable pcre)
+ #--disable-python-tools
}
src_compile() {
@@ -133,7 +137,7 @@ src_install() {
# dobin *.rb
#fi
- cd "${S}"
+ #cd "${S}"
emake DESTDIR="${D}" commoninstall
emake DESTDIR="${D}" forceconfigs