summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-06-15 23:18:16 +0200
committerSam James <sam@gentoo.org>2023-06-15 22:32:50 +0100
commit3eeb1d9a9121ddc0d03565f5cef46b0decee7f8c (patch)
tree9c84e24b7b3062934cd0183058f73f3b538f7e7b /net-wireless
parentruby-ng.eclass: add _ruby_get_use_targets comment (diff)
downloadgentoo-3eeb1d9a9121ddc0d03565f5cef46b0decee7f8c.tar.gz
gentoo-3eeb1d9a9121ddc0d03565f5cef46b0decee7f8c.tar.bz2
gentoo-3eeb1d9a9121ddc0d03565f5cef46b0decee7f8c.zip
net-wireless/gnuradio: fixes build with GCC-13
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/31472 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnuradio/files/gnuradio-3.10.6.0-fix-stdint.patch20
-rw-r--r--net-wireless/gnuradio/gnuradio-3.10.4.0-r1.ebuild1
-rw-r--r--net-wireless/gnuradio/gnuradio-3.10.5.1.ebuild1
-rw-r--r--net-wireless/gnuradio/gnuradio-3.10.6.0.ebuild1
4 files changed, 23 insertions, 0 deletions
diff --git a/net-wireless/gnuradio/files/gnuradio-3.10.6.0-fix-stdint.patch b/net-wireless/gnuradio/files/gnuradio-3.10.6.0-fix-stdint.patch
new file mode 100644
index 000000000000..6252d96fd8b5
--- /dev/null
+++ b/net-wireless/gnuradio/files/gnuradio-3.10.6.0-fix-stdint.patch
@@ -0,0 +1,20 @@
+Author: Christian Inci <chris.gh@broke-the-inter.net>
+Date: Mon May 15 21:26:05 2023 +0200
+Upstream: https://github.com/gnuradio/gnuradio/pull/6667
+
+ Include cstdint in gr-fec's alist.h
+
+ GCC 13 will error out otherwise.
+
+ Signed-off-by: Christian Inci <chris.gh@broke-the-inter.net>
+
+--- a/gr-fec/include/gnuradio/fec/alist.h
++++ b/gr-fec/include/gnuradio/fec/alist.h
+@@ -23,6 +23,7 @@
+ #define ALIST_H
+
+ #include <gnuradio/fec/api.h>
++#include <cstdint>
+ #include <cstdlib>
+ #include <fstream>
+ #include <sstream>
diff --git a/net-wireless/gnuradio/gnuradio-3.10.4.0-r1.ebuild b/net-wireless/gnuradio/gnuradio-3.10.4.0-r1.ebuild
index cb4db21dfed5..32e79d5f8f58 100644
--- a/net-wireless/gnuradio/gnuradio-3.10.4.0-r1.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.10.4.0-r1.ebuild
@@ -134,6 +134,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-3.10.3.0-fix-fmt-v9.patch" #858659
"${FILESDIR}/${PN}-3.10.4.0-fix-blockinterleaving.patch"
+ "${FILESDIR}/${PN}-3.10.6.0-fix-stdint.patch"
)
src_prepare() {
diff --git a/net-wireless/gnuradio/gnuradio-3.10.5.1.ebuild b/net-wireless/gnuradio/gnuradio-3.10.5.1.ebuild
index b9ce9c0ab979..6a703292b5ab 100644
--- a/net-wireless/gnuradio/gnuradio-3.10.5.1.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.10.5.1.ebuild
@@ -133,6 +133,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-3.10.3.0-fix-fmt-v9.patch" #858659
+ "${FILESDIR}/${PN}-3.10.6.0-fix-stdint.patch"
)
src_prepare() {
diff --git a/net-wireless/gnuradio/gnuradio-3.10.6.0.ebuild b/net-wireless/gnuradio/gnuradio-3.10.6.0.ebuild
index b9ce9c0ab979..6a703292b5ab 100644
--- a/net-wireless/gnuradio/gnuradio-3.10.6.0.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.10.6.0.ebuild
@@ -133,6 +133,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-3.10.3.0-fix-fmt-v9.patch" #858659
+ "${FILESDIR}/${PN}-3.10.6.0-fix-stdint.patch"
)
src_prepare() {