summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-07 23:10:19 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-08-07 23:10:35 +0000
commit5ee062b8db77303aa3cf55f1619aee66bd6867cc (patch)
tree11481a5a5093e4661f8a6469003fa1ea54db397f /net-wireless
parentnet-libs/libbtbb: bump (diff)
downloadgentoo-5ee062b8db77303aa3cf55f1619aee66bd6867cc.tar.gz
gentoo-5ee062b8db77303aa3cf55f1619aee66bd6867cc.tar.bz2
gentoo-5ee062b8db77303aa3cf55f1619aee66bd6867cc.zip
net-wireless/ubertooth: bump
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/ubertooth/Manifest1
-rw-r--r--net-wireless/ubertooth/ubertooth-2018.08.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-wireless/ubertooth/Manifest b/net-wireless/ubertooth/Manifest
index a40079b50ab7..508e10f460d9 100644
--- a/net-wireless/ubertooth/Manifest
+++ b/net-wireless/ubertooth/Manifest
@@ -1 +1,2 @@
DIST ubertooth-2017-03-R2.tar.xz 676124 BLAKE2B 1f82c9a6b4b2fcec84d5f69862f843ee4920eb0e17e61940aba48e118fe290f67777eed4bd9826c420e218ab433b94630abaf8793c845d2e68ff5587e8b73fbc SHA512 4806a6ac664ec9b78964caeb47f87a60db8f664c529e6e58bc1e5db4d858eaaa1ae51f0293f4a5227a102e556caf1611e97f6675147af4bc34e23646049e8571
+DIST ubertooth-2018-08-R1.tar.xz 701928 BLAKE2B 031d4178693a4c1734f72d5c7292ba58f0c74b9a57cc1841ecdec286d547994847dc7badabc3efce6eff9a34abe505d942b561bc3291b3cda0f29a42fa7dd340 SHA512 630707583b4fa0683d3f2a40e06697546897e603bd27842886897949ffeaff252d3b34040dee6b8b3319f9bed65eb706f57b885d7a6719fc9cb993e7c1d9c203
diff --git a/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild b/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild
new file mode 100644
index 000000000000..1341a9478aa6
--- /dev/null
+++ b/net-wireless/ubertooth/ubertooth-2018.08.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils udev
+
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+bluez static-libs +ubertooth1-firmware +udev"
+
+DEPEND="bluez? ( net-wireless/bluez:= )
+ >=net-libs/libbtbb-${PV}:=[static-libs?]
+ static-libs? ( dev-libs/libusb[static-libs] )
+ virtual/libusb:1="
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/${P}/host"
+else
+ S="${WORKDIR}/${PN}-${MY_PV}/host"
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+DESCRIPTION="open source wireless development platform suitable for Bluetooth experimentation"
+
+#readd firmware building, but do it right
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_BLUEZ=$(usex bluez)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ -DINSTALL_UDEV_RULES=$(usex udev)
+ -DENABLE_PYTHON=false
+ )
+ if use udev; then
+ mycmakeargs+=(
+ -DUDEV_RULES_GROUP=usb
+ -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ insinto /usr/share/${PN}
+ pushd "${WORKDIR}/${PN}-${MY_PV}" || die
+ if [[ ${PV} == "9999" ]] ; then
+ ewarn "Firmware isn't available for git releases, we assume you are already"
+ ewarn "on the latest and/or can build your own."
+ else
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ fi
+ popd
+
+ elog "Everyone can read from the ubertooth, but to talk to it"
+ elog "your user needs to be in the usb group."
+}