summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-01-10 15:44:47 -0500
committerRick Farina <zerochaos@gentoo.org>2020-01-10 15:44:58 -0500
commit7f312872277aa9dbcd755cb5667bdca492e52f6b (patch)
treea204d46ebfd262193240a9cc7cfb108aa7096a38 /net-wireless
parentx11-misc/py3status: version bump (diff)
downloadgentoo-7f312872277aa9dbcd755cb5667bdca492e52f6b.tar.gz
gentoo-7f312872277aa9dbcd755cb5667bdca492e52f6b.tar.bz2
gentoo-7f312872277aa9dbcd755cb5667bdca492e52f6b.zip
net-wireless/wpa_supplicant: sync some changes to live
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index a439dde4108c..f73f675d9fde 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,6 +20,14 @@ fi
SLOT="0"
IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
+# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
+# interface functions used for MACsec, so this combination cannot be used
+# at least for now.
+REQUIRED_USE="
+ macsec? ( !privsep )
+ privsep? ( !macsec )
+"
+
CDEPEND="dbus? ( sys-apps/dbus )
kernel_linux? (
dev-libs/libnl:3
@@ -157,6 +165,7 @@ src_configure() {
Kconfig_style_config EAP_LEAP
Kconfig_style_config EAP_MSCHAPV2
Kconfig_style_config EAP_PEAP
+ Kconfig_style_config EAP_TEAP
Kconfig_style_config EAP_TLS
Kconfig_style_config EAP_TTLS
@@ -235,6 +244,8 @@ src_configure() {
if use smartcard ; then
Kconfig_style_config SMARTCARD
+ else
+ Kconfig_style_config SMARTCARD n
fi
if use tdls ; then
@@ -279,6 +290,13 @@ src_configure() {
Kconfig_style_config WPS_UPNP
# Near Field Communication
Kconfig_style_config WPS_NFC
+ else
+ Kconfig_style_config WPS n
+ Kconfig_style_config WPS2 n
+ Kconfig_style_config WPS_UFD n
+ Kconfig_style_config WPS_ER n
+ Kconfig_style_config WPS_UPNP n
+ Kconfig_style_config WPS_NFC n
fi
# Wi-Fi Direct (WiDi)
@@ -290,6 +308,8 @@ src_configure() {
# Access Point Mode
if use ap ; then
Kconfig_style_config AP
+ else
+ Kconfig_style_config AP n
fi
# Enable essentials for AP/P2P