summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-06-02 22:11:55 -0400
committerRick Farina <zerochaos@gentoo.org>2021-06-02 22:12:05 -0400
commitcb2949a004bc702258b0e83c757f2641eb4e7bad (patch)
tree055e0da5b4603081c9ddabd0bda2278bc7cccbe6 /net-wireless
parentnet-im/telegram-desktop: add patch to fix crash on voice recording (diff)
downloadgentoo-cb2949a004bc702258b0e83c757f2641eb4e7bad.tar.gz
gentoo-cb2949a004bc702258b0e83c757f2641eb4e7bad.tar.bz2
gentoo-cb2949a004bc702258b0e83c757f2641eb4e7bad.zip
net-wireless/uhd: fixes build with boost 1.76.0
fixes bug #743097 for fun Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/uhd/files/uhd-4.0.0.0-boost-1.76.patch59
-rw-r--r--net-wireless/uhd/uhd-4.0.0.0.ebuild7
2 files changed, 63 insertions, 3 deletions
diff --git a/net-wireless/uhd/files/uhd-4.0.0.0-boost-1.76.patch b/net-wireless/uhd/files/uhd-4.0.0.0-boost-1.76.patch
new file mode 100644
index 000000000000..123a01bca56e
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-4.0.0.0-boost-1.76.patch
@@ -0,0 +1,59 @@
+From b05285b3853493436f71eb4192365b818005b0af Mon Sep 17 00:00:00 2001
+From: loqs <loqs@users.noreply.github.com>
+Date: Tue, 25 May 2021 22:43:07 +0100
+Subject: [PATCH] Fix Boost 1.76.0 incompatibility
+
+Fixes EttusResearch/uhd/issues/437
+---
+ host/lib/usrp/cores/rx_dsp_core_3000.cpp | 1 +
+ host/lib/usrp/cores/rx_frontend_core_3000.cpp | 1 +
+ host/lib/usrp/usrp2/usrp2_impl.cpp | 5 ++---
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/lib/usrp/cores/rx_dsp_core_3000.cpp b/host/lib/usrp/cores/rx_dsp_core_3000.cpp
+index ff431fd41..53f3fee69 100644
+--- a/lib/usrp/cores/rx_dsp_core_3000.cpp
++++ b/lib/usrp/cores/rx_dsp_core_3000.cpp
+@@ -14,6 +14,7 @@
+ #include <uhdlib/usrp/cores/rx_dsp_core_3000.hpp>
+ #include <boost/assign/list_of.hpp>
+ #include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
+ #include <algorithm>
+ #include <cmath>
+ #include <functional>
+diff --git a/lib/usrp/cores/rx_frontend_core_3000.cpp b/host/lib/usrp/cores/rx_frontend_core_3000.cpp
+index abbe64b13..d51fea2ca 100644
+--- a/lib/usrp/cores/rx_frontend_core_3000.cpp
++++ b/lib/usrp/cores/rx_frontend_core_3000.cpp
+@@ -12,6 +12,7 @@
+ #include <uhdlib/usrp/cores/rx_frontend_core_3000.hpp>
+ #include <boost/assign/list_of.hpp>
+ #include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
+ #include <functional>
+
+ using namespace uhd;
+diff --git a/lib/usrp/usrp2/usrp2_impl.cpp b/host/lib/usrp/usrp2/usrp2_impl.cpp
+index c2514ae02..28aa11083 100644
+--- a/lib/usrp/usrp2/usrp2_impl.cpp
++++ b/lib/usrp/usrp2/usrp2_impl.cpp
+@@ -17,6 +17,8 @@
+ #include <uhdlib/usrp/common/apply_corrections.hpp>
+ #include <boost/asio.hpp> //used for htonl and ntohl
+ #include <boost/asio/ip/address_v4.hpp>
++#include <boost/math/special_functions/round.hpp>
++#include <boost/math/special_functions/sign.hpp>
+ #include <boost/format.hpp>
+ #include <boost/thread.hpp>
+ #include <functional>
+@@ -948,9 +950,6 @@ meta_range_t usrp2_impl::get_tx_dsp_freq_range(const std::string& mb)
+ return meta_range_t(-dac_rate / 2, +dac_rate / 2, dsp_range_step);
+ }
+
+-#include <boost/math/special_functions/round.hpp>
+-#include <boost/math/special_functions/sign.hpp>
+-
+ void usrp2_impl::update_clock_source(const std::string& mb, const std::string& source)
+ {
+ // NOTICE: U2_REG_MISC_CTRL_CLOCK is on the wb clock, and cannot be set from fifo_ctrl
diff --git a/net-wireless/uhd/uhd-4.0.0.0.ebuild b/net-wireless/uhd/uhd-4.0.0.0.ebuild
index 25a3b44949ee..2515af186bab 100644
--- a/net-wireless/uhd/uhd-4.0.0.0.ebuild
+++ b/net-wireless/uhd/uhd-4.0.0.0.ebuild
@@ -48,7 +48,10 @@ DEPEND="${RDEPEND}
app-arch/gzip
"
-PATCHES=( "${FILESDIR}/${PN}-4.0.0.0-tinfo.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.0.0-tinfo.patch"
+ "${FILESDIR}/${PN}-4.0.0.0-boost-1.76.patch"
+)
S="${WORKDIR}/${P}/host"
@@ -70,7 +73,6 @@ src_configure() {
mycmakeargs=(
-DENABLE_LIBUHD=ON
-DENABLE_C_API=ON
- -DENABLE_LIBERIO=OFF
-DENABLE_MAN_PAGES=ON
-DENABLE_MAN_PAGE_COMPRESSION=OFF
-DENABLE_EXAMPLES="$(usex examples)"
@@ -85,7 +87,6 @@ src_configure() {
-DENABLE_USRP1="$(usex usrp1)"
-DENABLE_USRP2="$(usex usrp2)"
-DENABLE_X300="$(usex x300)"
- -DENABLE_N230="$(usex n230)"
-DENABLE_MPMD="$(usex mpmd)"
-DENABLE_OCTOCLOCK="$(usex octoclock)"
-DPYTHON_EXECUTABLE="${PYTHON}"