summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-10 11:16:49 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 11:18:08 +0100
commite86b0dc6db7cbcb250c4010c148ab5df312d62ca (patch)
tree2b3db0dab74241cf481c3c2b463857d19f8f09bf /net-wireless
parentsys-firmware/iwl6030-ucode: Bump to EAPI 7 (diff)
downloadgentoo-e86b0dc6db7cbcb250c4010c148ab5df312d62ca.tar.gz
gentoo-e86b0dc6db7cbcb250c4010c148ab5df312d62ca.tar.bz2
gentoo-e86b0dc6db7cbcb250c4010c148ab5df312d62ca.zip
net-wireless/bcm43xx-fwcutter: Bump to EAPI 7
Bug: https://bugs.gentoo.org/697232 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bcm43xx-fwcutter/bcm43xx-fwcutter-006.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-wireless/bcm43xx-fwcutter/bcm43xx-fwcutter-006.ebuild b/net-wireless/bcm43xx-fwcutter/bcm43xx-fwcutter-006.ebuild
index 0cf29ec49d4a..de0ef52c8c2f 100644
--- a/net-wireless/bcm43xx-fwcutter/bcm43xx-fwcutter-006.ebuild
+++ b/net-wireless/bcm43xx-fwcutter/bcm43xx-fwcutter-006.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
@@ -10,13 +10,13 @@ HOMEPAGE="http://bcm43xx.berlios.de"
#SRC_URI="mirror://berlios/bcm43xx/${P}.tar.bz2"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ppc ~ppc64 ~x86"
IUSE=""
src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+ emake CC="$(tc-getCC)"
}
src_install() {
@@ -27,15 +27,13 @@ src_install() {
}
pkg_postinst() {
- if ! [ -f /lib/firmware/${PN}_microcode2.fw ]; then
- echo
- einfo "You'll need to use bcm43xx-fwcutter to install the bcm43xx firmware."
- einfo "Please read the bcm43xx-fwcutter readme for more details:"
- einfo "README in /usr/share/doc/${P}"
- echo
+ if [[ ! -f ${EROOT}/lib/firmware/${PN}_microcode2.fw ]]; then
+ elog "You'll need to use bcm43xx-fwcutter to install the bcm43xx firmware."
+ elog "Please read the bcm43xx-fwcutter readme for more details:"
+ elog "README in /usr/share/doc/${PF}"
+ elog
fi
- einfo "Please read this forum thread for help and troubleshooting:"
- einfo "https://forums.gentoo.org/viewtopic-t-409194.html"
- echo
+ elog "Please read this forum thread for help and troubleshooting:"
+ elog "https://forums.gentoo.org/viewtopic-t-409194.html"
}