summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-02-22 15:42:30 -0500
committerRick Farina <zerochaos@gentoo.org>2023-02-22 15:44:36 -0500
commiteac4803723e269b65bed0847b3e57924d347d340 (patch)
treebe7b8bedd6d21a0aca9479f25e753472845b6753 /net-wireless
parentnet-wireless/spectools: fix deps (diff)
downloadgentoo-eac4803723e269b65bed0847b3e57924d347d340.tar.gz
gentoo-eac4803723e269b65bed0847b3e57924d347d340.tar.bz2
gentoo-eac4803723e269b65bed0847b3e57924d347d340.zip
net-wireless/kismet: fixup deps
Adjust deps per qa tools Remove do nothing sed lines Use bundled libfmt Closes: https://bugs.gentoo.org/872608 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet/files/kismet-2022.08.1-sandbox-fix.patch147
-rw-r--r--net-wireless/kismet/kismet-2022.08.1-r2.ebuild208
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild32
3 files changed, 369 insertions, 18 deletions
diff --git a/net-wireless/kismet/files/kismet-2022.08.1-sandbox-fix.patch b/net-wireless/kismet/files/kismet-2022.08.1-sandbox-fix.patch
new file mode 100644
index 000000000000..358475cbc194
--- /dev/null
+++ b/net-wireless/kismet/files/kismet-2022.08.1-sandbox-fix.patch
@@ -0,0 +1,147 @@
+From 8264835a935de9c754c0ff28c632695103b2dc2f Mon Sep 17 00:00:00 2001
+From: Mike Kershaw / Dragorn <dragorn@kismetwireless.net>
+Date: Fri, 6 Jan 2023 15:22:52 -0500
+Subject: [PATCH] python: Merge patch from Rick Farina / Zero_Chaos to make
+ gentoo not complain about python build parameters
+
+---
+ capture_bt_geiger/Makefile.in | 4 +++-
+ capture_freaklabs_zigbee/Makefile.in | 4 +++-
+ capture_proxy_adsb/Makefile.in | 4 +++-
+ capture_sdr_rtl433/Makefile.in | 4 +++-
+ capture_sdr_rtladsb/Makefile.in | 4 +++-
+ capture_sdr_rtlamr/Makefile.in | 4 +++-
+ 6 files changed, 18 insertions(+), 6 deletions(-)
+
+diff --git a/capture_bt_geiger/Makefile.in b/capture_bt_geiger/Makefile.in
+index 646069fed..4f644535b 100644
+--- a/capture_bt_geiger/Makefile.in
++++ b/capture_bt_geiger/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -19,7 +21,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
+diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
+index 646069fed..4f644535b 100644
+--- a/capture_freaklabs_zigbee/Makefile.in
++++ b/capture_freaklabs_zigbee/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -19,7 +21,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
+diff --git a/capture_proxy_adsb/Makefile.in b/capture_proxy_adsb/Makefile.in
+index d16ba601f..96ba6ceca 100644
+--- a/capture_proxy_adsb/Makefile.in
++++ b/capture_proxy_adsb/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -22,7 +24,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
+diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
+index 646069fed..4f644535b 100644
+--- a/capture_sdr_rtl433/Makefile.in
++++ b/capture_sdr_rtl433/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -19,7 +21,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
+diff --git a/capture_sdr_rtladsb/Makefile.in b/capture_sdr_rtladsb/Makefile.in
+index d16ba601f..96ba6ceca 100644
+--- a/capture_sdr_rtladsb/Makefile.in
++++ b/capture_sdr_rtladsb/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -22,7 +24,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
+diff --git a/capture_sdr_rtlamr/Makefile.in b/capture_sdr_rtlamr/Makefile.in
+index 646069fed..4f644535b 100644
+--- a/capture_sdr_rtlamr/Makefile.in
++++ b/capture_sdr_rtlamr/Makefile.in
+@@ -2,6 +2,8 @@ KIS_SRC_DIR ?= ..
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
++DESTDIR ?= /
++
+ DATASOURCE_NAME := $(shell $(PYTHON) setup.py --name)
+
+ PROTOBUF_DIR = $(KIS_SRC_DIR)/protobuf_definitions
+@@ -19,7 +21,7 @@ $(DATASOURCE_NAME)/kismetexternal/%_pb2.py: $(PROTOBUF_DIR)/%.proto
+ sed -i -E 's/^import kismet_/from . import kismet_/' $@
+
+ install:
+- $(PYTHON) setup.py install --root="/$(DESTDIR)" --prefix="$(prefix)"
++ $(PYTHON) setup.py install --root="$(DESTDIR)" --prefix="$(prefix)"
+
+ clean:
+ @-$(PYTHON) setup.py clean
diff --git a/net-wireless/kismet/kismet-2022.08.1-r2.ebuild b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
new file mode 100644
index 000000000000..fe8f8bc10d3c
--- /dev/null
+++ b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools python-single-r1 udev systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
+ inherit git-r3
+ RESTRICT="strip"
+else
+ MY_P=${P/\./-}
+ MY_P=${MY_P/_beta/-BETA}
+ MY_P=${MY_P/./-R}
+ S=${WORKDIR}/${MY_P/BETA/beta}
+
+ #normally we want an official release
+ SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
+
+ #but sometimes we want a git commit
+ #COMMIT="9ca7e469cf115469f392db7436816151867e1654"
+ #SRC_URI="https://github.com/kismetwireless/kismet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}/${PN}-${COMMIT}"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+fi
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
+HOMEPAGE="https://www.kismetwireless.net"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="libusb lm-sensors networkmanager +pcre rtlsdr selinux +suid ubertooth udev"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+ acct-user/kismet
+ acct-group/kismet
+ networkmanager? ( net-misc/networkmanager )
+ dev-libs/glib:2
+ dev-libs/elfutils
+ sys-libs/zlib:=
+ dev-db/sqlite:3
+ net-libs/libwebsockets:=[client,lejp]
+ kernel_linux? ( sys-libs/libcap
+ dev-libs/libnl:3
+ net-libs/libpcap
+ )
+ libusb? ( virtual/libusb:1 )
+ dev-libs/protobuf-c:=
+ dev-libs/protobuf:=
+ $(python_gen_cond_dep '
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ ')
+ lm-sensors? ( sys-apps/lm-sensors:= )
+ pcre? ( dev-libs/libpcre )
+ suid? ( sys-libs/libcap )
+ ubertooth? ( net-wireless/ubertooth )
+ "
+RDEPEND="${CDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ ')
+ rtlsdr? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ net-wireless/rtl-sdr
+ )
+ selinux? ( sec-policy/selinux-kismet )
+"
+#switched back to bundled libfmt-8
+#https://bugs.gentoo.org/895252
+#<dev-libs/libfmt-9
+DEPEND="${CDEPEND}
+ dev-libs/boost
+ sys-libs/libcap
+"
+BDEPEND="virtual/pkgconfig"
+
+# https://bugs.gentoo.org/872608
+# drop after 2022.08*
+PATCHES=( "${FILESDIR}/${P}-sandbox-fix.patch" )
+
+src_prepare() {
+ #sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+ # conf/kismet_logging.conf || die
+
+ #this was added to quiet macosx builds but it makes gcc builds noisier
+ sed -i -e 's#-Wno-unknown-warning-option ##g' Makefile.inc.in || die
+
+ #sed -i -e 's#root#kismet#g' packaging/systemd/kismet.service.in
+
+ rm -r boost || die
+ #switched back to bundled libfmt-8
+ #https://bugs.gentoo.org/895252
+ #rm -r fmt || die
+
+ #dev-libs/jsoncpp
+ #rm -r json || die
+ #sed -i 's#"json/json.h"#<json/json.h>#' jsoncpp.cc kis_net_beast_httpd.h \
+ # log_tools/kismetdb_clean.cc log_tools/kismetdb_dump_devices.cc \
+ # log_tools/kismetdb_statistics.cc log_tools/kismetdb_to_gpx.cc \
+ # log_tools/kismetdb_to_kml.cc log_tools/kismetdb_to_pcap.cc \
+ # log_tools/kismetdb_to_wiglecsv.cc trackedcomponent.h \
+ # trackedelement.h trackedelement_workers.h
+
+ eapply_user
+
+ if [ "${PV}" = "9999" ]; then
+ eautoreconf
+ fi
+ # drop after 2022.08*
+ # VERSION was incorrectly removed in 4e490cf0b49a287e964df9c5e5c4067f6918909e upstream
+ # https://github.com/kismetwireless/kismet/issues/427
+ # https://bugs.gentoo.org/864298
+ echo "${PV}" > VERSION
+}
+
+src_configure() {
+ econf \
+ $(use_enable libusb libusb) \
+ $(use_enable pcre) \
+ $(use_enable lm-sensors lmsensors) \
+ $(use_enable networkmanager libnm) \
+ $(use_enable ubertooth) \
+ --sysconfdir=/etc/kismet \
+ --disable-optimization
+}
+
+src_install() {
+ emake DESTDIR="${D}" commoninstall
+ python_optimize
+ emake DESTDIR="${D}" forceconfigs
+ use udev && udev_dorules packaging/udev/*.rules
+
+ insinto /usr/share/${PN}
+ doins Makefile.inc
+ if [ "${PV}" = "9999" ];then
+ doins "${FILESDIR}"/gdb
+ dobin "${FILESDIR}"/kismet-gdb
+ fi
+
+ dodoc README*
+ newinitd "${FILESDIR}"/${PN}.initd-r3 kismet
+ newconfd "${FILESDIR}"/${PN}.confd-r2 kismet
+ systemd_dounit packaging/systemd/kismet.service
+}
+
+pkg_preinst() {
+ if use suid; then
+ fowners root:kismet /usr/bin/kismet_cap_linux_bluetooth
+ fowners root:kismet /usr/bin/kismet_cap_linux_wifi
+ fowners root:kismet /usr/bin/kismet_cap_pcapfile
+ # Need to set the permissions after chowning.
+ # See chown(2)
+ fperms 4550 /usr/bin/kismet_cap_linux_bluetooth
+ fperms 4550 /usr/bin/kismet_cap_linux_wifi
+ fperms 4550 /usr/bin/kismet_cap_pcapfile
+ elog "Kismet has been installed with a setuid-root helper binary"
+ elog "to enable minimal-root operation. Users need to be part of"
+ elog "the 'kismet' group to perform captures from physical devices."
+ fi
+ if ! use suid; then
+ ewarn "It is highly discouraged to run a sniffer as root,"
+ ewarn "Please consider enabling the suid use flag and adding"
+ ewarn "your user to the kismet group."
+ fi
+}
+
+migrate_config() {
+ einfo "Kismet Configuration files are now read from /etc/kismet/"
+ ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
+ if [ -n "$(ls "${EROOT}"/etc/kismet_*.conf 2> /dev/null)" ]; then
+ ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
+ fi
+ if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
+ mv /etc/kismet_site.conf /etc/kismet/kismet_site.conf || die "Failed to migrate kismet_site.conf to new location"
+ ewarn "Your /etc/kismet_site.conf file has been automatically moved to /etc/kismet/kismet_site.conf"
+ elif [ -f "${EROOT}/etc/kismet_site.conf" ] && [ -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
+ ewarn "Both /etc/kismet_site.conf and /etc/kismet/kismet_site.conf exist, please migrate needed bits"
+ ewarn "into /etc/kismet/kismet_site.conf and remove /etc/kismet_site.conf"
+ fi
+}
+
+pkg_postinst() {
+ if [ -n "${REPLACING_VERSIONS}" ]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test ${v} -lt 2019.07.2 ; then
+ migrate_config
+ break
+ fi
+ if ver_test ${v} -eq 9999 ; then
+ migrate_config
+ break
+ fi
+ done
+ fi
+ udev_reload
+}
+pkg_postrm() {
+ udev_reload
+}
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index c9e0a62e9649..913097640161 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit autotools python-single-r1 udev systemd
@@ -40,13 +40,12 @@ CDEPEND="
${PYTHON_DEPS}
acct-user/kismet
acct-group/kismet
- networkmanager? ( net-misc/networkmanager:= )
- dev-libs/glib:=
- dev-libs/elfutils:=
+ networkmanager? ( net-misc/networkmanager )
+ dev-libs/glib:2
+ dev-libs/elfutils
dev-libs/openssl:=
sys-libs/zlib:=
- dev-db/sqlite:=
- net-libs/libmicrohttpd:=
+ dev-db/sqlite:3
net-libs/libwebsockets:=[client,lejp]
kernel_linux? ( sys-libs/libcap
dev-libs/libnl:3
@@ -59,7 +58,6 @@ CDEPEND="
dev-python/protobuf-python[${PYTHON_USEDEP}]
dev-python/websockets[${PYTHON_USEDEP}]
')
- sys-libs/ncurses:=
lm-sensors? ( sys-apps/lm-sensors:= )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
@@ -77,15 +75,18 @@ RDEPEND="${CDEPEND}
)
selinux? ( sec-policy/selinux-kismet )
"
+#switched back to bundled libfmt-8
+#https://bugs.gentoo.org/895252
+#<dev-libs/libfmt-9
DEPEND="${CDEPEND}
dev-libs/boost
- <dev-libs/libfmt-9
+ sys-libs/libcap
"
BDEPEND="virtual/pkgconfig"
src_prepare() {
- sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
- conf/kismet_logging.conf || die
+ #sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+ # conf/kismet_logging.conf || die
#this was added to quiet macosx builds but it makes gcc builds noisier
sed -i -e 's#-Wno-unknown-warning-option ##g' Makefile.inc.in || die
@@ -93,7 +94,9 @@ src_prepare() {
#sed -i -e 's#root#kismet#g' packaging/systemd/kismet.service.in
rm -r boost || die
- rm -r fmt || die
+ #switched back to bundled libfmt-8
+ #https://bugs.gentoo.org/895252
+ #rm -r fmt || die
#dev-libs/jsoncpp
#rm -r json || die
@@ -107,15 +110,8 @@ src_prepare() {
eapply_user
if [ "${PV}" = "9999" ]; then
- sed -i -e 's|@mangrp@|root|g' Makefile.inc.in || die
eautoreconf
- else
- sed -i -e 's|@mangrp@|root|g' Makefile.inc || die
fi
- # VERSION was incorrectly removed in 4e490cf0b49a287e964df9c5e5c4067f6918909e upstream
- # https://github.com/kismetwireless/kismet/issues/427
- # https://bugs.gentoo.org/864298
- echo "${PV}" > VERSION
}
src_configure() {