summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-26 06:17:27 +0100
committerSam James <sam@gentoo.org>2022-06-26 06:25:07 +0100
commit23a1ebc4b2c0fe1837fc66b271d7b4a5826a158d (patch)
tree5b6fbd2909209114ead1732b371a01752eb1208f /perl-core/Compress-Raw-Zlib
parentsys-fs/zfs-auto-snapshot: patch out which dep (diff)
downloadgentoo-23a1ebc4b2c0fe1837fc66b271d7b4a5826a158d.tar.gz
gentoo-23a1ebc4b2c0fe1837fc66b271d7b4a5826a158d.tar.bz2
gentoo-23a1ebc4b2c0fe1837fc66b271d7b4a5826a158d.zip
perl-core/Compress-Raw-Zlib: new package, add 2.201.0
Fixes test failures on musl. Restored based on 6b1b54851d9b8525f5981592138dc35ca6d2380a. Bug: https://github.com/pmqs/Compress-Raw-Zlib/issues/12 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.201.0.ebuild31
-rw-r--r--perl-core/Compress-Raw-Zlib/Manifest1
-rw-r--r--perl-core/Compress-Raw-Zlib/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.201.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.201.0.ebuild
new file mode 100644
index 000000000000..cb39422f2c42
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.201.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_TEST=parallel
+DIST_VERSION=2.201
+inherit perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# We use the bundled version of zlib as the minimum version for the system copy
+# Check on bumps! Look in https://github.com/pmqs/Compress-Raw-Zlib/commits/master/zlib-src.
+RDEPEND=">=sys-libs/zlib-1.2.12"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False ZLIB_INCLUDE="${ESYSROOT}"/usr/include \
+ ZLIB_LIB="${ESYSROOT}"/usr/$(get_libdir) perl-module_src_configure
+}
diff --git a/perl-core/Compress-Raw-Zlib/Manifest b/perl-core/Compress-Raw-Zlib/Manifest
new file mode 100644
index 000000000000..65da62873b24
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Manifest
@@ -0,0 +1 @@
+DIST Compress-Raw-Zlib-2.201.tar.gz 480467 BLAKE2B e2c706447cdd82c712b0613da69903adb3e9f51dd3e791bea51c836a767ca1df03f18870d377fea20af5f5ffb074925b0a70c80ef507622264d21b657bda4ea2 SHA512 1262f5be347e1efe71f0308385a5b8b927854b1e061d69d9a38c74e6dfacf2ffbec0891bdeb76092de28a5049e1fd1eb3e784e0570b34612a8256d955d7f1ab7
diff --git a/perl-core/Compress-Raw-Zlib/metadata.xml b/perl-core/Compress-Raw-Zlib/metadata.xml
new file mode 100644
index 000000000000..7154c6b2e8d4
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Compress-Raw-Zlib</remote-id>
+ <remote-id type="cpan-module">Compress::Raw::Zlib</remote-id>
+ </upstream>
+</pkgmetadata>