summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-19 02:13:05 +0100
committerSam James <sam@gentoo.org>2023-09-19 06:24:47 +0100
commitc13dc7384923184292df961d24d5f82fbd123873 (patch)
tree8f4c898902b06b8b51ad00587940bdec4e2f3d61 /perl-core
parentnet-misc/ipcalc: style tweaks (diff)
downloadgentoo-c13dc7384923184292df961d24d5f82fbd123873.tar.gz
gentoo-c13dc7384923184292df961d24d5f82fbd123873.tar.bz2
gentoo-c13dc7384923184292df961d24d5f82fbd123873.zip
perl-core/Math-BigInt: new package, add 1.999.838
Fished out from 43f46bf3bb3a914898b04cb0a29736849d8f094a. Bug: https://bugs.gentoo.org/914392 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Math-BigInt/Manifest1
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild36
-rw-r--r--perl-core/Math-BigInt/metadata.xml16
3 files changed, 53 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
new file mode 100644
index 000000000000..2c0bac6dd700
--- /dev/null
+++ b/perl-core/Math-BigInt/Manifest
@@ -0,0 +1 @@
+DIST Math-BigInt-1.999838.tar.gz 2870131 BLAKE2B 749e0b04175070a571dd749c99b3558ce7bce442ee800eb227d952723bfd09b588c8ce6f3ddd2d2b71e8c89dbd2be80ac1272f9725a7bc435db77fa2f4ffac15 SHA512 33beb52f3e952d78e637336e61522416256029cdd106bab1a8b7d26a0b0f6aee16b779819b6922e99ccd3d67b14766ed661b2dec39dd9b31da4608df4fbe548f
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
new file mode 100644
index 000000000000..aebb9315936f
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999838
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-Complex-1.390.0
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+# TODO: where does this come from?
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.500.600
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}
diff --git a/perl-core/Math-BigInt/metadata.xml b/perl-core/Math-BigInt/metadata.xml
new file mode 100644
index 000000000000..36405a484b9b
--- /dev/null
+++ b/perl-core/Math-BigInt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigFloat</remote-id>
+ <remote-id type="cpan-module">Math::BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Calc</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::CalcEmu</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Lib</remote-id>
+ </upstream>
+</pkgmetadata>