summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2018-08-30 15:29:41 +0800
committerBenda Xu <heroxbd@gentoo.org>2018-08-30 15:33:37 +0800
commit085f50f00ae2751c88eaba887e20b4e5808345f7 (patch)
treefa6a53cf5a19e059a88ea4f8468373add70c301a /profiles/features/prefix
parentsparc/package.use.mask: mask app-office/scribus[osg], bug #550040 (diff)
downloadgentoo-085f50f00ae2751c88eaba887e20b4e5808345f7.tar.gz
gentoo-085f50f00ae2751c88eaba887e20b4e5808345f7.tar.bz2
gentoo-085f50f00ae2751c88eaba887e20b4e5808345f7.zip
p/f/p/s/kernel-2.6.16+/profile.bashrc: glibc to be well to linux-2.6.16.
F_DUPFD_CLOEXEC is available from linux-2.6.24. pipe2 and dup3 is introduced in linux-2.6.27.
Diffstat (limited to 'profiles/features/prefix')
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc15
1 files changed, 11 insertions, 4 deletions
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
index eeba17808ece..0fc68db876ab 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
@@ -2,15 +2,22 @@
if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing utimensat outputs..."
- sed -e '/UTIMENSAT=/d' -i ${S}/Source/kwsys/CMakeLists.txt || die
+ sed -e '/UTIMENSAT=/d' -i "${S}"/Source/kwsys/CMakeLists.txt || die
elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing pipe2 definitions..."
- sed -e '/define.*HAVE_PIPE2/d' -i ${S}/src/3rdparty/forkfd/forkfd.c || die
+ sed -e '/define.*HAVE_PIPE2/d' -i "${S}"/src/3rdparty/forkfd/forkfd.c || die
einfo "Removing utimensat calls..."
- sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i ${S}/qmake/library/ioutils.cpp || die
+ sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i "${S}"/qmake/library/ioutils.cpp || die
elif [[ ${CATEGORY}/${PN} == dev-lang/ocaml && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing dup3 and pipe2 definitions..."
- sed -e '/hasgot dup3/,/^fi/d;/hasgot pipe2/,/^fi/d' -i ${S}/configure || die
+ sed -e '/hasgot dup3/,/^fi/d;/hasgot pipe2/,/^fi/d' -i "${S}"/configure || die
+elif [[ ${CATEGORY}/${PN} == sys-libs/glibc && ${EBUILD_PHASE} == compile ]]; then
+ einfo "Removing F_DUPFD_CLOEXEC definitions..."
+ sed -e '/define.*F_DUPFD_CLOEXEC/,/*\//d' -i "${S}"/sysdeps/unix/sysv/linux/bits/fcntl-linux.h || die
+ einfo "Removing pipe2 definitions..."
+ sed -e '/^extern int pipe2/d' -i "${S}"/posix/unistd.h || die
+ einfo "Removing epoll_create1 definitions..."
+ sed -e '/^extern int epoll_create1/d' -i "${S}"/sysdeps/unix/sysv/linux/sys/epoll.h || die
fi
# Local Variables: