summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2018-08-18 14:35:12 +0900
committerBenda Xu <heroxbd@gentoo.org>2018-08-18 14:37:23 +0900
commit94b0c25e55cf4477438ddca4884589421748c428 (patch)
treec9f7dbd43a432ee2783f90cc63d78d0339f0ce76 /profiles/features
parentprofiles/arch/s390: mask media-gfx/imagemagick[raw] (diff)
downloadgentoo-94b0c25e55cf4477438ddca4884589421748c428.tar.gz
gentoo-94b0c25e55cf4477438ddca4884589421748c428.tar.bz2
gentoo-94b0c25e55cf4477438ddca4884589421748c428.zip
p/f/p/s/kernel-2.6.16+/profile.bashrc: disable pipe2, utimensat
qtcore incorrectly uses kernel features without testing. Fix it.
Diffstat (limited to 'profiles/features')
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc11
1 files changed, 10 insertions, 1 deletions
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
index e537cc0fa319..fb926138685d 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
@@ -2,5 +2,14 @@
if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing utimensat outputs..."
- sed -i '/UTIMENSAT=/d' ${S}/Source/kwsys/CMakeLists.txt
+ sed -e '/UTIMENSAT=/d' -i ${S}/Source/kwsys/CMakeLists.txt || die
+elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
+ einfo "Removing pipe2 definitions..."
+ sed -e '/define.*HAVE_PIPE2/d' -i ${S}/src/3rdparty/forkfd/forkfd.c || die
+ einfo "Removing utimensat calls..."
+ sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i ${S}/qmake/library/ioutils.cpp || die
fi
+
+# Local Variables:
+# mode: shell-script
+# End: