summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:57:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:57:09 +0200
commitf2121d30941fd130636f28d0e1b1c95fdf1985a6 (patch)
treea4e381d060cfefdc76a3aa500065f9b0ca0deeda /ros-meta/desktop/desktop-9999.ebuild
parentros-meta/visualization_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-f2121d30941fd130636f28d0e1b1c95fdf1985a6.tar.gz
gentoo-f2121d30941fd130636f28d0e1b1c95fdf1985a6.tar.bz2
gentoo-f2121d30941fd130636f28d0e1b1c95fdf1985a6.zip
ros-meta/desktop: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/desktop/desktop-9999.ebuild')
-rw-r--r--ros-meta/desktop/desktop-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/ros-meta/desktop/desktop-9999.ebuild b/ros-meta/desktop/desktop-9999.ebuild
new file mode 100644
index 000000000000..9eabc1401fbd
--- /dev/null
+++ b/ros-meta/desktop/desktop-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for a basic ROS desktop install"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/robot
+ ros-meta/viz
+ dev-ros/roslint
+ ros-meta/rqt_common_plugins
+ ros-meta/rqt_robot_plugins
+ dev-ros/urdf_tutorial
+ ros-meta/visualization_tutorials
+"
+DEPEND="${RDEPEND}"