summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-13 12:42:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:57 +0200
commitcb7b056d9da4efabc8bdba57b8b9901488165d00 (patch)
tree619e852b122859f2d7aba559eca441a3aacec63a /ros-meta/ros_core/ros_core-1.4.0.ebuild
parentros-meta/ros_base: bump to 1.4.0 (diff)
downloadgentoo-cb7b056d9da4efabc8bdba57b8b9901488165d00.tar.gz
gentoo-cb7b056d9da4efabc8bdba57b8b9901488165d00.tar.bz2
gentoo-cb7b056d9da4efabc8bdba57b8b9901488165d00.zip
ros-meta/ros_core: bump to 1.4.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'ros-meta/ros_core/ros_core-1.4.0.ebuild')
-rw-r--r--ros-meta/ros_core/ros_core-1.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/ros-meta/ros_core/ros_core-1.4.0.ebuild b/ros-meta/ros_core/ros_core-1.4.0.ebuild
new file mode 100644
index 000000000000..ebd39617e81e
--- /dev/null
+++ b/ros-meta/ros_core/ros_core-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage to aggregate the packages required to use core ROS concepts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-util/catkin
+ dev-ros/cmake_modules
+ ros-meta/common_msgs
+ dev-ros/gencpp
+ dev-ros/geneus
+ dev-ros/genlisp
+ dev-ros/genmsg
+ dev-ros/gennodejs
+ dev-ros/genpy
+ dev-ros/message_generation
+ dev-ros/message_runtime
+ ros-meta/ros
+ ros-meta/ros_comm
+ dev-ros/rosbag_migration_rule
+ dev-ros/rosconsole_bridge
+ ros-meta/roscpp_core
+ dev-ros/rosgraph_msgs
+ dev-ros/roslisp
+ dev-ros/rospack
+ dev-ros/std_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"