summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:37:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:37:59 +0200
commit62755d6bc89711f01641d89315a72548a3aed568 (patch)
tree2e2ec9bc6254e94daded1bc805fcd5c64fb687e9 /ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild
parentdev-ros/rqt_tf_tree: Initial import. Ebuild by me. (diff)
downloadgentoo-62755d6bc89711f01641d89315a72548a3aed568.tar.gz
gentoo-62755d6bc89711f01641d89315a72548a3aed568.tar.bz2
gentoo-62755d6bc89711f01641d89315a72548a3aed568.zip
ros-meta/rqt_robot_plugins: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild')
-rw-r--r--ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild b/ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild
new file mode 100644
index 000000000000..9b478ab610d4
--- /dev/null
+++ b/ros-meta/rqt_robot_plugins/rqt_robot_plugins-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage of rqt plugins that are particularly used with robots during its operation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rqt_moveit
+ dev-ros/rqt_nav_view
+ dev-ros/rqt_pose_view
+ dev-ros/rqt_robot_dashboard
+ dev-ros/rqt_robot_monitor
+ dev-ros/rqt_robot_steering
+ dev-ros/rqt_runtime_monitor
+ dev-ros/rqt_rviz
+ dev-ros/rqt_tf_tree
+"
+DEPEND="${RDEPEND}"