summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/cpl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/cpl/files')
-rw-r--r--sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch35
-rw-r--r--sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch46
2 files changed, 81 insertions, 0 deletions
diff --git a/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch b/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch
new file mode 100644
index 000000000000..658f2eaefb9e
--- /dev/null
+++ b/sci-astronomy/cpl/files/cpl-6.1.1-check-shared-libs.patch
@@ -0,0 +1,35 @@
+Check shared library instead of static ones.
+bicatali@gentoo.org
+
+diff -Nur cpl-6.1.1.orig/m4/cpl.m4 cpl-6.1.1/m4/cpl.m4
+--- cpl-6.1.1.orig/m4/cpl.m4 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/m4/cpl.m4 2012-06-04 18:46:37.000000000 +0100
+@@ -8,7 +8,7 @@
+
+ cpl_cfitsio_check_version="$1"
+ cpl_cfitsio_check_header="fitsio.h"
+- cpl_cfitsio_check_lib="libcfitsio.a"
++ cpl_cfitsio_check_lib="libcfitsio.so"
+
+ cpl_cfitsio_incdirs=""
+ cpl_cfitsio_libdirs=""
+@@ -668,7 +668,7 @@
+
+ cpl_wcs_check_version="$1"
+ cpl_wcs_check_header="wcslib/wcslib.h"
+- cpl_wcs_check_lib="libwcs.a"
++ cpl_wcs_check_lib="libwcs.so"
+
+ cpl_wcs_includes=""
+ cpl_wcs_libraries=""
+@@ -900,8 +900,8 @@
+
+ cpl_fftw_check_version="$1"
+ cpl_fftw_check_header="fftw3.h"
+- cpl_fftw_check_lib="libfftw3.a"
+- cpl_fftwf_check_lib="libfftw3f.a"
++ cpl_fftw_check_lib="libfftw3.so"
++ cpl_fftwf_check_lib="libfftw3f.so"
+
+ cpl_fftw_includes=""
+ cpl_fftw_libraries=""
diff --git a/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch b/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch
new file mode 100644
index 000000000000..a0c23a75d38c
--- /dev/null
+++ b/sci-astronomy/cpl/files/cpl-6.1.1-use-system-ltdl.patch
@@ -0,0 +1,46 @@
+use system libtdl from libtool instead of bundled one
+see http://www.flameeyes.eu/autotools-mythbuster/libtool/plugins.html
+bicatali@gentoo.org
+
+diff -Nur cpl-6.1.1.orig/configure.ac cpl-6.1.1/configure.ac
+--- cpl-6.1.1.orig/configure.ac 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/configure.ac 2012-06-04 22:14:23.000000000 +0100
+@@ -60,8 +60,12 @@
+ AC_ENABLE_STATIC(yes)
+ AC_ENABLE_SHARED(yes)
+
+-AC_LIBLTDL_CONVENIENCE
+-AC_PROG_LIBTOOL
++LT_INIT([dlopen])
++AC_CHECK_HEADER([ltdl.h],
++ [AC_CHECK_LIB([ltdl], [lt_dladvise_init],
++ [LIBLTDL=-lltdl], [LIBLTDL=])],
++ [LIBLTDL=])
++
+ AC_SUBST(INCLTDL)
+ AC_SUBST(LIBLTDL)
+ AC_SUBST(LIBTOOL_DEPS)
+@@ -131,7 +135,6 @@
+ CPL_CONFIG_FUNC
+
+ # Configure subpackages
+-AC_CONFIG_SUBDIRS(libltdl)
+
+ if test ! x$"cpl_cv_with_system_cext" = xyes; then
+ AC_CONFIG_SUBDIRS([libcext])
+diff -Nur cpl-6.1.1.orig/Makefile.am cpl-6.1.1/Makefile.am
+--- cpl-6.1.1.orig/Makefile.am 2012-06-04 18:38:01.000000000 +0100
++++ cpl-6.1.1/Makefile.am 2012-06-04 19:07:41.000000000 +0100
+@@ -25,11 +25,10 @@
+ DISTCLEANFILES = *~
+
+ if GASGANO_SUPPORT
+-libltdl = libltdl
+ cpljava = cpljava
+ endif
+
+-SUBDIRS = $(libltdl) $(libcext) cplcore cplui cpldrs cpldfs $(cpljava)
++SUBDIRS = $(libcext) cplcore cplui cpldrs cpldfs $(cpljava)
+
+ HTML_SUBDIRS =
+