summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-12-23 10:57:13 +0100
committerJustin Lecher <jlec@gentoo.org>2016-12-23 10:57:46 +0100
commit079e9f3f8e7c40da207b8a8020f9ff5b908d4cae (patch)
treeeedcc7dda576436619d0514cf81cade1ef527310 /sci-astronomy/idlastro
parentdev-lua/luaposix: New package, ebuild written by me (diff)
downloadgentoo-079e9f3f8e7c40da207b8a8020f9ff5b908d4cae.tar.gz
gentoo-079e9f3f8e7c40da207b8a8020f9ff5b908d4cae.tar.bz2
gentoo-079e9f3f8e7c40da207b8a8020f9ff5b908d4cae.zip
sci-astronomy/idlastro: Copy instead of symlinking
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-astronomy/idlastro')
l---------sci-astronomy/idlastro/idlastro-20161220.ebuild32
1 files changed, 31 insertions, 1 deletions
diff --git a/sci-astronomy/idlastro/idlastro-20161220.ebuild b/sci-astronomy/idlastro/idlastro-20161220.ebuild
index 307bca823cfa..e3dabdb9e833 120000
--- a/sci-astronomy/idlastro/idlastro-20161220.ebuild
+++ b/sci-astronomy/idlastro/idlastro-20161220.ebuild
@@ -1 +1,31 @@
-idlastro-99999999.ebuild \ No newline at end of file
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://idlastro.gsfc.nasa.gov/ftp/astron.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}"
+else
+ inherit git-r3
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI=( "git://github.com/wlandsman/IDLAstro.git" )
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Astronomical user routines for IDL"
+HOMEPAGE="http://idlastro.gsfc.nasa.gov/"
+
+LICENSE="BSD-2 BSD"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ insinto /usr/share/gnudatalanguage/${PN}
+ doins -r pro/*
+ dodoc *txt text/*
+}