summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-03-07 20:59:36 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-03-07 21:02:21 +0000
commit174a68f95c2127998f99d3ce304028de6aae34d3 (patch)
tree8a21694f31c91da9c0583e96c237d9a3a370dd3f /sci-astronomy/scamp/scamp-2.0.4.ebuild
parentsci-libs/atlas: initial import (diff)
downloadgentoo-174a68f95c2127998f99d3ce304028de6aae34d3.tar.gz
gentoo-174a68f95c2127998f99d3ce304028de6aae34d3.tar.bz2
gentoo-174a68f95c2127998f99d3ce304028de6aae34d3.zip
sci-astronomy/scamp: initial import
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/scamp/scamp-2.0.4.ebuild')
-rw-r--r--sci-astronomy/scamp/scamp-2.0.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/scamp/scamp-2.0.4.ebuild b/sci-astronomy/scamp/scamp-2.0.4.ebuild
new file mode 100644
index 000000000000..0d601c0924a0
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-2.0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc plplot threads"
+
+RDEPEND="
+ sci-astronomy/cdsclient
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ local mycblas=atlcblas myclapack=atlclapack
+ if use threads; then
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
+ mycblas=ptcblas
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
+ myclapack=ptclapack
+ fi
+ sed -e "s/-lcblas/-l${mycblas}/g" \
+ -e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
+ -e "s|lapack_lib=\"lapack\"|lapack_lib=${myclapack}|" \
+ -i acx_atlas.m4 || die
+ sed -e 's|plplotd|plplot|g' -i acx_plplot.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
+ $(use_enable plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*
+}