summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-24 18:55:42 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-24 18:56:07 +0000
commite946244936157ce995d0194a62d30963ac0fedbe (patch)
treeb9b5a42f045cdfe3f6bc7399bdbd7a1c1a739342 /sci-astronomy/stiff/stiff-2.4.0.ebuild
parentsci-astronomy/ds9-bin: Version bump (diff)
downloadgentoo-e946244936157ce995d0194a62d30963ac0fedbe.tar.gz
gentoo-e946244936157ce995d0194a62d30963ac0fedbe.tar.bz2
gentoo-e946244936157ce995d0194a62d30963ac0fedbe.zip
sci-astronomy/stiff: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-astronomy/stiff/stiff-2.4.0.ebuild')
-rw-r--r--sci-astronomy/stiff/stiff-2.4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-astronomy/stiff/stiff-2.4.0.ebuild b/sci-astronomy/stiff/stiff-2.4.0.ebuild
new file mode 100644
index 000000000000..195aa2fe5837
--- /dev/null
+++ b/sci-astronomy/stiff/stiff-2.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Converts astronomical FITS images to the TIFF format"
+HOMEPAGE="http://www.astronomatic.net/software/stiff"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc threads"
+
+RDEPEND="
+ media-libs/tiff:0=
+ virtual/jpeg:0
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/stiff.pdf
+}