summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/xephem/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/xephem/files')
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.4-libs-flags.patch160
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch15
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.5-respect-flags.patch57
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.6-implicits.patch12
-rw-r--r--sci-astronomy/xephem/files/xephem-3.7.6-respect_env_vars.patch129
5 files changed, 373 insertions, 0 deletions
diff --git a/sci-astronomy/xephem/files/xephem-3.7.4-libs-flags.patch b/sci-astronomy/xephem/files/xephem-3.7.4-libs-flags.patch
new file mode 100644
index 000000000000..500ea12f223a
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.4-libs-flags.patch
@@ -0,0 +1,160 @@
+diff -Nur xephem-3.7.4.orig/GUI/xephem/Makefile xephem-3.7.4/GUI/xephem/Makefile
+--- xephem-3.7.4.orig/GUI/xephem/Makefile 2009-01-05 20:55:59.000000000 +0000
++++ xephem-3.7.4/GUI/xephem/Makefile 2009-07-26 15:26:42.000000000 +0100
+@@ -10,8 +10,8 @@
+ # one executable, xephem.
+
+ # These -I and -L flags point to the supporting XEphem libraries
+-LIBINC = -I../../libastro -I../../libip -I../../liblilxml -I../../libjpegd -I../../libpng -I../../libz
+-LIBLNK = -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd -L../../libpng -L../../libz
++LIBINC = -I../../libastro -I../../libip -I../../liblilxml
++LIBLNK = -L../../libastro -L../../libip -L../../liblilxml
+-LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
++LIBLIB = -lastro -lip -llilxml -ljpeg -lpng -lz
+
+ # MOTIFI is the directory containing the Xm directory of include files.
+@@ -32,12 +32,9 @@
+
+ # for linux and Apple OS X
+ # some systems now use just /usr/X11 (not /usr/X11R6)
+-CC = gcc
+-CLDFLAGS = -g
+-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
+-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
+-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lXmu -lX11
+-LIBS = $(XLIBS) $(LIBLIB) -lm
++XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11
++LIBS = $(LIBLNK) $(XLIBS) $(LIBLIB) -lm
++CFLAGS := $(LIBINC) $(CFLAGS)
+
+ # for ppc Apple OS X to make universal (i386 and ppc binary), requires
+ # Xcode 2.2, /Developers/SDK/MacOSX10.4u.sdk and all libs, including libXm,
+@@ -187,12 +184,9 @@
+ nroff -man $? > $@
+
+ libs:
+- cd ../../libastro; make
+- cd ../../libip; make
+- cd ../../libjpegd; make
+- cd ../../liblilxml; make
+- cd ../../libpng; make
+- cd ../../libz; make
++ cd ../../libastro; $(MAKE)
++ cd ../../libip; $(MAKE)
++ cd ../../liblilxml; $(MAKE)
+
+ clean:
+ rm -fr *.o ../../lib*/*.[ao]
+diff -Nur xephem-3.7.4.orig/GUI/xephem/tools/lx200xed/Makefile xephem-3.7.4/GUI/xephem/tools/lx200xed/Makefile
+--- xephem-3.7.4.orig/GUI/xephem/tools/lx200xed/Makefile 2005-03-20 11:04:51.000000000 +0000
++++ xephem-3.7.4/GUI/xephem/tools/lx200xed/Makefile 2009-07-26 15:15:06.000000000 +0100
+@@ -1,10 +1,6 @@
+ LIBASTRO = ../../../../libastro
+-CLDFLAGS =
+-CFLAGS = -Wall -O2 $(CLDFLAGS) -I$(LIBASTRO)
+-LDFLAGS = $(CLDFLAGS) -L$(LIBASTRO)
+-CC = gcc
+-
+-LIBS = -lastro -lm
++CFLAGS := -I$(LIBASTRO) $(CFLAGS)
++LIBS = -L$(LIBASTRO) -lastro -lm
+
+ OBJS = \
+ liblx200.o \
+diff -Nur xephem-3.7.4.orig/GUI/xephem/tools/xedb/Makefile xephem-3.7.4/GUI/xephem/tools/xedb/Makefile
+--- xephem-3.7.4.orig/GUI/xephem/tools/xedb/Makefile 2005-03-20 11:04:51.000000000 +0000
++++ xephem-3.7.4/GUI/xephem/tools/xedb/Makefile 2009-07-26 15:13:30.000000000 +0100
+@@ -2,11 +2,8 @@
+ # assumes gcc, adjust to suit.
+
+ ASLIBDIR = ../../../../libastro
+-CLDFLAGS =
+-GCCFLAGS = -O2 -ffast-math -Wall
+-CFLAGS = $(CLDFLAGS) $(GCCFLAGS) -I$(ASLIBDIR)
+-LDFLAGS = $(CLDFLAGS) -L$(ASLIBDIR)
+-LIBS = -lastro -lm
++CFLAGS := -I$(ASLIBDIR) $(CFLAGS)
++LIBS = -L$(ASLIBDIR) -lastro -lm
+
+ OBJS = xedb.o \
+ print.o
+diff -Nur xephem-3.7.4.orig/GUI/xephem/tools/xephemdbd/Makefile xephem-3.7.4/GUI/xephem/tools/xephemdbd/Makefile
+--- xephem-3.7.4.orig/GUI/xephem/tools/xephemdbd/Makefile 2005-03-20 11:04:51.000000000 +0000
++++ xephem-3.7.4/GUI/xephem/tools/xephemdbd/Makefile 2009-07-26 15:16:13.000000000 +0100
+@@ -2,16 +2,12 @@
+ # run this after successfully making XEphem and its libs.
+ # Only tested on Linux.
+
+-CC = gcc
+-
+ XED = ../..
+ LAS = $(XED)/../../libastro
+ IPH = $(XED)/../../libip
+
+-CLDFLAGS =-g
+-CFLAGS = $(CLDFLAGS) -Wall -ffast-math -I$(XED) -I$(LAS) -I$(IPH)
+-LDFLAGS = $(CLDFLAGS) -L$(LAS)
+-LIBS = -lastro -lm
++CFLAGS := -I$(XED) -I$(LAS) -I$(IPH) $(CFLAGS)
++LIBS = -L$(LAS) -lastro -lm
+
+ OBJS = xephemdbd.o \
+ db.o \
+diff -Nur xephem-3.7.4.orig/libastro/Makefile xephem-3.7.4/libastro/Makefile
+--- xephem-3.7.4.orig/libastro/Makefile 2006-02-24 03:37:31.000000000 +0000
++++ xephem-3.7.4/libastro/Makefile 2009-07-26 15:22:43.000000000 +0100
+@@ -3,10 +3,6 @@
+
+ # compiler and flags
+
+-# gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+-
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
+
+@@ -87,7 +83,7 @@
+ ranlib $@
+
+ libastro.so: $(HS) $(OBJS)
+- $(CC) -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libastro.a
+diff -Nur xephem-3.7.4.orig/libip/Makefile xephem-3.7.4/libip/Makefile
+--- xephem-3.7.4.orig/libip/Makefile 2009-01-05 20:53:46.000000000 +0000
++++ xephem-3.7.4/libip/Makefile 2009-07-26 15:20:43.000000000 +0100
+@@ -2,8 +2,7 @@
+ # (C) 2001 Elwood Charles Downey
+
+ # gcc
+-CC = gcc
+-CFLAGS= -I../libastro -O2 -Wall
++CFLAGS := -I../libastro $(CFLAGS)
+
+ # macosx universal binary
+ # CFLAGS= -I../libastro -O2 -Wall -arch i386 -arch ppc
+@@ -40,7 +39,7 @@
+ ranlib $@
+
+ libip.so: $(OBJS)
+- gcc -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libip.a
+diff -Nur xephem-3.7.4.orig/liblilxml/Makefile xephem-3.7.4/liblilxml/Makefile
+--- xephem-3.7.4.orig/liblilxml/Makefile 2006-02-24 03:37:32.000000000 +0000
++++ xephem-3.7.4/liblilxml/Makefile 2009-07-26 15:22:04.000000000 +0100
+@@ -3,9 +3,6 @@
+
+ # compiler and flags
+
+-# gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
diff --git a/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch b/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch
new file mode 100644
index 000000000000..2dd5e55c3696
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.4-overflows.patch
@@ -0,0 +1,15 @@
+Fix buffer overflow
+
+http://bugs.gentoo.org/show_bug.cgi?id=339901
+
+--- GUI/xephem/tools/lx200xed/liblx200.c
++++ GUI/xephem/tools/lx200xed/liblx200.c
+@@ -855,7 +855,7 @@
+ return(LX200_FALSE); /*Probably ought to verify all characters are acceptable*/
+ szCmd[1]='L' + iSite;
+ szCmd[2]='\0';
+- snprintf(szSite,6,"%3s",buf);
++ snprintf(szSite,4,"%3s",buf);
+ return(lx200_set_generic(fd,szCmd,szSite));
+ }
+
diff --git a/sci-astronomy/xephem/files/xephem-3.7.5-respect-flags.patch b/sci-astronomy/xephem/files/xephem-3.7.5-respect-flags.patch
new file mode 100644
index 000000000000..8a695652fac4
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.5-respect-flags.patch
@@ -0,0 +1,57 @@
+Respect AR, RANLIB
+
+https://bugs.gentoo.org/show_bug.cgi?id=436646
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/libastro/Makefile
++++ b/libastro/Makefile
+@@ -79,8 +79,8 @@ OBJS = \
+ vsop87_data.o
+
+ libastro.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libastro.so: $(HS) $(OBJS)
+ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+--- a/libip/Makefile
++++ b/libip/Makefile
+@@ -35,8 +35,8 @@ OBJS = \
+ HS = ip.h fsmatch.h
+
+ libip.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libip.so: $(OBJS)
+ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+--- a/libjpegd/Makefile
++++ b/libjpegd/Makefile
+@@ -62,8 +62,8 @@ OBJS = \
+ jutils.o
+
+ libjpegd.a: $(HS) $(OBJS)
+- ar r $@ $(OBJS)
+- ranlib $@
++ $(AR) r $@ $(OBJS)
++ $(RANLIB) $@
+
+ clobber:
+ touch x.o x.a
+--- a/liblilxml/Makefile
++++ b/liblilxml/Makefile
+@@ -24,8 +24,8 @@ HS = lilxml.h
+ OBJS = lilxml.o base64.o
+
+ liblilxml.a: $(HS) $(OBJS)
+- ar r $@ $(OBJS)
+- ranlib $@
++ $(AR) r $@ $(OBJS)
++ $(RANLIB) $@
+
+ liltest: liltest.o liblilxml.a
+ $(CC) $(LDFLAGS) -o liltest liltest.o liblilxml.a
diff --git a/sci-astronomy/xephem/files/xephem-3.7.6-implicits.patch b/sci-astronomy/xephem/files/xephem-3.7.6-implicits.patch
new file mode 100644
index 000000000000..4c340711e0e8
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.6-implicits.patch
@@ -0,0 +1,12 @@
+sunmenu.c:920:3: warning: implicit declaration of function ‘strptime’
+
+--- a/GUI/xephem/sunmenu.c
++++ b/GUI/xephem/sunmenu.c
+@@ -1,6 +1,7 @@
+ /* code to manage the sun display
+ */
+
++#define _XOPEN_SOURCE /* See feature_test_macros(7) */
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
diff --git a/sci-astronomy/xephem/files/xephem-3.7.6-respect_env_vars.patch b/sci-astronomy/xephem/files/xephem-3.7.6-respect_env_vars.patch
new file mode 100644
index 000000000000..4fc48a763c5e
--- /dev/null
+++ b/sci-astronomy/xephem/files/xephem-3.7.6-respect_env_vars.patch
@@ -0,0 +1,129 @@
+diff --git a/GUI/xephem/Makefile b/GUI/xephem/Makefile
+index b4c26f2..ab4f256 100644
+--- a/GUI/xephem/Makefile
++++ b/GUI/xephem/Makefile
+@@ -10,9 +10,9 @@
+ # one executable, xephem.
+
+ # These -I and -L flags point to the supporting XEphem libraries
+-LIBINC = -I../../libastro -I../../libip -I../../liblilxml -I../../libjpegd -I../../libpng -I../../libz
+-LIBLNK = -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd -L../../libpng -L../../libz
+-LIBLIB = -lastro -lip -llilxml -ljpegd -lpng -lz
++LIBINC = -I../../libastro -I../../libip -I../../liblilxml
++LIBLNK = -L../../libastro -L../../libip -L../../liblilxml
++LIBLIB = -lastro -lip -llilxml -ljpeg -lpng -lz
+
+ # MOTIFI is the directory containing the Xm directory of include files.
+ # MOTIFL is the directory containing the libXm.a library.
+@@ -32,12 +32,9 @@ endif
+
+ # for linux and Apple OS X
+ # some systems now use just /usr/X11 (not /usr/X11R6)
+-CC = gcc
+-CLDFLAGS = -g
+-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
+-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
++CFLAGS := $(LIBINC) $(CFLAGS)
+ XLIBS = -lXm -lXp -lXt -lXext -lXmu -lX11
+-LIBS = $(XLIBS) $(LIBLIB) -lm
++LIBS = $(LIBLNK) $(XLIBS) $(LIBLIB) -lm
+
+ # for ppc Apple OS X to make universal (i386 and ppc binary), requires
+ # Xcode 2.2, /Developers/SDK/MacOSX10.4u.sdk and all libs, including libXm,
+@@ -187,12 +184,9 @@ xephem.1: xephem.man
+ nroff -man $? > $@
+
+ libs:
+- cd ../../libastro; make
+- cd ../../libip; make
+- cd ../../libjpegd; make
+- cd ../../liblilxml; make
+- cd ../../libpng; make
+- cd ../../libz; make
++ $(MAKE) -C ../../libastro
++ $(MAKE) -C ../../libip
++ $(MAKE) -C ../../liblilxml
+
+ clean:
+ rm -fr *.o ../../lib*/*.[ao]
+diff --git a/libastro/Makefile b/libastro/Makefile
+index b1ab0bf..62c5412 100644
+--- a/libastro/Makefile
++++ b/libastro/Makefile
+@@ -4,8 +4,6 @@
+ # compiler and flags
+
+ # gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
+@@ -83,11 +81,11 @@ OBJS = \
+ vsop87_data.o
+
+ libastro.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libastro.so: $(HS) $(OBJS)
+- $(CC) -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libastro.a
+diff --git a/libip/Makefile b/libip/Makefile
+index 35cb9c6..cba71e1 100644
+--- a/libip/Makefile
++++ b/libip/Makefile
+@@ -2,8 +2,7 @@
+ # (C) 2001 Elwood Charles Downey
+
+ # gcc
+-CC = gcc
+-CFLAGS= -I../libastro -O2 -Wall
++CFLAGS += -I../libastro
+
+ # macosx universal binary
+ # CFLAGS= -I../libastro -O2 -Wall -arch i386 -arch ppc
+@@ -36,11 +35,11 @@ OBJS = \
+ HS = ip.h fsmatch.h
+
+ libip.a: $(HS) $(OBJS)
+- ar rv $@ $(OBJS)
+- ranlib $@
++ $(AR) rv $@ $(OBJS)
++ $(RANLIB) $@
+
+ libip.so: $(OBJS)
+- gcc -shared -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -shared -o $@ $(OBJS)
+
+ clobber:
+ rm -f *.o libip.a
+diff --git a/liblilxml/Makefile b/liblilxml/Makefile
+index 9ab98cb..85e7889 100644
+--- a/liblilxml/Makefile
++++ b/liblilxml/Makefile
+@@ -4,8 +4,6 @@
+ # compiler and flags
+
+ # gcc
+-CC = gcc
+-CFLAGS= -O2 -Wall
+
+ # macosx universal binary
+ # CFLAGS= -O2 -Wall -arch i386 -arch ppc
+@@ -27,8 +25,8 @@ HS = lilxml.h
+ OBJS = lilxml.o base64.o
+
+ liblilxml.a: $(HS) $(OBJS)
+- ar r $@ $(OBJS)
+- ranlib $@
++ $(AR) r $@ $(OBJS)
++ $(RANLIB) $@
+
+ liltest: liltest.o liblilxml.a
+ $(CC) $(LDFLAGS) -o liltest liltest.o liblilxml.a