summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-04 01:09:53 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-04 01:09:53 +0200
commit15811784574e3886dd48185511c0b8444bae5c52 (patch)
treebefe330df90b1f06885293ff5e372f2bffb8f409 /sci-astronomy
parentsci-astronomy/stuff: Fix -fno-common (diff)
downloadgentoo-15811784574e3886dd48185511c0b8444bae5c52.tar.gz
gentoo-15811784574e3886dd48185511c0b8444bae5c52.tar.bz2
gentoo-15811784574e3886dd48185511c0b8444bae5c52.zip
sci-astronomy/skymaker: Fix -fno-common
Closes: https://bugs.gentoo.org/707164 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch66
-rw-r--r--sci-astronomy/skymaker/skymaker-3.10.5.ebuild10
2 files changed, 72 insertions, 4 deletions
diff --git a/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch b/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch
new file mode 100644
index 000000000000..f80ed5422c67
--- /dev/null
+++ b/sci-astronomy/skymaker/files/skymaker-3.10.5-fno-common.patch
@@ -0,0 +1,66 @@
+--- a/src/fits/fitscat.c
++++ b/src/fits/fitscat.c
+@@ -42,6 +42,9 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++int bswapflag;
++char gstr[MAXCHAR];
++
+ /****** about_cat **************************************************************
+ PROTO int about_cat(catstruct *cat, FILE *stream)
+ PURPOSE Print some info about a catalog.
+--- a/src/fits/fitscat_defs.h
++++ b/src/fits/fitscat_defs.h
+@@ -86,7 +86,7 @@
+ typedef int LONG; /* for DEC-Alpha... */
+
+ /*----------------------------- Internal constants --------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*----------------------------- External constants --------------------------*/
+
+--- a/src/fits/fitscat.h
++++ b/src/fits/fitscat.h
+@@ -333,6 +333,6 @@
+ warning(char *msg1, char *msg2);
+
+
+-int bswapflag;
++extern int bswapflag;
+
+ #endif
+--- a/src/globals.h
++++ b/src/globals.h
+@@ -29,7 +29,7 @@
+ #include "types.h"
+
+ /*----------------------- miscellaneous variables ---------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*------------------------------- functions ---------------------------------*/
+ extern void makeit(void);
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -59,6 +59,8 @@
+ #include "prefs.h"
+ #include "preflist.h"
+
++prefstruct prefs;
++
+ /********************************* dumpprefs ********************************/
+ /*
+ Print the default preference parameters.
+--- a/src/prefs.h
++++ b/src/prefs.h
+@@ -149,7 +149,7 @@
+ int nobj; /* Number of sources added */
+ } prefstruct;
+
+-prefstruct prefs;
++extern prefstruct prefs;
+
+ /*-------------------------------- protos -----------------------------------*/
+ extern int cistrcmp(char *cs, char *ct, int mode);
diff --git a/sci-astronomy/skymaker/skymaker-3.10.5.ebuild b/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
index da9788d145b4..dd5c6c6a1882 100644
--- a/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
+++ b/sci-astronomy/skymaker/skymaker-3.10.5.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Program that simulates astronomical images"
HOMEPAGE="http://www.astromatic.net/software/skymaker"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
-RDEPEND="sci-libs/fftw:3.0"
+RDEPEND="sci-libs/fftw:3.0="
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_configure() {
econf $(use_enable threads)
}