summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-05 21:44:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-06 21:31:11 +0000
commit40b9c7abdf2e26711a288970abb260c09023d328 (patch)
treedf7adf1ec20d5594bb68b8515cbfea02d5c0086d /sci-astronomy
parentdev-haskell/extra: fix test, bump up to 1.5.1, bug #624030 (diff)
downloadgentoo-40b9c7abdf2e26711a288970abb260c09023d328.tar.gz
gentoo-40b9c7abdf2e26711a288970abb260c09023d328.tar.bz2
gentoo-40b9c7abdf2e26711a288970abb260c09023d328.zip
sci-astronomy/cdsclient: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cdsclient/Manifest1
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-astronomy/cdsclient/Manifest b/sci-astronomy/cdsclient/Manifest
index 33ac3483caa3..daf5d1039258 100644
--- a/sci-astronomy/cdsclient/Manifest
+++ b/sci-astronomy/cdsclient/Manifest
@@ -1 +1,2 @@
DIST cdsclient-3.81.tar.gz 122719 SHA256 d74dca1d450e2c8f187e3d7c4952ac480a8913da799f5522a42ea7d5075e339d SHA512 3fcf7a902dfddb3583ff34eedbcddd6a5641bf9c87d234159090378436ac370313ea311d3fee6e202ee84b3fe4065ef45a46a15b5d996e05afd1418e617c20ea WHIRLPOOL 350a5d3bff06fbe15105b9f60c4d8266dda15974b32f01b19ec8aca05fb1e830298dc9f885088f58d4ddf6685da84579db908a68f15fe7bb64165684a2d8cd58
+DIST cdsclient-3.84.tar.gz 119585 SHA256 09eb633011461b9261b923e1d0db69d3591d376b447f316eb1994aaea8919700 SHA512 2d7abf0079189b9dd19cb8919061445fd19ea9f7dfd54e8ceee26b743218cf62ab00eba0147abe82d9294223927f04b4cc3328620dfc9184a7049f8d515b29e4 WHIRLPOOL 9c0526e9549b750cf54b94d37e905cc54d24ce4a5fe6415e87d23c9489d6f47d91c6673d3fd31869b956f073133f9216a8ee07442c1ec5d5ec96ded94ef9eeeb
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
new file mode 100644
index 000000000000..868a8b7c0c88
--- /dev/null
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils versionator
+
+# upstream versioning wrong: 3.71 is really 3.7.1
+MYP="${PN}-$(delete_version_separator 2)"
+
+DESCRIPTION="Collection of scripts to access the CDS databases"
+HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
+SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="mirror bindist"
+DEPEND=""
+RDEPEND="app-shells/tcsh"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+src_prepare() {
+ default
+ # remove non standard "mantex" page
+ sed -e 's/aclient.tex//' -i configure || die
+}
+
+src_install() {
+ local bindir="${EPREFIX}/usr/bin/${PN}"
+ emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
+ cat <<-EOF > 99${PN}
+ PATH=${bindir}
+ ROOTPATH=${bindir}
+ EOF
+ doenvd 99${PN}
+}