summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-20 23:51:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-20 23:51:33 +0200
commit5a36d6651fcd49e5f9c2264ab52ec0dba552eb4c (patch)
tree303af94a6e5d7e5a66a5373fdbf9dbe33c5f3eea /sci-astronomy
parentvirtual/perl-Module-CoreList: Add 5.34.0 version (diff)
downloadgentoo-5a36d6651fcd49e5f9c2264ab52ec0dba552eb4c.tar.gz
gentoo-5a36d6651fcd49e5f9c2264ab52ec0dba552eb4c.tar.bz2
gentoo-5a36d6651fcd49e5f9c2264ab52ec0dba552eb4c.zip
sci-astronomy/kstars: Fix build with IUSE="-raw fits"
Closes: https://bugs.gentoo.org/790638 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/kstars/files/kstars-3.5.3-fits-w-o-libraw.patch25
-rw-r--r--sci-astronomy/kstars/kstars-3.5.3.ebuild2
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-astronomy/kstars/files/kstars-3.5.3-fits-w-o-libraw.patch b/sci-astronomy/kstars/files/kstars-3.5.3-fits-w-o-libraw.patch
new file mode 100644
index 000000000000..a0bb66046f01
--- /dev/null
+++ b/sci-astronomy/kstars/files/kstars-3.5.3-fits-w-o-libraw.patch
@@ -0,0 +1,25 @@
+From 1adf58605d18ee24c68ca6762a94de75a09d738a Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Mon, 26 Apr 2021 12:53:19 +0200
+Subject: [PATCH] Fix build without BUILD_KSTARS_LITE and libraw
+
+---
+ kstars/fitsviewer/fitsdata.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kstars/fitsviewer/fitsdata.cpp b/kstars/fitsviewer/fitsdata.cpp
+index 8300e9687..ca59d808e 100644
+--- a/kstars/fitsviewer/fitsdata.cpp
++++ b/kstars/fitsviewer/fitsdata.cpp
+@@ -524,7 +524,7 @@ bool FITSData::loadRAWImage(const QByteArray &buffer, const QString &extension,
+ Q_UNUSED(extension);
+
+ #if !defined(KSTARS_LITE) && !defined(HAVE_LIBRAW)
+- lastError = i18n("Unable to find dcraw and cjpeg. Please install the required tools to convert CR2/NEF to JPEG.");
++ m_LastError = i18n("Unable to find dcraw and cjpeg. Please install the required tools to convert CR2/NEF to JPEG.");
+ return false;
+ #else
+
+--
+GitLab
+
diff --git a/sci-astronomy/kstars/kstars-3.5.3.ebuild b/sci-astronomy/kstars/kstars-3.5.3.ebuild
index 8c5431d2e410..49493cc295d5 100644
--- a/sci-astronomy/kstars/kstars-3.5.3.ebuild
+++ b/sci-astronomy/kstars/kstars-3.5.3.ebuild
@@ -74,6 +74,8 @@ RDEPEND="${COMMON_DEPEND}
>=dev-qt/qtquickcontrols2-${QTMIN}:5
"
+PATCHES=( "${FILESDIR}/${P}-fits-w-o-libraw.patch" ) # bug 790638
+
src_configure() {
local mycmakeargs=(
-DFETCH_TRANSLATIONS=OFF