summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-30 15:39:33 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-27 10:27:34 +0100
commit6af47f1b26b6dc37a9e9f366f97887190c22bc78 (patch)
tree73a1c3e944f689f5383c62ffb22acbc9cf70deaa /sci-astronomy
parentmedia-sound/abcmidi: bump to 2023.11.26, dropped 2023.11.17 (diff)
downloadgentoo-6af47f1b26b6dc37a9e9f366f97887190c22bc78.tar.gz
gentoo-6af47f1b26b6dc37a9e9f366f97887190c22bc78.tar.bz2
gentoo-6af47f1b26b6dc37a9e9f366f97887190c22bc78.zip
sci-astronomy/pal: Fix call to undeclared library function strlcpy
Closes: https://bugs.gentoo.org/898106 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31558 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pal/files/pal-0.9.8-fix-strlcpy-musl.patch14
-rw-r--r--sci-astronomy/pal/pal-0.9.8-r1.ebuild38
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/pal/files/pal-0.9.8-fix-strlcpy-musl.patch b/sci-astronomy/pal/files/pal-0.9.8-fix-strlcpy-musl.patch
new file mode 100644
index 000000000000..7ceef8e4b52e
--- /dev/null
+++ b/sci-astronomy/pal/files/pal-0.9.8-fix-strlcpy-musl.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/898106
+bsd/string.h is available on most libc's
+--- a/palDfltin.c
++++ b/palDfltin.c
+@@ -121,6 +121,9 @@ static int ISBLANK( int c ) {
+
+ #ifdef HAVE_BSD_STRING_H
+ #include <bsd/string.h>
++#else
++#define _GNU_SOURCE
++#define __USE_MISC
+ #endif
+
+ /* System include files */
diff --git a/sci-astronomy/pal/pal-0.9.8-r1.ebuild b/sci-astronomy/pal/pal-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..9b0e2ee32686
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="https://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.8-fix-strlcpy-musl.patch
+)
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # remove cruft from non-fhs compliant
+ dodoc -r "${ED}"/usr/{docs,manifests,news}
+ rm -r "${ED}"/usr/{docs,manifests,news} || die
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}