summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-09 21:18:20 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 21:18:20 +0200
commit865415d66249cce12b8fc7b7e9206d28a7c27a74 (patch)
tree4533816795c82a125f1ca84a88f6dff9b68b2786 /sci-astronomy
parentsci-astronomy/xfitsview: Respect AR (diff)
downloadgentoo-865415d66249cce12b8fc7b7e9206d28a7c27a74.tar.gz
gentoo-865415d66249cce12b8fc7b7e9206d28a7c27a74.tar.bz2
gentoo-865415d66249cce12b8fc7b7e9206d28a7c27a74.zip
sci-astronomy/stiff: Respect AR
Closes: https://bugs.gentoo.org/725272 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stiff/files/stiff-2.4.0-autotools.patch10
-rw-r--r--sci-astronomy/stiff/stiff-2.4.0.ebuild26
2 files changed, 23 insertions, 13 deletions
diff --git a/sci-astronomy/stiff/files/stiff-2.4.0-autotools.patch b/sci-astronomy/stiff/files/stiff-2.4.0-autotools.patch
new file mode 100644
index 000000000000..0a3bb4de9ee6
--- /dev/null
+++ b/sci-astronomy/stiff/files/stiff-2.4.0-autotools.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,6 +82,7 @@
+ fi
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ # Checks for libraries.
+ AC_CHECK_LIB(m, sin)
diff --git a/sci-astronomy/stiff/stiff-2.4.0.ebuild b/sci-astronomy/stiff/stiff-2.4.0.ebuild
index 85bdc78a39f9..02e91240249e 100644
--- a/sci-astronomy/stiff/stiff-2.4.0.ebuild
+++ b/sci-astronomy/stiff/stiff-2.4.0.ebuild
@@ -3,20 +3,15 @@
EAPI=7
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
-else
- inherit flag-o-matic
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit autotools flag-o-matic
DESCRIPTION="Converts astronomical FITS images to the TIFF format"
HOMEPAGE="http://www.astronomatic.net/software/stiff"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc threads"
RDEPEND="
@@ -25,16 +20,21 @@ RDEPEND="
sys-libs/zlib:0="
DEPEND="${RDEPEND}"
+PATCHES=(
+ # https://bugs.gentoo.org/725272
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
src_prepare() {
default
-
- # bug #708382
- append-cflags -fcommon
+ eautoreconf
}
src_configure() {
- CONFIG_SHELL="${EPREFIX}/bin/bash" ECONF_SOURCE="${S}" econf \
- $(use_enable threads)
+ # https://bugs.gentoo.org/708382
+ append-cflags -fcommon
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf $(use_enable threads)
}
src_install() {