summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 02:26:27 -0400
committerSam James <sam@gentoo.org>2024-03-17 06:43:34 +0000
commit966b160bae9f786af04da2b52414a0f054460b8b (patch)
treeba31aac427b0bd4ddaa023c2fca949231e8d2ead /sci-astronomy
parentsci-astronomy/wcslib: mark as LTO-unsafe (diff)
downloadgentoo-966b160bae9f786af04da2b52414a0f054460b8b.tar.gz
gentoo-966b160bae9f786af04da2b52414a0f054460b8b.tar.bz2
gentoo-966b160bae9f786af04da2b52414a0f054460b8b.zip
sci-astronomy/wcslib: add 8.2.2
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/wcslib-8.2.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index b4f348e45772..72b89b7ef156 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -2,3 +2,4 @@ DIST wcslib-7.11.tar.bz2 2946962 BLAKE2B 7c812f50e3c539da3d58a70acd9128bd957fccd
DIST wcslib-7.12.tar.bz2 2989693 BLAKE2B 8070cdddb9e89478464443411d165706d44593e33290149da11d2c2857bad202f5dd6ad98b5840167f618eceb9ec47e35f3ee332a8c6e1719fc2b20fe2f31ef2 SHA512 7f38f725992d3c4bd3c1b908d494ac361c17f6b60f091d987fda596211423bb7396b3a5e2f1f6dd6215835016d302083472a7ad0822f17cdfe230c8f556b3e23
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
+DIST wcslib-8.2.2.tar.bz2 3187577 BLAKE2B cd75652eac5777bce4a66ea1de03796b12c77f7269c6050eda95518d28a17be2ad8ae46b57e0a21f8d03dcf3a0144316d06d16aac7a37a42150e713113cc7edc SHA512 cf540fdac03d2868902c9d4c2f1cd5919e878e79de635b01006b61f4d95f727659033d0d05172a7bcd00287ecc395609a643cf95a6498fbc3ff2d3fb26c136b4
diff --git a/sci-astronomy/wcslib/wcslib-8.2.2.ebuild b/sci-astronomy/wcslib/wcslib-8.2.2.ebuild
new file mode 100644
index 000000000000..ff5f3d72e32e
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-8.2.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit flag-o-matic fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/7"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig"
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/877885
+ #
+ # Upstream has an email contact address, so sent an email describing the issue.
+ filter-lto
+
+ # workaround until upstream fix it properly
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf "${myconf[@]}"
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib*.a || die
+ fi
+
+ if ! use doc; then
+ rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+ # always creates this symlink
+ rm "${ED}"/usr/share/doc/${PN} || die
+}