summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-18 21:49:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-18 21:51:51 +0200
commit967ffe2ac3852a1c8fa5e7505ab49e770575cb5c (patch)
tree52927f68e61e16051df7a71da49e453c0872dde7 /sci-astronomy
parentsys-kernel/linux-firmware: Add postinst message. (diff)
downloadgentoo-967ffe2ac3852a1c8fa5e7505ab49e770575cb5c.tar.gz
gentoo-967ffe2ac3852a1c8fa5e7505ab49e770575cb5c.tar.bz2
gentoo-967ffe2ac3852a1c8fa5e7505ab49e770575cb5c.zip
sci-astronomy/stellarium: Source upstream patch
Mixed CRLF, LF line terminators... Closes: https://bugs.gentoo.org/686250 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch33
1 files changed, 25 insertions, 8 deletions
diff --git a/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch b/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch
index 9675d389f204..ec2ae5ba2be0 100644
--- a/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch
+++ b/sci-astronomy/stellarium/files/stellarium-0.19.0-static.patch
@@ -1,3 +1,20 @@
+From d280caa72fbbcd362b820a71a01d4f0e2c1a3bcb Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <sokolov@google.com>
+Date: Sat, 18 May 2019 08:28:31 +0100
+Subject: [PATCH] Fix build with cmake -DBUILD_SHARED_LIBS=ON (#683)
+
+Ref https://github.com/gentoo/gentoo/pull/11770
+---
+ plugins/TelescopeControl/src/INDI/CMakeLists.txt | 2 +-
+ plugins/TelescopeControl/src/Lx200/CMakeLists.txt | 2 +-
+ plugins/TelescopeControl/src/NexStar/CMakeLists.txt | 2 +-
+ plugins/TelescopeControl/src/Rts2/CMakeLists.txt | 2 +-
+ plugins/TelescopeControl/src/common/CMakeLists.txt | 2 +-
+ plugins/TelescopeControl/src/gui/CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 2 +-
+ src/external/CMakeLists.txt | 2 +-
+ 8 files changed, 8 insertions(+), 8 deletions(-)
+
diff --git a/plugins/TelescopeControl/src/INDI/CMakeLists.txt b/plugins/TelescopeControl/src/INDI/CMakeLists.txt
index 40c27601a0..a250e1bb0f 100644
--- a/plugins/TelescopeControl/src/INDI/CMakeLists.txt
@@ -94,11 +111,11 @@ index 42a073e828..4c56837314 100644
--- a/src/external/CMakeLists.txt
+++ b/src/external/CMakeLists.txt
@@ -190,7 +190,7 @@ IF(USE_PLUGIN_TELESCOPECONTROL)
- include_directories(libindi)
- include_directories(libindi/libs)
- include_directories(libindi/libs/indibase)
-- add_library(indiclient
-+ add_library(indiclient STATIC
- libindi/libs/lilxml.c
- libindi/base64.c
- libindi/libs/indibase/basedevice.h
+ include_directories(libindi)
+ include_directories(libindi/libs)
+ include_directories(libindi/libs/indibase)
+- add_library(indiclient
++ add_library(indiclient STATIC
+ libindi/libs/lilxml.c
+ libindi/base64.c
+ libindi/libs/indibase/basedevice.h