summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-02-13 10:06:36 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-13 10:11:39 +0100
commitc77eaaf4a6a3c05a7445fb016dba7178a52b8cf9 (patch)
tree440fdca06686e598959aceea90d4f22da66d31c3 /sci-astronomy
parentdev-ruby/net-imap: import 0.2.3 (diff)
downloadgentoo-c77eaaf4a6a3c05a7445fb016dba7178a52b8cf9.tar.gz
gentoo-c77eaaf4a6a3c05a7445fb016dba7178a52b8cf9.tar.bz2
gentoo-c77eaaf4a6a3c05a7445fb016dba7178a52b8cf9.zip
sci-astronomy/healpix: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/healpix/Manifest1
-rw-r--r--sci-astronomy/healpix/healpix-3.31.ebuild141
-rw-r--r--sci-astronomy/healpix/metadata.xml20
3 files changed, 0 insertions, 162 deletions
diff --git a/sci-astronomy/healpix/Manifest b/sci-astronomy/healpix/Manifest
deleted file mode 100644
index f4344c29ce19..000000000000
--- a/sci-astronomy/healpix/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Healpix_3.31_2016Aug26.tar.gz 23834899 BLAKE2B a9e3b6567e851eb941e81d45145848a8daede260454dee29e056857f98ea643a0a438a5cc763651f4156ae975be41c601b8664f8bebbcf13b0fb23822c36ae40 SHA512 fd80e9ed80d19e438134f63c3d13802f63c4cd1b9f3596807e67d4ba5ff814e652a130d038449269d6ead271085eb0ab74884b2d768d8531066727377c457f9c
diff --git a/sci-astronomy/healpix/healpix-3.31.ebuild b/sci-astronomy/healpix/healpix-3.31.ebuild
deleted file mode 100644
index d96d3c91b57e..000000000000
--- a/sci-astronomy/healpix/healpix-3.31.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools toolchain-funcs java-pkg-opt-2 java-ant-2
-
-MYP="Healpix_${PV}"
-MYPF=${MYP}_2016Aug26
-
-DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere"
-HOMEPAGE="http://healpix.sourceforge.net/"
-SRC_URI="mirror://sourceforge/healpix/${MYP}/${MYPF}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# might add fortran in the future if requested
-IUSE="cxx doc idl java openmp static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=sci-libs/cfitsio-3
- idl? (
- dev-lang/gdl
- sci-astronomy/idlastro )
- java? ( >=virtual/jre-1.6:* )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- java? ( >=virtual/jdk-1.6:* test? ( dev-java/ant-junit4:0 ) )"
-
-S="${WORKDIR}/${MYP}"
-
-pkg_pretend() {
- if use cxx && use openmp && [[ $(tc-getCXX)$ == *g++* ]] && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || \
- die "You are using gcc but without OpenMP capabilities that you requested"
- fi
-}
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-}
-
-src_prepare() {
- pushd src/C/autotools > /dev/null
- eautoreconf
- popd > /dev/null
- # why was static-libtool-libs forced?
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- sed -i -e '/-static-libtool-libs/d' Makefile.am || die
- eautoreconf
- popd > /dev/null
- fi
- # duplicate of idlastro (in rdeps)
- rm -r src/idl/zzz_external/astron || die
- mv src/idl/zzz_external/README src/idl/README.external || die
- java-pkg-opt-2_src_prepare
- default
-}
-
-src_configure() {
- pushd src/C/autotools > /dev/null
- econf $(use_enable static-libs static)
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- econf \
- --disable-native-optimizations \
- $(use_enable openmp) \
- $(use_enable static-libs static)
- popd > /dev/null
- fi
-}
-
-src_compile() {
- pushd src/C/autotools > /dev/null
- emake
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- eant dist-notest
- popd > /dev/null
- fi
-}
-
-src_test() {
- pushd src/C/autotools > /dev/null
- emake check
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake check
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- EANT_GENTOO_CLASSPATH="ant-junit4" ANT_TASKS="ant-junit4" eant test
- popd > /dev/null
- fi
-}
-
-src_install() {
- dodoc READ_Copyrights_Licenses.txt
- pushd src/C/autotools > /dev/null
- emake install DESTDIR="${D}"
- popd > /dev/null
- if use cxx; then
- pushd src/cxx/autotools > /dev/null
- emake install DESTDIR="${D}"
- docinto cxx
- dodoc ../CHANGES
- popd > /dev/null
- fi
- use static-libs || find "${ED}" -name '*.la' -delete || die
- if use idl; then
- pushd src/idl > /dev/null
- insinto /usr/share/gnudatalanguage/healpix
- doins -r examples fits interfaces misc toolkit visu zzz_external
- doins HEALPix_startup
- docinto idl
- dodoc README.*
- popd > /dev/null
- fi
- if use java; then
- pushd src/java > /dev/null
- java-pkg_dojar dist/*.jar
- docinto java
- dodoc README CHANGES
- popd > /dev/null
- fi
- use doc && dodoc -r doc/html
-}
diff --git a/sci-astronomy/healpix/metadata.xml b/sci-astronomy/healpix/metadata.xml
deleted file mode 100644
index e65bd49bc3b9..000000000000
--- a/sci-astronomy/healpix/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-astronomy@gentoo.org</email>
- <name>Gentoo Astronomy Project</name>
- </maintainer>
- <longdescription lang="en">
- HEALPix is an acronym for Hierarchical Equal Area isoLatitude
- Pixelization of a sphere. As suggested in the name, this pixelization produces a
- subdivision of a spherical surface in which each pixel covers the same
- surface area as every other pixel.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">healpix</remote-id>
- </upstream>
- <use>
- <flag name="idl">Install healpix IDL/GDL routines</flag>
- </use>
-</pkgmetadata>