summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-20 19:32:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-20 19:37:41 +0200
commitec80058fdeb087d2ccdc5526ef3dc6d7c842e5a1 (patch)
tree948e495f34f098e783318d157d8b8ab23e1aca52 /sci-astronomy
parentdev-db/futuresql5: Keyword 0.1.1 x86, #912682 (diff)
downloadgentoo-ec80058fdeb087d2ccdc5526ef3dc6d7c842e5a1.tar.gz
gentoo-ec80058fdeb087d2ccdc5526ef3dc6d7c842e5a1.tar.bz2
gentoo-ec80058fdeb087d2ccdc5526ef3dc6d7c842e5a1.zip
sci-astronomy/siril: Fix build with >=exiv2-0.28
Closes: https://bugs.gentoo.org/906499 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/files/siril-1.2-exiv2-0.28.patch39
-rw-r--r--sci-astronomy/siril/siril-1.2.0_rc1-r1.ebuild5
2 files changed, 42 insertions, 2 deletions
diff --git a/sci-astronomy/siril/files/siril-1.2-exiv2-0.28.patch b/sci-astronomy/siril/files/siril-1.2-exiv2-0.28.patch
new file mode 100644
index 000000000000..8678316bfc87
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-exiv2-0.28.patch
@@ -0,0 +1,39 @@
+* asturm 2023-08-20: Combination of two commits from upstream git master
+ 3c2579cd: Pick the only hunk relevant for exiv2-0.28...
+ 64583490: Blend with that to fix build w/o exiv2 and fix indendation...
+
+
+From 3c2579cd171314f7e408c00bc8e793330dcc07ba Mon Sep 17 00:00:00 2001
+From: Cyril Richard <cyril.richard42@gmail.com>
+Date: Sun, 4 Jun 2023 22:10:55 +0000
+Subject: [PATCH] XISF image import
+
+From 64583490214302f4057cf223d7591be9d2172a4f Mon Sep 17 00:00:00 2001
+From: Vincent Hourdin <vh@free-astro.org>
+Date: Mon, 5 Jun 2023 00:27:56 +0200
+Subject: [PATCH] fixing exiv2 as optional
+
+--- a/src/core/exif.cpp
++++ b/src/core/exif.cpp
+@@ -121,10 +121,18 @@
+ #endif
+ }
+
++#ifdef HAVE_EXIV2
++#if EXIV2_TEST_VERSION(0,28,0)
++typedef Exiv2::Image::UniquePtr ImagePtr;
++#else
++typedef Exiv2::Image::AutoPtr ImagePtr;
++#endif
++#endif
++
+ gchar* siril_get_date_from_exif(const char *filename) {
+ #ifdef HAVE_EXIV2
+ try {
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(WIDEN(filename));
++ ImagePtr image = Exiv2::ImageFactory::open(WIDEN(filename));
+ if (image.get() == 0) {
+ fprintf(stderr, "Error Cannot open the file.\n");
+ return NULL;
+--
+GitLab
diff --git a/sci-astronomy/siril/siril-1.2.0_rc1-r1.ebuild b/sci-astronomy/siril/siril-1.2.0_rc1-r1.ebuild
index 54a8e916b5fc..c5cbbe1bd8e2 100644
--- a/sci-astronomy/siril/siril-1.2.0_rc1-r1.ebuild
+++ b/sci-astronomy/siril/siril-1.2.0_rc1-r1.ebuild
@@ -52,8 +52,9 @@ BDEPEND="dev-util/cmake
PATCHES=(
"${FILESDIR}/${PN}-docfiles.patch"
- "${FILESDIR}/${PN}-$(ver_cut 1-2)-stdint.patch"
- "${FILESDIR}/${PN}-$(ver_cut 1-2)-tiff.patch"
+ "${FILESDIR}/${PN}-1.2-stdint.patch"
+ "${FILESDIR}/${PN}-1.2-tiff.patch"
+ "${FILESDIR}/${PN}-1.2-exiv2-0.28.patch" # bug 906499
)
DOCS=( README.md NEWS ChangeLog AUTHORS )