summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-13 13:13:01 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-13 13:13:28 +0100
commitfa07bd694ba520d9a8345343ac1dfd0fbfa57327 (patch)
tree17fb218f4c26194faa53178eb5203678b7020281 /sci-astronomy
parentpython-utils-r1.eclass: epytest, force color output to match NOCOLOR (diff)
downloadgentoo-fa07bd694ba520d9a8345343ac1dfd0fbfa57327.tar.gz
gentoo-fa07bd694ba520d9a8345343ac1dfd0fbfa57327.tar.bz2
gentoo-fa07bd694ba520d9a8345343ac1dfd0fbfa57327.zip
sci-astronomy/erfa: add version 2.0.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/erfa/Manifest1
-rw-r--r--sci-astronomy/erfa/erfa-2.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-astronomy/erfa/Manifest b/sci-astronomy/erfa/Manifest
index f2e89441bab4..13f84a906984 100644
--- a/sci-astronomy/erfa/Manifest
+++ b/sci-astronomy/erfa/Manifest
@@ -1 +1,2 @@
DIST erfa-1.4.0.tar.gz 641051 BLAKE2B 448f9f883d85a3c39a58497c6211542719c77b05b6bf4087519b710642c144939a9e27ba44b82a42d759dc04e1effe9833ae087487292846f954e6c3f93fb8db SHA512 2befe5a45486dbbd2ee88229cce7a6101462254bd346d3a2859e294f31119eb5cf5e4113e4061fa3e371216ed793a79ea1ba98fc6fd8aa53d2ba4170e1e135e2
+DIST erfa-2.0.0.tar.gz 729292 BLAKE2B af081b44bdcde4457aba661b08b6bc941e8a4e4fad4a61c40a529dd719eb125263662126246cee83dfa73eb81032888331522e04fe824d0e54fd66bd6ce8b222 SHA512 6761a8c1e1fc20f8603b451a47a47c872fe99e39ec805f131f3db24aeb5b6ac3ac480c89630ff9defbedd0e621fb7e2b7922869b8c29ada1fd41cb9793c9ca0a
diff --git a/sci-astronomy/erfa/erfa-2.0.0.ebuild b/sci-astronomy/erfa/erfa-2.0.0.ebuild
new file mode 100644
index 000000000000..b32aa4eca47c
--- /dev/null
+++ b/sci-astronomy/erfa/erfa-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Essential Routines for Fundamental Astronomy"
+HOMEPAGE="https://github.com/liberfa/erfa"
+SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}