summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@gmail.com>2017-01-10 14:32:37 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 18:53:17 +0100
commit6764ffe099c90b89117afeb0087258ec76f3136f (patch)
tree9945e7170da61c9bf3360c8fa68902eabcb89c3d /sci-biology/abyss/abyss-2.0.2-r1.ebuild
parentapp-admin/salt: random_org unittest was moved to integration tests (diff)
downloadgentoo-6764ffe099c90b89117afeb0087258ec76f3136f.tar.gz
gentoo-6764ffe099c90b89117afeb0087258ec76f3136f.tar.bz2
gentoo-6764ffe099c90b89117afeb0087258ec76f3136f.zip
sci-biology/abyss: only openmpi is supported
Closes: https://github.com/gentoo/gentoo/pull/3414
Diffstat (limited to 'sci-biology/abyss/abyss-2.0.2-r1.ebuild')
-rw-r--r--sci-biology/abyss/abyss-2.0.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/abyss/abyss-2.0.2-r1.ebuild b/sci-biology/abyss/abyss-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..4533f9b824d6
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.0.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? (
+ dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( sys-cluster/openmpi )"
+DEPEND="${RDEPEND}
+ misc-haskell? (
+ dev-lang/ghc
+ dev-haskell/mmap
+ )"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}