summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-06 13:12:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-06 13:12:25 +0000
commit4c8a5799cd9b07143e1c1b9ba865c3e9bbbf5f3e (patch)
tree2863a97e594f29df08730a3d9dc0ade3a1d877b5 /sci-biology/abyss/abyss-2.0.2.ebuild
parentkde-misc/chromi: Remove 0.2 (diff)
downloadgentoo-4c8a5799cd9b07143e1c1b9ba865c3e9bbbf5f3e.tar.gz
gentoo-4c8a5799cd9b07143e1c1b9ba865c3e9bbbf5f3e.tar.bz2
gentoo-4c8a5799cd9b07143e1c1b9ba865c3e9bbbf5f3e.zip
sci-biology/abyss: bump up to 2.0.2, bug #596018
Fixes gcc-6 and boost-1.62 build failures. Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/596018 Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/abyss/abyss-2.0.2.ebuild')
-rw-r--r--sci-biology/abyss/abyss-2.0.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/abyss/abyss-2.0.2.ebuild b/sci-biology/abyss/abyss-2.0.2.ebuild
new file mode 100644
index 000000000000..92a3780e0ade
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? ( dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}
+ misc-haskell? ( dev-lang/ghc
+ dev-haskell/mmap )
+"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}