summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-25 00:47:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 00:55:37 +0200
commitc8c95dc5616fe51e1fffe9f875556a5ff14be39e (patch)
treea24cc25241c20241b810c32b3d334878a05d045a /sci-biology/bedtools/bedtools-2.26.0.ebuild
parentdev-python/six: run pkg_preinst in a temporary directory (diff)
downloadgentoo-c8c95dc5616fe51e1fffe9f875556a5ff14be39e.tar.gz
gentoo-c8c95dc5616fe51e1fffe9f875556a5ff14be39e.tar.bz2
gentoo-c8c95dc5616fe51e1fffe9f875556a5ff14be39e.zip
sci-biology/bedtools: Version bump to 2.26.0
Gentoo-bug: 594994 * EAPI=6 * Make buildsystem output verbose * Inherit 'python-any-r1', due to python script * Add dependencies for test suite * Properly set CXX and CXXFLAGS Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-biology/bedtools/bedtools-2.26.0.ebuild')
-rw-r--r--sci-biology/bedtools/bedtools-2.26.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/bedtools/bedtools-2.26.0.ebuild b/sci-biology/bedtools/bedtools-2.26.0.ebuild
new file mode 100644
index 000000000000..feddd87ef3a5
--- /dev/null
+++ b/sci-biology/bedtools/bedtools-2.26.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Tools for manipulation and analysis of BED, GFF/GTF, VCF, SAM/BAM file formats"
+HOMEPAGE="https://bedtools.readthedocs.io/"
+SRC_URI="https://github.com/arq5x/${PN}2/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ sci-libs/htslib
+ sci-biology/samtools
+ )"
+
+S="${WORKDIR}/${PN}2"
+
+DOCS=( README.md RELEASE_HISTORY )
+PATCHES=( "${FILESDIR}/${PN}-2.26.0-fix-buildsystem.patch" )
+
+src_configure() {
+ append-lfs-flags
+ export prefix="${EPREFIX}/usr"
+ tc-export AR CXX
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins -r genomes
+}