summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-18 19:19:38 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-18 23:39:37 +0100
commit1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24 (patch)
treeb64d456f6d1d7ecbe3658fc9a192ff9969492f00 /sci-biology/biogrep/biogrep-1.0-r2.ebuild
parentsci-biology/arb: Fix overlong DESCRIPTION (diff)
downloadgentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.tar.gz
gentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.tar.bz2
gentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.zip
sci-biology/biogrep: Port to EAPI=6
* Add USE="doc" and USE="examples" * Run 'eautoreconf' to modernize configure script Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/biogrep/biogrep-1.0-r2.ebuild')
-rw-r--r--sci-biology/biogrep/biogrep-1.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/biogrep/biogrep-1.0-r2.ebuild b/sci-biology/biogrep/biogrep-1.0-r2.ebuild
new file mode 100644
index 000000000000..7a5e486d48f3
--- /dev/null
+++ b/sci-biology/biogrep/biogrep-1.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Multithreaded tool for matching large sets of patterns against biosequence DBs"
+HOMEPAGE="http://stephanopoulos.openwetware.org/BIOGREP.html"
+SRC_URI="http://www.openwetware.org/images/3/3d/${P^}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.openwetware.org/images/4/49/${PN^}.pdf -> ${P}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ use doc && DOCS+=( "${DISTDIR}"/${P}.pdf )
+ if use examples; then
+ # remove cruft before installing examples
+ find examples/ \( -name 'CVS' -o -name '*~' \) -exec rm -rf '{}' + || die
+
+ DOCS+=( examples )
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ default
+}