summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-19 18:07:56 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-19 18:07:56 +0100
commit600880b34ddaaf4b9ff6faaae46545b76db394c5 (patch)
tree6302e1949d79f96c65ec2128cf94483a45d0f5aa /sci-biology/bioperl-run
parentsci-biology/bioperl-network: update EAPI 5 -> 8 (diff)
downloadgentoo-600880b34ddaaf4b9ff6faaae46545b76db394c5.tar.gz
gentoo-600880b34ddaaf4b9ff6faaae46545b76db394c5.tar.bz2
gentoo-600880b34ddaaf4b9ff6faaae46545b76db394c5.zip
sci-biology/bioperl-run: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/835362 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/bioperl-run')
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.6.9-r1.ebuild33
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild41
2 files changed, 33 insertions, 41 deletions
diff --git a/sci-biology/bioperl-run/bioperl-run-1.6.9-r1.ebuild b/sci-biology/bioperl-run/bioperl-run-1.6.9-r1.ebuild
new file mode 100644
index 000000000000..2541aab82506
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-1.6.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BIOPERL_RELEASE=1.6.9
+
+DIST_AUTHOR=CJFIELDS
+DIST_NAME=BioPerl-Run
+DIST_VERSION=1.006900
+inherit perl-module
+
+DESCRIPTION="Perl wrapper modules for key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="minimal test"
+RESTRICT="test"
+
+RDEPEND="
+ >=sci-biology/bioperl-${BIOPERL_RELEASE}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ dev-perl/File-Sort
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-perl/Module-Build"
+
+mydoc="AUTHORS BUGS FAQ"
diff --git a/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild b/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
deleted file mode 100644
index 461c4f51b071..000000000000
--- a/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-BIOPERL_RELEASE=1.6.9
-
-MY_PN=BioPerl-Run
-MODULE_AUTHOR=CJFIELDS
-MODULE_VERSION=1.006900
-inherit perl-module
-
-DESCRIPTION="Perl wrapper modules for key bioinformatics applications"
-HOMEPAGE="http://www.bioperl.org/"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="minimal test"
-#SRC_TEST="do"
-
-RESTRICT="test"
-
-CDEPEND=">=sci-biology/bioperl-${BIOPERL_RELEASE}
- !minimal? (
- dev-perl/Algorithm-Diff
- dev-perl/XML-Twig
- dev-perl/IO-String
- dev-perl/IPC-Run
- dev-perl/File-Sort
- )"
-DEPEND="dev-perl/Module-Build
- ${CDEPEND}"
-RDEPEND="${CDEPEND}"
-
-src_install() {
- mydoc="AUTHORS BUGS FAQ"
- perl-module_src_install
- # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
- # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
- #find "${D}" -name '*ConfigData*' -print -delete
-}