summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 18:49:25 +0000
committerSam James <sam@gentoo.org>2022-03-20 18:50:49 +0000
commitb381e310090d0857c4894f4a7134584a73deb1b0 (patch)
treeeca1ed9dfd36d11848574d0a48d460a9865d1115 /sci-biology/blat/blat-34-r2.ebuild
parentmedia-sound/dagrab: update EAPI 6 -> 8 (diff)
downloadgentoo-b381e310090d0857c4894f4a7134584a73deb1b0.tar.gz
gentoo-b381e310090d0857c4894f4a7134584a73deb1b0.tar.bz2
gentoo-b381e310090d0857c4894f4a7134584a73deb1b0.zip
sci-biology/blat: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology/blat/blat-34-r2.ebuild')
-rw-r--r--sci-biology/blat/blat-34-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-biology/blat/blat-34-r2.ebuild b/sci-biology/blat/blat-34-r2.ebuild
index b07246356381..7c7004cf950e 100644
--- a/sci-biology/blat/blat-34-r2.ebuild
+++ b/sci-biology/blat/blat-34-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,7 +30,7 @@ src_compile() {
tc-export AR CC
export HOME="${S}"
- export MACHTYPE=$(tc-arch)
+ export MACHTYPE="$(tc-arch)"
[[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
mkdir -p bin/${MACHTYPE} || die
@@ -38,7 +38,7 @@ src_compile() {
}
src_install() {
- export MACHTYPE=$(tc-arch)
+ export MACHTYPE="$(tc-arch)"
[[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
dobin bin/${MACHTYPE}/*