summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/blat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/blat')
-rw-r--r--sci-biology/blat/Manifest1
-rw-r--r--sci-biology/blat/blat-34-r1.ebuild45
-rw-r--r--sci-biology/blat/blat-34.ebuild34
-rw-r--r--sci-biology/blat/files/34-gentoo.patch226
-rw-r--r--sci-biology/blat/metadata.xml5
5 files changed, 311 insertions, 0 deletions
diff --git a/sci-biology/blat/Manifest b/sci-biology/blat/Manifest
new file mode 100644
index 000000000000..c1b249e1a095
--- /dev/null
+++ b/sci-biology/blat/Manifest
@@ -0,0 +1 @@
+DIST blatSrc34.zip 2142975 SHA256 b764828fdf8ef4c9994ae4b6148340a776493475edb573b6adf63ae7ca9b2629
diff --git a/sci-biology/blat/blat-34-r1.ebuild b/sci-biology/blat/blat-34-r1.ebuild
new file mode 100644
index 000000000000..c61327420f26
--- /dev/null
+++ b/sci-biology/blat/blat-34-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_PN="${PN}Src"
+
+DESCRIPTION="The BLAST-Like Alignment Tool, a fast genomic sequence aligner"
+HOMEPAGE="http://www.cse.ucsc.edu/~kent/"
+SRC_URI="http://www.soe.ucsc.edu/~kent/src/${MY_PN}${PV}.zip"
+
+SLOT="0"
+LICENSE="blat"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed \
+ -e "1i\CFLAGS=${CFLAGS}" \
+ -e "1i\LDFLAGS=${LDFLAGS}" \
+ -i inc/common.mk || die
+ tc-export CC
+}
+
+src_compile() {
+ MACHTYPE=$(tc-arch)
+ [[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
+ mkdir -p "${S}/bin/${MACHTYPE}"
+ emake MACHTYPE="${MACHTYPE}" HOME="${S}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ MACHTYPE=$(tc-arch)
+ [[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
+ dobin "${S}/bin/${MACHTYPE}/"*
+}
diff --git a/sci-biology/blat/blat-34.ebuild b/sci-biology/blat/blat-34.ebuild
new file mode 100644
index 000000000000..41d48bf26bd3
--- /dev/null
+++ b/sci-biology/blat/blat-34.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="The BLAST-Like Alignment Tool, a fast genomic sequence aligner"
+LICENSE="blat"
+HOMEPAGE="http://www.cse.ucsc.edu/~kent/"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+MY_PN="${PN}Src"
+SRC_URI="http://www.soe.ucsc.edu/~kent/src/${MY_PN}${PV}.zip"
+S="${WORKDIR}/${MY_PN}"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ MACHTYPE=$(tc-arch)
+ [[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
+ sed -i 's/-Werror//; s/CFLAGS=//;' "${S}/inc/common.mk"
+ sed -i 's/\(${STRIP} \)/#\1/' "${S}"/{*/makefile,utils/*/makefile,*/*.mk}
+ mkdir -p "${S}/bin/${MACHTYPE}"
+ emake MACHTYPE="${MACHTYPE}" HOME="${S}" || die "emake failed"
+}
+
+src_install() {
+ MACHTYPE=$(tc-arch)
+ [[ ${MACHTYPE} == "x86" ]] && MACHTYPE="i386"
+ dobin "${S}/bin/${MACHTYPE}/"*
+}
diff --git a/sci-biology/blat/files/34-gentoo.patch b/sci-biology/blat/files/34-gentoo.patch
new file mode 100644
index 000000000000..8bdd05bff68d
--- /dev/null
+++ b/sci-biology/blat/files/34-gentoo.patch
@@ -0,0 +1,226 @@
+ blat/makefile | 2 +-
+ gfClient/makefile | 2 +-
+ gfServer/makefile | 2 +-
+ hg/pslPretty/makefile | 2 +-
+ hg/pslReps/makefile | 2 +-
+ hg/pslSort/makefile | 2 +-
+ inc/common.mk | 11 +++--------
+ makefile | 28 ++++++++++++++--------------
+ utils/faToNib/makefile | 2 +-
+ utils/faToTwoBit/makefile | 2 +-
+ utils/nibFrag/makefile | 2 +-
+ utils/twoBitInfo/makefile | 2 +-
+ utils/twoBitToFa/makefile | 2 +-
+ 13 files changed, 28 insertions(+), 33 deletions(-)
+
+diff --git a/blat/makefile b/blat/makefile
+index b889c7b..739503a 100644
+--- a/blat/makefile
++++ b/blat/makefile
+@@ -7,7 +7,7 @@ MYLIBS = $(MYLIBDIR)/jkOwnLib.a $(MYLIBDIR)/jkweb.a
+ O = blat.o
+
+ blat: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/blat $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/blat $O $(MYLIBS) $L
+ ${STRIP} ${BINDIR}/blat${EXE}
+
+ all:
+diff --git a/gfClient/makefile b/gfClient/makefile
+index c3288de..36e957e 100644
+--- a/gfClient/makefile
++++ b/gfClient/makefile
+@@ -8,5 +8,5 @@ O = gfClient.o
+ X = gfClient
+
+ gfClient: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/$X $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/$X $O $(MYLIBS) $L
+ ${STRIP} ${BINDIR}/$X${EXE}
+diff --git a/gfServer/makefile b/gfServer/makefile
+index c06b3a5..f042d22 100644
+--- a/gfServer/makefile
++++ b/gfServer/makefile
+@@ -8,7 +8,7 @@ O = gfServer.o
+ X = gfServer
+
+ gfServer: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/$X $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/$X $O $(MYLIBS) $L
+ ${STRIP} ${BINDIR}/$X${EXE}
+
+ test:
+diff --git a/hg/pslPretty/makefile b/hg/pslPretty/makefile
+index c780b96..cbbcd0d 100644
+--- a/hg/pslPretty/makefile
++++ b/hg/pslPretty/makefile
+@@ -8,7 +8,7 @@ MYLIBS = $(MYLIBDIR)/jkweb.a
+ O = pslPretty.o
+
+ pslPretty: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/pslPretty $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/pslPretty $O $(MYLIBS) $L
+
+ test:: testRna testDnax
+
+diff --git a/hg/pslReps/makefile b/hg/pslReps/makefile
+index 6e8f6d7..2b73b60 100644
+--- a/hg/pslReps/makefile
++++ b/hg/pslReps/makefile
+@@ -9,7 +9,7 @@ MYLIBS = $(MYLIBDIR)/jkweb.a
+ O = pslReps.o
+
+ pslReps: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/pslReps${EXE} $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/pslReps${EXE} $O $(MYLIBS) $L
+
+ lib:
+ cd ../../lib && ${MAKE}
+diff --git a/hg/pslSort/makefile b/hg/pslSort/makefile
+index 81fe083..eb63257 100644
+--- a/hg/pslSort/makefile
++++ b/hg/pslSort/makefile
+@@ -8,7 +8,7 @@ MYLIBS = $(MYLIBDIR)/jkweb.a
+ O = pslSort.o
+
+ pslSort: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/pslSort $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/pslSort $O $(MYLIBS) $L
+
+
+ lib:
+diff --git a/inc/common.mk b/inc/common.mk
+index 1823163..3a04e2b 100644
+--- a/inc/common.mk
++++ b/inc/common.mk
+@@ -1,20 +1,15 @@
+-CC=gcc
+-ifeq (${COPT},)
+- COPT=-O
+-endif
+-CFLAGS=
+ HG_DEFS=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -DMACHTYPE_${MACHTYPE}
+ HG_WARN=-Wformat -Wimplicit -Wuninitialized -Wreturn-type
+ HG_INC=-I../inc -I../../inc -I../../../inc -I../../../../inc -I../../../../../inc
+
+ # Stronger warning checks, and warnings-->errors, for libraries and CGIs:
+ ifeq (darwin,$(findstring darwin,${OSTYPE}))
+- HG_WARN_ERR = -DJK_WARN -Wall -Werror -Wno-unused-variable
++ HG_WARN_ERR = -DJK_WARN -Wall -Wno-unused-variable
+ else
+ ifeq (solaris,$(findstring solaris,${OSTYPE}))
+ HG_WARN_ERR = -DJK_WARN -Wall
+ else
+- HG_WARN_ERR = -DJK_WARN -Wall -Werror
++ HG_WARN_ERR = -DJK_WARN -Wall
+ endif
+ endif
+ # Apply the stronger checks to all code on our development machine:
+@@ -37,7 +32,7 @@ ifeq (${BINDIR},)
+ endif
+ MKDIR=mkdir -p
+ ifeq (${STRIP},)
+- STRIP=strip
++ STRIP=true
+ endif
+ CVS=cvs
+
+diff --git a/makefile b/makefile
+index 6f9fddf..dded1cd 100644
+--- a/makefile
++++ b/makefile
+@@ -1,18 +1,18 @@
+ all:
+- cd lib && ${MAKE}
+- cd jkOwnLib && ${MAKE}
+- cd blat && $(MAKE)
+- cd gfClient && $(MAKE)
+- cd gfServer && $(MAKE)
+- cd hg/pslPretty && $(MAKE)
+- cd hg/pslReps && $(MAKE)
+- cd hg/pslSort && $(MAKE)
+- cd utils/nibFrag && $(MAKE)
+- cd utils/faToNib && $(MAKE)
+- cd utils/faToTwoBit && $(MAKE)
+- cd utils/twoBitToFa && $(MAKE)
+- cd utils/twoBitInfo && $(MAKE)
+- cd webBlat && $(MAKE)
++ $(MAKE) -C lib
++ $(MAKE) -C jkOwnLib
++ $(MAKE) -C blat
++ $(MAKE) -C gfClient
++ $(MAKE) -C gfServer
++ $(MAKE) -C hg/pslPretty
++ $(MAKE) -C hg/pslReps
++ $(MAKE) -C hg/pslSort
++ $(MAKE) -C utils/nibFrag
++ $(MAKE) -C utils/faToNib
++ $(MAKE) -C utils/faToTwoBit
++ $(MAKE) -C utils/twoBitToFa
++ $(MAKE) -C utils/twoBitInfo
++ $(MAKE) -C webBlat
+
+ clean:
+ rm -f */*.o */*/*.o
+diff --git a/utils/faToNib/makefile b/utils/faToNib/makefile
+index fd0e3eb..63a1593 100644
+--- a/utils/faToNib/makefile
++++ b/utils/faToNib/makefile
+@@ -8,4 +8,4 @@ MYLIBS = $(MYLIBDIR)/jkweb.a
+ O = faToNib.o
+
+ faToNib: $O $(MYLIBS)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/faToNib $O $(MYLIBS) $L
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/faToNib $O $(MYLIBS) $L
+diff --git a/utils/faToTwoBit/makefile b/utils/faToTwoBit/makefile
+index b1b44a9..1e8c1c8 100644
+--- a/utils/faToTwoBit/makefile
++++ b/utils/faToTwoBit/makefile
+@@ -7,7 +7,7 @@ MYLIBS = ${MYLIBDIR}/jkweb.a
+ O = faToTwoBit.o
+
+ faToTwoBit: $O ${MYLIBS}
+- ${CC} ${COPT} -o ${BINDIR}/faToTwoBit $O ${MYLIBS} $L
++ ${CC} ${COPT} ${LDFLAGS} -o ${BINDIR}/faToTwoBit $O ${MYLIBS} $L
+ ${STRIP} ${BINDIR}/faToTwoBit${EXE}
+
+ clean:
+diff --git a/utils/nibFrag/makefile b/utils/nibFrag/makefile
+index 260a6f3..e37b9ab 100755
+--- a/utils/nibFrag/makefile
++++ b/utils/nibFrag/makefile
+@@ -4,7 +4,7 @@ include ../../inc/common.mk
+ O = nibFrag.o
+
+ nibFrag: $(O)
+- ${CC} ${COPT} ${CFLAGS} -o ${BINDIR}/nibFrag $O ../../lib/$(MACHTYPE)/jkweb.a
++ ${CC} ${COPT} ${CFLAGS} ${LDFLAGS} -o ${BINDIR}/nibFrag $O ../../lib/$(MACHTYPE)/jkweb.a
+
+
+
+diff --git a/utils/twoBitInfo/makefile b/utils/twoBitInfo/makefile
+index 649784f..9434d1c 100644
+--- a/utils/twoBitInfo/makefile
++++ b/utils/twoBitInfo/makefile
+@@ -7,7 +7,7 @@ MYLIBS = ${MYLIBDIR}/jkweb.a
+ O = twoBitInfo.o
+
+ twoBitInfo: $O ${MYLIBS}
+- ${CC} ${COPT} -o ${BINDIR}/twoBitInfo $O ${MYLIBS} $L
++ ${CC} ${COPT} ${LDFLAGS} -o ${BINDIR}/twoBitInfo $O ${MYLIBS} $L
+ ${STRIP} ${BINDIR}/twoBitInfo${EXE}
+
+ clean:
+diff --git a/utils/twoBitToFa/makefile b/utils/twoBitToFa/makefile
+index cf979f2..081f3b8 100644
+--- a/utils/twoBitToFa/makefile
++++ b/utils/twoBitToFa/makefile
+@@ -8,7 +8,7 @@ MYLIBS = ${MYLIBDIR}/jkweb.a
+ O = twoBitToFa.o
+
+ twoBitToFa: $O ${MYLIBS}
+- ${CC} ${COPT} -o ${BINDIR}/twoBitToFa $O ${MYLIBS} $L
++ ${CC} ${COPT} ${LDFLAGS} -o ${BINDIR}/twoBitToFa $O ${MYLIBS} $L
+ #${STRIP} ${BINDIR}/twoBitToFa${EXE}
+
+ clean:
diff --git a/sci-biology/blat/metadata.xml b/sci-biology/blat/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/blat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>