summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-04-26 20:48:22 +0200
committerJustin Lecher <jlec@gentoo.org>2016-04-26 20:48:30 +0200
commit38938220c8b6fde207fb7054dbdd8987bfa5085d (patch)
tree1a44c7e508358bdf4165500cf67f13980397fd74 /sci-biology/emboss
parentnet-analyzer/zmap: Version Bump (diff)
downloadgentoo-38938220c8b6fde207fb7054dbdd8987bfa5085d.tar.gz
gentoo-38938220c8b6fde207fb7054dbdd8987bfa5085d.tar.bz2
gentoo-38938220c8b6fde207fb7054dbdd8987bfa5085d.zip
sci-biology/emboss: Clean up of files dir
Move to readme.gentoo-r1.eclass Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=579728 Package-Manager: portage-2.2.28 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/emboss-6.6.0.ebuild9
-rw-r--r--sci-biology/emboss/files/22emboss4
-rw-r--r--sci-biology/emboss/files/6.3.1_p4-unbundle-libs.patch600
-rw-r--r--sci-biology/emboss/files/README.Gentoo28
-rw-r--r--sci-biology/emboss/files/emboss-5.0.0-as-needed.patch24
-rw-r--r--sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch112
-rw-r--r--sci-biology/emboss/files/emboss-README.Gentoo-134
-rw-r--r--sci-biology/emboss/files/emboss-README.Gentoo-234
8 files changed, 7 insertions, 838 deletions
diff --git a/sci-biology/emboss/emboss-6.6.0.ebuild b/sci-biology/emboss/emboss-6.6.0.ebuild
index a853743739c7..5c4c77d8cd39 100644
--- a/sci-biology/emboss/emboss-6.6.0.ebuild
+++ b/sci-biology/emboss/emboss-6.6.0.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils emboss-r1 eutils readme.gentoo
+
+inherit autotools-utils emboss-r1 eutils readme.gentoo-r1
DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
@@ -59,3 +60,7 @@ src_install() {
mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
die "Failed to move CODON directory."
}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sci-biology/emboss/files/22emboss b/sci-biology/emboss/files/22emboss
deleted file mode 100644
index 177643ced11f..000000000000
--- a/sci-biology/emboss/files/22emboss
+++ /dev/null
@@ -1,4 +0,0 @@
-# plplot libs dir
-PLPLOT_LIB="/usr/share/EMBOSS/"
-# ACD files location
-EMBOSS_ACDROOT="/usr/share/EMBOSS/acd"
diff --git a/sci-biology/emboss/files/6.3.1_p4-unbundle-libs.patch b/sci-biology/emboss/files/6.3.1_p4-unbundle-libs.patch
deleted file mode 100644
index 5e463744a739..000000000000
--- a/sci-biology/emboss/files/6.3.1_p4-unbundle-libs.patch
+++ /dev/null
@@ -1,600 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 4fe2ed1..7f3a95f 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -5,12 +5,21 @@ ACLOCAL_AMFLAGS = -I m4
-
- AUTOMAKE_OPTIONS = gnits
-
--SUBDIRS = plplot ajax nucleus emboss test doc jemboss
-+if !ESYSTEMLIBS
-+EXTRA_DIRS = plplot
-+endif
-+
-+if GJEMBOSS
-+JEMBOSS_DIR = jemboss
-+endif
-+
-+SUBDIRS = $(EXTRA_DIRS) ajax nucleus emboss test doc $(JEMBOSS_DIR)
-+DIST_SUBDIRS = $(EXTRA_DIRS) ajax nucleus emboss test doc $(JEMBOSS_DIR)
-
- # AJAX_FIXED_ROOT = \"`pwd`/emboss/acd\"
-
- # files with nonstandard names in this directory
--EXTRA_DIST = COMPAT LICENSE KNOWN_BUGS ONEWS PROBLEMS FAQ ChangeLog depcomp ltmain.sh
-+EXTRA_DIST = COMPAT KNOWN_BUGS ONEWS PROBLEMS FAQ ChangeLog depcomp ltmain.sh
-
- # tar to pick up the other directories
- # then remove any CVS subdirectories
-diff --git a/README.fixes b/README.fixes
-new file mode 100644
-index 0000000..3c56d79
---- /dev/null
-+++ b/README.fixes
-@@ -0,0 +1,9 @@
-+The files in this directory are bugfix replacements for files in
-+the EMBOSS-6.3.1 distribution. Just drop the replacement files in
-+the location shown and redo the 'make install.'
-+
-+Fix 1. EMBOSS-6.3.1/configure
-+ EMBOSS-6.3.1/m4/mysql.m4
-+
-+21 Jul 2010: Addresses a problem whereby, in some circumstances, inclusion of
-+ hpdf support prevented inclusion of MySQL support.
-diff --git a/ajax/Makefile.am b/ajax/Makefile.am
-index 4a44f6f..cf27ff8 100644
---- a/ajax/Makefile.am
-+++ b/ajax/Makefile.am
-@@ -1,6 +1,6 @@
- ## Process this file with automake to produce Makefile.in
- if !ESYSTEMLIBS
--EXTRA_DIRS = expat zlib
-+EXTRA_DIRS = pcre expat zlib
- endif
-
--SUBDIRS = pcre $(EXTRA_DIRS) core graphics ensembl ajaxdb acd
-+SUBDIRS = $(EXTRA_DIRS) core graphics ensembl ajaxdb acd
-diff --git a/ajax/acd/Makefile.am b/ajax/acd/Makefile.am
-index 02bcaa7..368ddfe 100644
---- a/ajax/acd/Makefile.am
-+++ b/ajax/acd/Makefile.am
-@@ -13,10 +13,13 @@ CYGWIN_LDACD = -L../../plplot -L../pcre -L../expat -L../zlib -L../core \
- endif
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
-+else
-+EXTRA_INCLUDES = $(PLPLOT_CFLAGS)
- endif
-
--INCLUDES = -I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre \
-+INCLUDES = \
- $(EXTRA_INCLUDES) \
- -I$(top_srcdir)/ajax/core \
- -I$(top_srcdir)/ajax/graphics \
-@@ -38,3 +41,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libacd_la_LDFLAGS = $(LINKFLAGS)
-+libacd_la_LIBADD = ../core/libajax.la ../graphics/libajaxg.la ../ajaxdb/libajaxdb.la
-diff --git a/ajax/ajaxdb/Makefile.am b/ajax/ajaxdb/Makefile.am
-index da57727..857ca5f 100644
---- a/ajax/ajaxdb/Makefile.am
-+++ b/ajax/ajaxdb/Makefile.am
-@@ -13,11 +13,12 @@ CYGWIN_LDAJAXDB = -L../../plplot -L../pcre -L../expat -L../zlib -L../core \
- endif
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
- endif
-
-
--INCLUDES = -I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre \
-+INCLUDES = \
- $(EXTRA_INCLUDES) \
- -I$(top_srcdir)/ajax/core -I$(top_srcdir)/ajax/ensembl
-
-@@ -37,3 +38,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libajaxdb_la_LDFLAGS = $(LINKFLAGS)
-+libajaxdb_la_LIBADD = ../core/libajax.la ../ensembl/libensembl.la
-diff --git a/ajax/core/Makefile.am b/ajax/core/Makefile.am
-index af27cb0..8fa4a3a 100644
---- a/ajax/core/Makefile.am
-+++ b/ajax/core/Makefile.am
-@@ -12,13 +12,18 @@ CYGWIN_LDAJAX = -L../../plplot -L../expat -L../pcre -L../zlib \
- endif
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
-+else
-+EXTRA_LIBS = -lexpat -lpcre
- endif
-
-+EXTRA_DIST = ajax-pcre-config.h.in
-+DISTCLEAN = ajax-pcre-config.h
-
- INCLUDES = -DAJAX_FIXED_ROOT=$(AJAX_FIXED_ROOT) \
- -DAJAX_SYSTEM="$(AJAX_SYSTEM)" -DPREFIX=\"$(prefix)\" \
---I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre $(EXTRA_INCLUDES)
-+$(EXTRA_INCLUDES) $(POSTGRESQL_CFLAGS) $(MYSQL_CFLAGS)
-
- AJAXSRC = ajalign.c ajarr.c ajassert.c \
- ajbase.c ajcall.c ajcod.c \
-@@ -44,7 +49,7 @@ ajindex.h ajjava.h ajlist.h \
- ajmath.h ajmatrices.h ajmem.h ajmess.h \
- ajnam.h ajnexus.h ajobo.h \
- ajpat.h ajpdb.h ajpdbio.h ajphylo.h \
--ajrange.h ajreg.h ajreport.h ajresource.h \
-+ajrange.h ajreg.h ajax-pcre-config.h ajreport.h ajresource.h \
- ajseq.h ajseqabi.h ajseqbam.h ajseqdata.h ajseqread.h ajseqtype.h ajseqwrite.h \
- ajsort.h ajsql.h ajstr.h ajsys.h \
- ajtable.h ajtax.h ajtime.h ajtranslate.h ajtree.h ajutil.h ajvector.h
-@@ -61,3 +66,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libajax_la_LDFLAGS = $(LINKFLAGS)
-+libajax_la_LIBADD = $(EXTRA_LIBS) $(POSTGRESQL_LDFLAGS) $(MYSQL_LDFLAGS)
-diff --git a/ajax/core/ajax-pcre-config.h.in b/ajax/core/ajax-pcre-config.h.in
-new file mode 100644
-index 0000000..b09e4e6
---- /dev/null
-+++ b/ajax/core/ajax-pcre-config.h.in
-@@ -0,0 +1 @@
-+@DEFINE_USE_SYSTEM_PCRE@ AJAX_USE_SYSTEM_PCRE
-diff --git a/ajax/core/ajreg.h b/ajax/core/ajreg.h
-index 06793be..659f462 100644
---- a/ajax/core/ajreg.h
-+++ b/ajax/core/ajreg.h
-@@ -16,9 +16,14 @@ extern "C"
- #define ajreg_h
-
- #include "ajax.h"
-+#include "ajax-pcre-config.h"
-+#ifndef AJAX_USE_SYSTEM_PCRE
- #include "pcre_config.h"
- #include "pcre_internal.h"
- #include "pcreposix.h"
-+#else
-+#include <pcre.h>
-+#endif
-
- #define AJREG_OVECSIZE 30
-
-@@ -41,7 +46,11 @@ extern "C"
- ******************************************************************************/
-
- typedef struct AjSRegexp {
-+#ifndef AJAX_USE_SYSTEM_PCRE
- real_pcre *pcre;
-+#else
-+ pcre *pcre;
-+#endif
- pcre_extra *extra;
- int *ovector;
- const char* orig;
-diff --git a/ajax/ensembl/Makefile.am b/ajax/ensembl/Makefile.am
-index ca33a84..87e51bd 100644
---- a/ajax/ensembl/Makefile.am
-+++ b/ajax/ensembl/Makefile.am
-@@ -10,12 +10,13 @@ CYGWIN_LDENSEMBL = -L../../plplot -L../expat -L../pcre -L../core -lajax -leplplo
- endif
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
- endif
-
-
--INCLUDES = -I$(top_srcdir)/plplot $(EXTRA_INCLUDES) \
---I$(top_srcdir)/ajax/pcre -I$(top_srcdir)/ajax/core
-+INCLUDES = $(EXTRA_INCLUDES) \
-+-I$(top_srcdir)/ajax/core
-
- ENSEMBLSRC = ensanalysis.c ensassembly.c ensassemblyexception.c \
- ensassemblymapper.c ensattribute.c ensbaseadaptor.c enscache.c \
-@@ -56,3 +57,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libensembl_la_LDFLAGS = $(LINKFLAGS)
-+libensembl_la_LIBADD = ../core/libajax.la
-diff --git a/ajax/graphics/Makefile.am b/ajax/graphics/Makefile.am
-index ab45afc..f61c605 100644
---- a/ajax/graphics/Makefile.am
-+++ b/ajax/graphics/Makefile.am
-@@ -10,11 +10,15 @@ CYGWIN_LDAJAXG = -L../../plplot -L../expat -L../pcre -L../core -lajax -leplplot
- endif
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
-+else
-+EXTRA_INCLUDES = $(PLPLOT_CFLAGS) -DUSE_PLXSFNAM_SHIM
-+EXTRA_LIBS = $(PLPLOT_LIBS)
- endif
-
-
--INCLUDES = -I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre \
-+INCLUDES = \
- $(EXTRA_INCLUDES) -I$(top_srcdir)/ajax/core
-
- AJAXGSRC = ajgraph.c ajhist.c
-@@ -32,3 +36,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libajaxg_la_LDFLAGS = $(LINKFLAGS)
-+libajaxg_la_LIBADD = ../core/libajax.la $(EXTRA_LIBS)
-diff --git a/ajax/graphics/ajgraph.c b/ajax/graphics/ajgraph.c
-index 25e75e4..60f2743 100644
---- a/ajax/graphics/ajgraph.c
-+++ b/ajax/graphics/ajgraph.c
-@@ -34,10 +34,8 @@
- #include <float.h>
- #define AZ 28
-
--
- #include "plplotP.h"
-
--
- static void GraphArray(ajuint numofpoints,
- float *x, float *y);
- static void GraphArrayGaps(ajuint numofpoints,
-@@ -1049,13 +1047,26 @@ static void GraphDefCharSize(float size)
- ** @@
- ******************************************************************************/
-
-+#define _GNU_SOURCE
-+#include <stdio.h>
-+
- static void GraphSetName(const AjPGraph thys,
- const AjPStr txt, const char *ext)
- {
- if(!thys->ready)
- {
-+#ifdef USE_PLXSFNAM_SHIM
-+ char *fullname;
-+#endif
- ajDebug("=g= plxsfnam ('%S', '%s')\n", txt, ext);
-+#ifdef USE_PLXSFNAM_SHIM
-+ fullname = asprintf(fullname,"%s%s", ajStrGetPtr(txt), ext);
-+ ajDebug("=g= plsfnam ('%S') instead\n", fullname);
-+ plsfnam(fullname);
-+ free(fullname);
-+#else
- plxsfnam(ajStrGetPtr(txt), ext);
-+#endif
- ajStrAssignS(&graphBasename, txt);
- ajStrAssignC(&graphExtension, ext);
- if(ajStrGetCharFirst(graphExtension) == '.')
-diff --git a/configure.in b/configure.in
-index ddb4f81..3f4fe5e 100644
---- a/configure.in
-+++ b/configure.in
-@@ -235,15 +235,6 @@ AC_PROG_INSTALL
- AC_PROG_LN_S
- AC_PROG_MAKE_SET
-
--dnl Intel MacOSX 10.6 puts X11 in a non-standard place
--if test "${with_x}" != "no" ; then
--if test "`uname -a | grep Darwin`"; then
--OSXX=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
--if test ${OSXX} '>' '10.4'; then
--CFLAGS="$CFLAGS -I/usr/X11/include -L/usr/X11/lib"
--fi
--fi
--fi
-
- # Checks for header files.
- #as# AC_PATH_X
-@@ -292,9 +283,6 @@ AC_CHECK_FUNCS(memmove)
- #as# select socket sqrt strchr strcspn strdup strerror strpbrk \
- #as# strrchr strspn strstr strtol])
-
--if test "${with_x}" != "no" ; then
--LF_EMBOSS_PATH_XLIB
--fi
-
- dnl Library checks
- AC_CHECK_LIB(c, socket, LIBS="$LIBS" , LIBS="$LIBS -lsocket")
-@@ -316,14 +304,16 @@ CHECK_PNGDRIVER
- CHECK_AUTH
- CHECK_AMD64
-
-+AM_CONDITIONAL(GJEMBOSS, test "$JAVA_OK" = "yes")
-+
- AX_LIB_MYSQL
- AX_LIB_POSTGRESQL
-
- CFLAGS="$CFLAGS $MYSQL_CFLAGS"
- LDFLAGS="$LDFLAGS $MYSQL_LDFLAGS"
-
--CFLAGS="$CFLAGS $POSTGRESQL_CFLAGS"
--LDFLAGS="$LDFLAGS $POSTGRESQL_LDFLAGS"
-+CFLAGS="$POSTGRESQL_CFLAGS $CFLAGS"
-+LDFLAGS="$POSTGRESQL_LDFLAGS $LDFLAGS"
-
-
- dnl Check for 'ant' for packaging Jemboss and export result
-@@ -443,13 +433,36 @@ fi
-
- dnl Test if --enable-systemlibs given
- have_systemlibs=no
-+DEFINE_USE_SYSTEM_PCRE="#undef"
- AC_ARG_ENABLE(systemlibs,
- AS_HELP_STRING([--enable-systemlibs], [utility for RPM/dpkg bundles]))
-+AC_MSG_CHECKING(for systemlib usage)
- if test "${enable_systemlibs}" = "yes" ; then
- have_systemlibs=yes
-+ DEFINE_USE_SYSTEM_PCRE="#define"
-+ PKG_CHECK_MODULES([PLPLOT], [plplotd])
-+ PKG_CHECK_MODULES([ZLIB], [zlib])
-+else
-+ dnl X11 is only used by plplot
-+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
-+ if test "${with_x}" != "no" ; then
-+ if test "`uname -a | grep Darwin`"; then
-+ OSXX=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
-+ if test ${OSXX} '>' '10.4'; then
-+ CFLAGS="$CFLAGS -I/usr/X11/include -L/usr/X11/lib"
-+ fi
-+ fi
-+ fi
-+ if test "${with_x}" != "no" ; then
-+ LF_EMBOSS_PATH_XLIB
-+ fi
-+ AC_MSG_NOTICE(USING bundled LIBS)
- fi
- AM_CONDITIONAL(ESYSTEMLIBS, test "$have_systemlibs" = "yes")
- AC_SUBST(ESYSTEMLIBS)
-+AC_SUBST(DEFINE_USE_SYSTEM_PCRE)
-+AC_SUBST(PLPLOT_CFLAGS)
-+AC_SUBST(PLPLOT_LIBS)
-
-
-
-@@ -457,7 +470,6 @@ AC_SUBST(ESYSTEMLIBS)
-
- dnl Test if purify exists and if --enable-purify given if so
- dnl set "-g"
--
- AC_MSG_CHECKING(for purify)
- dnl if(purify -version) < /dev/null > /dev/null 2>&1; then
- AC_ARG_ENABLE(purify,
-@@ -683,6 +695,7 @@ CHECK_THREADS
-
-
- AC_OUTPUT([plplot/Makefile plplot/lib/Makefile nucleus/Makefile ajax/Makefile
-+ajax/core/ajax-pcre-config.h
- ajax/pcre/Makefile ajax/expat/Makefile ajax/zlib/Makefile ajax/core/Makefile
- ajax/graphics/Makefile ajax/ensembl/Makefile ajax/ajaxdb/Makefile
- ajax/acd/Makefile
-diff --git a/emboss/Makefile.am b/emboss/Makefile.am
-index 0820517..a0257b2 100644
---- a/emboss/Makefile.am
-+++ b/emboss/Makefile.am
-@@ -79,14 +79,17 @@ wordcount wordfinder wordmatch wossname \
- yank
-
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
-+else
-+EXTRA_INCLUDES = $(PLPLOT_CFLAGS)
- endif
-
--INCLUDES = -I$(top_srcdir)/nucleus -I$(top_srcdir)/ajax/pcre \
-+INCLUDES = -I$(top_srcdir)/nucleus \
- $(EXTRA_INCLUDES) \
- -I$(top_srcdir)/ajax/core -I$(top_srcdir)/ajax/graphics \
- -I$(top_srcdir)/ajax/ensembl -I$(top_srcdir)/ajax/ajaxdb \
-- -I$(top_srcdir)/ajax/acd -I$(top_srcdir)/plplot
-+ -I$(top_srcdir)/ajax/acd
-
-
- aaindexextract_SOURCES = aaindexextract.c
-@@ -319,7 +322,7 @@ testplot_SOURCES = testplot.c
- treetypedisplay_SOURCES = treetypedisplay.c
-
- if !ESYSTEMLIBS
--EXTRA_LDS = ../ajax/zlib/libezlib.la ../ajax/expat/libeexpat.la
-+EXTRA_LDS = ../ajax/zlib/libezlib.la ../ajax/expat/libeexpat.la ../plplot/libeplplot.la ../ajax/pcre/libepcre.la
- endif
-
-
-@@ -327,7 +330,6 @@ LDADD = ../nucleus/libnucleus.la ../ajax/acd/libacd.la \
- ../ajax/ajaxdb/libajaxdb.la ../ajax/ensembl/libensembl.la \
- ../ajax/graphics/libajaxg.la ../ajax/core/libajax.la \
- $(EXTRA_LDS) \
-- ../ajax/pcre/libepcre.la ../plplot/libeplplot.la \
- $(XLIB)
-
- pkgdata_DATA = emboss.default.template
-diff --git a/m4/mysql.m4 b/m4/mysql.m4
-index fe413af..ebea25c 100644
---- a/m4/mysql.m4
-+++ b/m4/mysql.m4
-@@ -1,4 +1,6 @@
--##### http://autoconf-archive.cryp.to/ax_lib_mysql.html
-+# ===========================================================================
-+# http://www.gnu.org/software/autoconf-archive/ax_lib_mysql.html
-+# ===========================================================================
- #
- # SYNOPSIS
- #
-@@ -6,19 +8,18 @@
- #
- # DESCRIPTION
- #
--# This macro provides tests of availability of MySQL client library
--# of particular version or newer.
-+# This macro provides tests of availability of MySQL client library of
-+# particular version or newer.
- #
--# AX_LIB_MYSQL macro takes only one argument which is optional. If
--# there is no required version passed, then macro does not run
--# version test.
-+# AX_LIB_MYSQL macro takes only one argument which is optional. If there
-+# is no required version passed, then macro does not run version test.
- #
- # The --with-mysql option takes one of three possible values:
- #
- # no - do not check for MySQL client library
- #
--# yes - do check for MySQL library in standard locations
--# (mysql_config should be in the PATH)
-+# yes - do check for MySQL library in standard locations (mysql_config
-+# should be in the PATH)
- #
- # path - complete path to mysql_config utility, use this option if
- # mysql_config can't be found in the PATH
-@@ -33,27 +34,23 @@
- #
- # HAVE_MYSQL
- #
--# LAST MODIFICATION
-+# LICENSE
- #
--# 2006-07-16
--# 2007-01-09 MS: mysql_config --cflags may set gcc -fomit-frame-pointers,
--# which prevents gdb from displaying stack traces.
--# Changed mysql_config --cflags to mysql_config --include
-+# Copyright (c) 2008 Mateusz Loskot <mateusz@loskot.net>
- #
--# COPYLEFT
--#
--# Copyright (c) 2006 Mateusz Loskot <mateusz@loskot.net>
--#
--# Copying and distribution of this file, with or without
--# modification, are permitted in any medium without royalty provided
--# the copyright notice and this notice are preserved.
-+# Copying and distribution of this file, with or without modification, are
-+# permitted in any medium without royalty provided the copyright notice
-+# and this notice are preserved. This file is offered as-is, without any
-+# warranty.
-+
-+#serial 12
-
- AC_DEFUN([AX_LIB_MYSQL],
- [
- AC_ARG_WITH([mysql],
-- [AS_HELP_STRING([--with-mysql=@<:@ARG@:>@],
-+ AS_HELP_STRING([--with-mysql=@<:@ARG@:>@],
- [use MySQL client library @<:@default=yes@:>@, optionally specify path to mysql_config]
-- )],
-+ ),
- [
- if test "$withval" = "no"; then
- want_mysql="no"
-@@ -66,19 +63,20 @@ AC_DEFUN([AX_LIB_MYSQL],
- ],
- [want_mysql="yes"]
- )
-+ AC_ARG_VAR([MYSQL_CONFIG], [Full path to mysql_config program])
-
- MYSQL_CFLAGS=""
- MYSQL_LDFLAGS=""
- MYSQL_VERSION=""
-
- dnl
-- dnl Check MySQL libraries (libpq)
-+ dnl Check MySQL libraries
- dnl
-
- if test "$want_mysql" = "yes"; then
-
-- if test -z "$MYSQL_CONFIG" -o test; then
-- AC_PATH_PROG([MYSQL_CONFIG], [mysql_config], [no])
-+ if test -z "$MYSQL_CONFIG" ; then
-+ AC_PATH_PROGS([MYSQL_CONFIG], [mysql_config mysql_config5], [no])
- fi
-
- if test "$MYSQL_CONFIG" != "no"; then
-@@ -90,35 +88,8 @@ dnl MYSQL_CFLAGS="`$MYSQL_CONFIG --cflags`"
-
- MYSQL_VERSION=`$MYSQL_CONFIG --version`
-
--dnl It isn't enough to just test for mysql_config as Fedora
--dnl provides it in the mysql RPM even though mysql-devel may
--dnl not be installed
--
-- EMBCFLAGS=$CFLAGS
-- EMBLDFLAGS=$LDFLAGS
-- CFLAGS=$MYSQL_CFLAGS
-- LDFLAGS=$MYSQL_LDFLAGS
--
-- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>
-- #include "mysql.h"]],
-- [[mysql_info(NULL)]])],
-- [havemysql=yes],
-- [havemysql=no])
--
-- CFLAGS=$EMBCFLAGS
-- LDFLAGS=$EMBLDFLAGS
--
-- if test "$havemysql" = yes; then
-- AC_DEFINE([HAVE_MYSQL], [1],
-- [Define to 1 if MySQL libraries are available])
-- found_mysql="yes"
-- AC_MSG_RESULT([yes])
-- else
-- MYSQL_CFLAGS=""
-- MYSQL_LDFLAGS=""
-- found_mysql="no"
-- AC_MSG_RESULT([no])
-- fi
-+ found_mysql="yes"
-+ AC_MSG_RESULT([yes])
- else
- found_mysql="no"
- AC_MSG_RESULT([no])
-@@ -170,6 +141,11 @@ dnl not be installed
- fi
- fi
-
-+ if test "$found_mysql" = "yes" ; then
-+ AC_DEFINE([HAVE_MYSQL], [1],
-+ [Define to 1 if MySQL libraries are available])
-+ fi
-+
- AC_SUBST([MYSQL_VERSION])
- AC_SUBST([MYSQL_CFLAGS])
- AC_SUBST([MYSQL_LDFLAGS])
-diff --git a/nucleus/Makefile.am b/nucleus/Makefile.am
-index c244786..ff301b9 100644
---- a/nucleus/Makefile.am
-+++ b/nucleus/Makefile.am
-@@ -19,13 +19,16 @@ CYGWIN_LIBS = -L../plplot -L../ajax/pcre -L../ajax/expat -L../ajax/zlib \
- -lezlib -leplplot
- else
- if !ESYSTEMLIBS
--EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib
-+EXTRA_INCLUDES = -I$(top_srcdir)/ajax/expat -I$(top_srcdir)/ajax/zlib \
-+-I$(top_srcdir)/plplot -I$(top_srcdir)/ajax/pcre
-+else
-+EXTRA_INCLUDES = $(PLPLOT_CFLAGS)
- endif
- endif
-
-
--INCLUDES = -I$(top_srcdir)/plplot $(X_CFLAGS) -I$(srcdir)/ \
-- -I$(top_srcdir)/ajax -I$(top_srcdir)/ajax/pcre \
-+INCLUDES = $(X_CFLAGS) -I$(srcdir)/ \
-+ -I$(top_srcdir)/ajax \
- $(EXTRA_INCLUDES) \
- -I$(top_srcdir)/ajax/core -I$(top_srcdir)/ajax/graphics \
- -I$(top_srcdir)/ajax/ensembl -I$(top_srcdir)/ajax/ajaxdb \
-@@ -55,3 +58,4 @@ LINKFLAGS = $(VERS_INF)
- endif
-
- libnucleus_la_LDFLAGS = $(LINKFLAGS)
-+libnucleus_la_LIBADD = ../ajax/core/libajax.la ../ajax/graphics/libajaxg.la ../ajax/acd/libacd.la
diff --git a/sci-biology/emboss/files/README.Gentoo b/sci-biology/emboss/files/README.Gentoo
deleted file mode 100644
index ce37576f0fc4..000000000000
--- a/sci-biology/emboss/files/README.Gentoo
+++ /dev/null
@@ -1,28 +0,0 @@
-Using EMBOSS on Gentoo systems
-
-Codon data files location
-
-The codon data files that are distributed with EMBOSS are installed in the
-"/usr/share/EMBOSS/data/CODONS.orig" directory instead of the usual
-"/usr/share/EMBOSS/data/CODONS". This is done to avoid confusion between these
-codon files and those installed with the CUTG database. The names of these files
-sometimes vary only by their case. Having both sets of files in the same directory
-is also impossible on systems such as MacOSX, where the root filesystem is case
-insensitive. If you do not have the CUTG database installed and want to use the
-codon files distributed with EMBOSS, you can symlink the "CODONS.orig" directory
-to "CODONS":
-
- cd /usr/share/EMBOSS/data
- ln -s CODONS.orig CODONS
-
-Restriction enzymes equivalence file location
-
-The restriction enzymes equivalence file distributed with EMBOSS is installed as
-"/usr/share/EMBOSS/data/embossre.equ.orig" rather than the usual
-"/usr/share/EMBOSS/data/embossre.equ". This is done to avoid a file collision
-with the equivalence file provided by the Rebase database. If you do not have the
-Rebase database installed and want to use the equivalence file distributed with
-EMBOSS, you can symlink the "embossre.equ.orig" file to "embossre.equ":
-
- cd /usr/share/EMBOSS/data
- ln -s embossre.equ.orig embossre.equ
diff --git a/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch b/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch
deleted file mode 100644
index 9915f95376d0..000000000000
--- a/sci-biology/emboss/files/emboss-5.0.0-as-needed.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur EMBOSS-5.0.0.old/ajax/Makefile.in EMBOSS-5.0.0/ajax/Makefile.in
---- EMBOSS-5.0.0.old/ajax/Makefile.in 2007-07-12 05:53:32.000000000 -0500
-+++ EMBOSS-5.0.0/ajax/Makefile.in 2008-01-25 16:43:51.000000000 -0500
-@@ -244,7 +244,7 @@
- top_srcdir = @top_srcdir@
- @ISCYGWIN_FALSE@lib_LTLIBRARIES = libajax.la libajaxg.la
- @ISCYGWIN_TRUE@lib_LTLIBRARIES = libajax.la
--@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS =
-+@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS = -lm -L../plplot/.libs -leplplot
- @ISAIXIA64_TRUE@@ISSHARED_TRUE@@NEEDAJAX_FALSE@AM_CFLAGS = -Wl,-G -L../plplot/.libs -L.libs -leplplot -lm
- @ISAIXIA64_TRUE@@ISSHARED_TRUE@@NEEDAJAX_TRUE@AM_CFLAGS = -Wl,-G -L../plplot/.libs -L.libs -lajax -leplplot -lm
- @ISCYGWIN_TRUE@AM_LDFLAGS = -no-undefined -Wl,--add-stdcall-alias -Wl,--export-all-symbols -Wl,--enable-auto-import -L../plplot -leplplot
-diff -Naur EMBOSS-5.0.0.old/plplot/Makefile.in EMBOSS-5.0.0/plplot/Makefile.in
---- EMBOSS-5.0.0.old/plplot/Makefile.in 2007-07-12 05:53:36.000000000 -0500
-+++ EMBOSS-5.0.0/plplot/Makefile.in 2008-01-25 16:42:51.000000000 -0500
-@@ -229,7 +229,7 @@
- lib_LTLIBRARIES = libeplplot.la
- @AMPNG_FALSE@@ISAIXIA64_TRUE@@ISSHARED_TRUE@AM_CFLAGS = -Wl,-G -lX11
- @AMPNG_TRUE@@ISAIXIA64_TRUE@@ISSHARED_TRUE@AM_CFLAGS = -Wl,-G -lgd -lpng -lz -lX11 -lm
--@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS =
-+@ISAIXIA64_FALSE@@ISSHARED_TRUE@AM_CFLAGS = PATCH_PLPLOT
- @ISCYGWIN_TRUE@AM_LDFLAGS = -no-undefined -Wl,--add-stdcall-alias -Wl,--export-all-symbols -Wl,--enable-auto-import -lX11 -lgd -lpng -lz
- INCLUDES = $(X_CFLAGS) -I$(srcdir)/ -I/usr/include/gd -DPREFIX=\"$(prefix)\" -DBUILD_DIR=\"$(srcdir)\" -DDRV_DIR=\"$(srcdir)\" -DEMBOSS_TOP=\"$(EMBOSS_TOP)\"
- PLPLOTSRC = pdfutils.c plargs.c plbox.c plcont.c plcore.c \
diff --git a/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch b/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch
deleted file mode 100644
index 0f5e592b77f1..000000000000
--- a/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch
+++ /dev/null
@@ -1,112 +0,0 @@
---- EMBOSS-6.3.1/ajax/graphics/ajgraph.c 2012-07-19 23:29:05.000000000 +0200
-+++ /tmp/ajgraph.c 2012-07-19 23:25:00.000000000 +0200
-@@ -1645,14 +1645,14 @@
- ** @return [void]
- ** @@
- ******************************************************************************/
-
- static void GraphSetPen(ajint colour)
- {
-- ajDebug("=g= plcol(%d '%s') [colour]\n", colour, graphColourName[colour]);
-- plcol((PLINT)colour);
-+ ajDebug("=g= plcol0(%d '%s') [colour]\n", colour, graphColourName[colour]);
-+ plcol0((PLINT)colour);
-
- return;
- }
-
-
-
---- EMBOSS-6.3.1/plplot/plcore.c 2007-10-24 15:14:43.000000000 +0200
-+++ /tmp/plcore.c 2012-07-19 23:25:00.000000000 +0200
-@@ -1709,13 +1709,13 @@
- if (plsc->zdigmax == 0)
- plsc->zdigmax = 3;
-
- /* Switch to graphics mode and set color and arrow style*/
-
- plgra();
-- plcol(1);
-+ plcol0(1);
-
- plstyl(0, &mk, &sp);
- plpat(1, &inc, &del);
-
- plsvect(def_arrow_x, def_arrow_y, 6, 0);
-
---- EMBOSS-6.3.1/plplot/plstripc.c 2007-05-08 11:09:37.000000000 +0200
-+++ /tmp/plstripc.c 2012-07-19 23:25:00.000000000 +0200
-@@ -153,17 +153,17 @@
-
- plgchr(&sc, &dy);
- sc = dy = dy/100;
- plwind(-0.01, 1.01, -0.01, 1.01);
- for (i=0; i<PEN; i++) {
- if (mystripc->npts[i] || first) {
-- plcol(mystripc->colline[i]);
-+ plcol0(mystripc->colline[i]);
- pllsty(mystripc->styline[i]);
- pljoin(mystripc->xlpos, mystripc->ylpos - sc,
- mystripc->xlpos + 0.1, mystripc->ylpos - sc);
-- plcol(mystripc->collab);
-+ plcol0(mystripc->collab);
- plptex(mystripc->xlpos + 0.11, mystripc->ylpos - sc,
- 0., 0., 0, mystripc->legline[i]);
- sc += dy;
- }
- }
- plwind(mystripc->xmin, mystripc->xmax, mystripc->ymin, mystripc->ymax);
-@@ -184,34 +184,34 @@
- PLFLT x[]={0.,1.,1.,0.}, y[]={0.,0.,1.,1.};
-
- /* Set up window */
-
- plvpor(0,1,0,1);
- plwind(0,1,0,1);
-- plcol(0);plpsty(0);
-+ plcol0(0);plpsty(0);
- plfill(4, &x[0], &y[0]);
- plvsta();
-
- /* Draw box and same window dimensions */
- mystrip->wxmin=mystrip->xmin;
- mystrip->wxmax=mystrip->xmax;
- mystrip->wymin=mystrip->ymin;
- mystrip->wymax=mystrip->ymax; /* FIXME - can exist some redundancy here */
-
- plwind(mystrip->xmin, mystrip->xmax, mystrip->ymin, mystrip->ymax);
-
- pllsty(1);
-- plcol(mystrip->colbox);
-+ plcol0(mystrip->colbox);
- plbox(mystrip->xspec, 0.0, 0, mystrip->yspec, 0.0, 0);
-
-- plcol(mystrip->collab);
-+ plcol0(mystrip->collab);
- pllab(mystrip->labx, mystrip->laby, mystrip->labtop);
-
- for (i=0; i<PEN; i++) {
- if (mystrip->npts[i] > 0) {
-- plcol(mystrip->colline[i]);pllsty(mystrip->styline[i]);
-+ plcol0(mystrip->colline[i]);pllsty(mystrip->styline[i]);
- plline(mystrip->npts[i], mystrip->x[i], mystrip->y[i]);
- }
- }
-
- plstrip_legend(mystrip,0);
- }
-@@ -269,13 +269,13 @@
- if (stripc->xmax - stripc->xmin < stripc->xlen) {
- if( yasc == 0) {
-
- /* If user has changed subwindow, make shure we have the correct one */
- plvsta();
- plwind(stripc->wxmin, stripc->wxmax, stripc->wymin, stripc->wymax); /* FIXME - can exist some redundancy here */
-- plcol(stripc->colline[p]); pllsty(stripc->styline[p]);
-+ plcol0(stripc->colline[p]); pllsty(stripc->styline[p]);
- if ((stripc->npts[p]-2) < 0)
- plP_movwor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
- else
- plP_movwor(stripc->x[p][stripc->npts[p]-2], stripc->y[p][stripc->npts[p]-2]);
- plP_drawor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
- plflush();
diff --git a/sci-biology/emboss/files/emboss-README.Gentoo-1 b/sci-biology/emboss/files/emboss-README.Gentoo-1
deleted file mode 100644
index 81e71988ae80..000000000000
--- a/sci-biology/emboss/files/emboss-README.Gentoo-1
+++ /dev/null
@@ -1,34 +0,0 @@
-Administrating EMBOSS on Gentoo systems
-=======================================
-
-
-Codon data files location
--------------------------
-
-The codon data files that are distributed with EMBOSS are installed in the
-``/usr/share/EMBOSS/data/CODONS.orig`` directory instead of the usual
-``/usr/share/EMBOSS/data/CODONS``. This is done to avoid confusion between
-these codon files and those installed with the CUTG database. The names of
-these files sometimes vary only by their case. Having both sets of files in
-the same directory is also impossible on systems such as MacOSX, where the
-root filesystem is case insensitive. If you do not have the CUTG database
-installed and want to use the codon files distributed with EMBOSS, you can
-symlink the ``CODONS.orig`` directory to ``CODONS``::
-
- # cd /usr/share/EMBOSS/data
- # ln -s CODONS.orig CODONS
-
-
-Restriction enzymes equivalence file location
----------------------------------------------
-
-The restriction enzymes equivalence file distributed with EMBOSS is installed
-as ``/usr/share/EMBOSS/data/embossre.equ.orig`` rather than the usual
-``/usr/share/EMBOSS/data/embossre.equ``. This is done to avoid a file
-collision with the equivalence file provided by the Rebase database. If you do
-not have the Rebase database installed and want to use the equivalence file
-distributed with EMBOSS, you can symlink the ``embossre.equ.orig`` file to
-``embossre.equ``::
-
- # cd /usr/share/EMBOSS/data
- # ln -s embossre.equ.orig embossre.equ
diff --git a/sci-biology/emboss/files/emboss-README.Gentoo-2 b/sci-biology/emboss/files/emboss-README.Gentoo-2
deleted file mode 100644
index 72fa3662c9a8..000000000000
--- a/sci-biology/emboss/files/emboss-README.Gentoo-2
+++ /dev/null
@@ -1,34 +0,0 @@
-Administrating EMBOSS on Gentoo systems
-=======================================
-
-
-Codon data files location
--------------------------
-
-The codon data files that are distributed with EMBOSS are installed in the
-``EPREFIX/usr/share/EMBOSS/data/CODONS.orig`` directory instead of the usual
-``EPREFIX/usr/share/EMBOSS/data/CODONS``. This is done to avoid confusion between
-these codon files and those installed with the CUTG database. The names of
-these files sometimes vary only by their case. Having both sets of files in
-the same directory is also impossible on systems such as MacOSX, where the
-root filesystem is case insensitive. If you do not have the CUTG database
-installed and want to use the codon files distributed with EMBOSS, you can
-symlink the ``CODONS.orig`` directory to ``CODONS``::
-
- # cd EPREFIX/usr/share/EMBOSS/data
- # ln -s CODONS.orig CODONS
-
-
-Restriction enzymes equivalence file location
----------------------------------------------
-
-The restriction enzymes equivalence file distributed with EMBOSS is installed
-as ``EPREFIX/usr/share/EMBOSS/data/embossre.equ.orig`` rather than the usual
-``EPREFIX/usr/share/EMBOSS/data/embossre.equ``. This is done to avoid a file
-collision with the equivalence file provided by the Rebase database. If you do
-not have the Rebase database installed and want to use the equivalence file
-distributed with EMBOSS, you can symlink the ``embossre.equ.orig`` file to
-``embossre.equ``::
-
- # cd EPREFIX/usr/share/EMBOSS/data
- # ln -s embossre.equ.orig embossre.equ