summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/fasta/fasta-36.3.5e.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/fasta/fasta-36.3.5e.ebuild')
-rw-r--r--sci-biology/fasta/fasta-36.3.5e.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/sci-biology/fasta/fasta-36.3.5e.ebuild b/sci-biology/fasta/fasta-36.3.5e.ebuild
new file mode 100644
index 000000000000..a9466820c4e8
--- /dev/null
+++ b/sci-biology/fasta/fasta-36.3.5e.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="FASTA is a DNA and Protein sequence alignment software package"
+HOMEPAGE="http://fasta.bioch.virginia.edu/fasta_www2/fasta_down.shtml"
+SRC_URI="http://faculty.virginia.edu/wrpearson/${PN}/${PN}36/${P}.tar.gz"
+
+LICENSE="fasta"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="debug cpu_flags_x86_sse2 test"
+
+DEPEND="test? ( app-shells/tcsh )"
+RDEPEND=""
+
+src_prepare() {
+ CC_ALT=
+ CFLAGS_ALT=
+ ALT=
+
+ use debug && append-flags -DDEBUG
+
+ if [[ $(tc-getCC) == *icc* ]]; then
+ CC_ALT=icc
+ ALT="${ALT}_icc"
+ else
+ CC_ALT=$(tc-getCC)
+ use x86 && ALT="32"
+ use amd64 && ALT="64"
+ fi
+
+ if use cpu_flags_x86_sse2 ; then
+ ALT="${ALT}_sse2"
+ append-flags -msse2
+ [[ $(tc-getCC) == *icc* ]] || append-flags -ffast-math
+ fi
+
+ export CC_ALT="${CC_ALT}"
+ export ALT="${ALT}"
+
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+
+ sed \
+ -e 's:-ffast-math::g' \
+ -i make/Makefile* || die
+
+}
+
+src_compile() {
+ cd src || die
+ emake -f ../make/Makefile.linux${ALT} CC="${CC_ALT} ${CFLAGS}" HFLAGS="${LDFLAGS} -o" all
+}
+
+src_test() {
+ cd test || die
+ FASTLIBS="../conf" bash test.sh || die
+}
+
+src_install() {
+ local bin
+ dobin bin/*
+
+ pushd bin > /dev/null || die
+ for bin in *36; do
+ dosym ${bin} /usr/bin/${bin%36} || die
+ done
+ popd
+
+ insinto /usr/share/${PN}
+ doins -r conf/* data seq
+
+ doman doc/{prss3.1,fasta36.1,fasts3.1,fastf3.1,ps_lav.1,map_db.1}
+ dodoc FASTA_LIST README doc/{README.versions,readme*,fasta*,changes*}
+}