summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/glimmer/glimmer-3.02-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/glimmer/glimmer-3.02-r3.ebuild')
-rw-r--r--sci-biology/glimmer/glimmer-3.02-r3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-biology/glimmer/glimmer-3.02-r3.ebuild b/sci-biology/glimmer/glimmer-3.02-r3.ebuild
new file mode 100644
index 000000000000..acc0eb98e18b
--- /dev/null
+++ b/sci-biology/glimmer/glimmer-3.02-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV//./}
+
+DESCRIPTION="An HMM-based microbial gene finding system from TIGR"
+HOMEPAGE="http://www.cbcb.umd.edu/software/glimmer/"
+SRC_URI="http://www.cbcb.umd.edu/software/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND=""
+RDEPEND="app-shells/tcsh"
+
+S="${WORKDIR}/${PN}${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc210.patch
+ "${FILESDIR}"/${P}-jobserver-fix.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${PN}-3.02b-rename_extract.patch
+)
+
+src_prepare() {
+ sed -i -e 's|\(set awkpath =\).*|\1 /usr/share/'${PN}'/scripts|' \
+ -e 's|\(set glimmerpath =\).*|\1 /usr/bin|' scripts/* || die "failed to rewrite paths"
+ # Fix Makefile to die on failure
+ sed -i 's/$(MAKE) $(TGT)/$(MAKE) $(TGT) || exit 1/' src/c_make.gen || die
+ # GCC 4.3 include fix
+ sed -i 's/include <string>/include <string.h>/' src/Common/delcher.hh || die
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() {
+ emake \
+ -C src \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ CXXFLAGS="${CXXFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ rm bin/test || die
+ dobin bin/*
+
+ insinto /usr/share/${PN}
+ doins -r scripts
+
+ dodoc glim302notes.pdf
+}