summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/gmap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/gmap')
-rw-r--r--sci-biology/gmap/Manifest2
-rw-r--r--sci-biology/gmap/gmap-2011.10.07.ebuild36
-rw-r--r--sci-biology/gmap/gmap-2012.07.20.ebuild36
-rw-r--r--sci-biology/gmap/metadata.xml9
4 files changed, 83 insertions, 0 deletions
diff --git a/sci-biology/gmap/Manifest b/sci-biology/gmap/Manifest
new file mode 100644
index 000000000000..b15b9200188f
--- /dev/null
+++ b/sci-biology/gmap/Manifest
@@ -0,0 +1,2 @@
+DIST gmap-gsnap-2011-10-07.tar.gz 3404351 SHA256 e508009592d5dd3442345dc5ce6fd9930366e008efa32e4c72dc243a495f3f20 SHA512 6546be4da41c45e41bdab71dcda69cbf172bc186ca64a2543461eb050f383641a13fea0cfcc6bb76b87cc4faa4c593944b029ee1ca2ba68dbaf7d939d0bf02e1 WHIRLPOOL 9f5cd62fb9cbb2cc73d6b971f29d8816e67e1b4b1b9906d8b06ddf99ffd9356bcdf19869066fb14ca5d3ad93a3b70527d05237be2f438da4db86898103bd2bf2
+DIST gmap-gsnap-2012-07-20.tar.gz 3623122 SHA256 4cd0c0a313cb7a35b8c7afd45b545e6062b343739f9ef522a09001d448aeb5ec SHA512 bbc22509fc63814a102f96ce0da6a1119c78de7fc2fc4fe17cc4d97881313a77818eaedc51bb6d4ce2426560925fe5ffa121acf972d7b3b097e8d3d65efb7b95 WHIRLPOOL 7318377e4cf80db5c5a9495bf68653fbc48051d6fa5748ed796e18888b6e20215d2714b753358fb4cc97aa9c8e441d53ef616ded6ee0923fe78312e78ee91e82
diff --git a/sci-biology/gmap/gmap-2011.10.07.ebuild b/sci-biology/gmap/gmap-2011.10.07.ebuild
new file mode 100644
index 000000000000..fb20296c2654
--- /dev/null
+++ b/sci-biology/gmap/gmap-2011.10.07.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+MY_PV=${PV//./-}
+
+DESCRIPTION="A Genomic Mapping and Alignment Program for mRNA and EST Sequences"
+HOMEPAGE="http://www.gene.com/share/gmap/"
+SRC_URI="http://research-pub.gene.com/gmap/src/gmap-gsnap-${MY_PV}.tar.gz"
+
+LICENSE="gmap"
+SLOT="0"
+IUSE="+samtools +goby"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="samtools? ( sci-biology/samtools )
+ goby? ( sci-biology/goby-cpp )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/gmap-${MY_PV}"
+
+src_configure() {
+ econf $(use_with samtools) \
+ $(use_with goby goby /usr)
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog README
+}
+
+src_test() {
+ emake check || die
+}
diff --git a/sci-biology/gmap/gmap-2012.07.20.ebuild b/sci-biology/gmap/gmap-2012.07.20.ebuild
new file mode 100644
index 000000000000..cd20c09b57f8
--- /dev/null
+++ b/sci-biology/gmap/gmap-2012.07.20.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_PV=${PV//./-}
+
+DESCRIPTION="A Genomic Mapping and Alignment Program for mRNA and EST Sequences"
+HOMEPAGE="http://research-pub.gene.com/gmap/"
+SRC_URI="http://research-pub.gene.com/gmap/src/gmap-gsnap-${MY_PV}.tar.gz"
+
+LICENSE="gmap"
+SLOT="0"
+IUSE="+samtools +goby"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="samtools? ( sci-biology/samtools )
+ goby? ( sci-biology/goby-cpp )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/gmap-${MY_PV}"
+
+src_configure() {
+ econf $(use_with samtools) \
+ $(use_with goby goby /usr)
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog README
+}
+
+src_test() {
+ emake check || die
+}
diff --git a/sci-biology/gmap/metadata.xml b/sci-biology/gmap/metadata.xml
new file mode 100644
index 000000000000..7d62e2f44e07
--- /dev/null
+++ b/sci-biology/gmap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name="samtools">Enable support for samtools</flag>
+ <flag name="goby">Enable support for goby</flag>
+ </use>
+</pkgmetadata>