summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-04 20:37:31 -0400
committerSam James <sam@gentoo.org>2024-04-07 07:16:09 +0100
commit14bc51e9759c448132391901ff1eb528fe0f5a0c (patch)
treece19dd05c53dce046191c858f3b7210fccaeeece /sci-biology/kallisto
parentsys-apps/man-db: add 2.12.1 (diff)
downloadgentoo-14bc51e9759c448132391901ff1eb528fe0f5a0c.tar.gz
gentoo-14bc51e9759c448132391901ff1eb528fe0f5a0c.tar.bz2
gentoo-14bc51e9759c448132391901ff1eb528fe0f5a0c.zip
sci-biology/kallisto: port to catch2 version 3
Which is the current default distributed version. Nicer than requiring people to downgrade to an old version. Closes: https://bugs.gentoo.org/877887 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology/kallisto')
-rw-r--r--sci-biology/kallisto/files/kallisto-0.46.2-catch2.patch10
-rw-r--r--sci-biology/kallisto/files/kallisto-0.46.2-cmake.patch2
-rw-r--r--sci-biology/kallisto/kallisto-0.46.2.ebuild10
3 files changed, 13 insertions, 9 deletions
diff --git a/sci-biology/kallisto/files/kallisto-0.46.2-catch2.patch b/sci-biology/kallisto/files/kallisto-0.46.2-catch2.patch
index 7566966c1c68..3ff6a0c33be0 100644
--- a/sci-biology/kallisto/files/kallisto-0.46.2-catch2.patch
+++ b/sci-biology/kallisto/files/kallisto-0.46.2-catch2.patch
@@ -3,12 +3,12 @@
@@ -1,2 +1,2 @@
#define CATCH_CONFIG_MAIN
-#include "catch.hpp"
-+#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
--- a/unit_tests/test_index.cpp
+++ b/unit_tests/test_index.cpp
@@ -1,4 +1,4 @@
-#include "catch.hpp"
-+#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
#include "common.h"
#include "KmerIndex.h"
@@ -16,7 +16,7 @@
+++ b/unit_tests/test_kmerhashtable.cpp
@@ -1,4 +1,4 @@
-#include "catch.hpp"
-+#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
#include <random>
#include <string>
@@ -24,7 +24,7 @@
+++ b/unit_tests/test_multinomial.cpp
@@ -1,4 +1,4 @@
-#include "catch.hpp"
-+#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
#include <iostream>
#include <vector>
@@ -32,7 +32,7 @@
+++ b/unit_tests/test_weights.cpp
@@ -1,4 +1,4 @@
-#include "catch.hpp"
-+#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
#include <vector>
diff --git a/sci-biology/kallisto/files/kallisto-0.46.2-cmake.patch b/sci-biology/kallisto/files/kallisto-0.46.2-cmake.patch
index ba6114a9164f..6516f162e906 100644
--- a/sci-biology/kallisto/files/kallisto-0.46.2-cmake.patch
+++ b/sci-biology/kallisto/files/kallisto-0.46.2-cmake.patch
@@ -142,7 +142,7 @@
+find_package( Catch2 REQUIRED )
+include_directories( ${Catch2_INCLUDE_DIRS} )
-+target_link_libraries( tests ${Catch2_LIBRARIES} )
++target_link_libraries( tests Catch2::Catch2WithMain )
+
find_package( ZLIB REQUIRED )
if ( ZLIB_FOUND )
diff --git a/sci-biology/kallisto/kallisto-0.46.2.ebuild b/sci-biology/kallisto/kallisto-0.46.2.ebuild
index 293cf9f76ed0..a1926bbd10fe 100644
--- a/sci-biology/kallisto/kallisto-0.46.2.ebuild
+++ b/sci-biology/kallisto/kallisto-0.46.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Near-optimal RNA-Seq quantification"
HOMEPAGE="http://pachterlab.github.io/kallisto/"
@@ -28,7 +28,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
test? (
- dev-cpp/catch:0
+ >=dev-cpp/catch-3:0
sci-libs/hdf5
)"
BDEPEND="virtual/pkgconfig"
@@ -51,6 +51,10 @@ src_prepare() {
# specific builddir nesting structure.
sed -e "s|../test/input/short_reads.fastq|$(readlink -f unit_tests/input/short_reads.fastq)|g" \
-i unit_tests/test_kmerhashtable.cpp || die
+
+ # This randomly hardcodes a particular std, which unfortunately is too old for catch2.
+ sed -i '/CMAKE_CXX_STANDARD/d' CMakeLists.txt || die
+ append-cxxflags -std=c++14
}
src_configure() {