summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-12-24 21:12:54 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-25 12:44:51 +0100
commit61b8654f706e0c48f79a631ee797be9ba5135b2c (patch)
treed55e8156e9b3365580874660daec53faf708a781 /sci-biology/mcl/mcl-14.137.ebuild
parentsci-biology/rmblast: Fix bug 569622. (diff)
downloadgentoo-61b8654f706e0c48f79a631ee797be9ba5135b2c.tar.gz
gentoo-61b8654f706e0c48f79a631ee797be9ba5135b2c.tar.bz2
gentoo-61b8654f706e0c48f79a631ee797be9ba5135b2c.zip
sci-biology/mcl: Version bump, fix bug 569040 and QA issues.
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-biology/mcl/mcl-14.137.ebuild')
-rw-r--r--sci-biology/mcl/mcl-14.137.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/mcl/mcl-14.137.ebuild b/sci-biology/mcl/mcl-14.137.ebuild
new file mode 100644
index 000000000000..6912351fd2ed
--- /dev/null
+++ b/sci-biology/mcl/mcl-14.137.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN}-${PV/./-}"
+
+DESCRIPTION="A Markov Cluster Algorithm implementation"
+HOMEPAGE="http://micans.org/mcl/"
+SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blast"
+
+PATCHES=("${FILESDIR}/${P}-qa-implicit-declarations.patch")
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ find \
+ -name Makefile.am \
+ -exec sed \
+ -e '/docdir/d' \
+ -e '/exampledir/s:doc::g' \
+ -i '{}' + || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable blast)
+}