summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-19 16:29:31 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-19 18:03:02 +0100
commita474ab0de01ae126ebfd16f834fbe01951da9ad4 (patch)
tree8ad2c55f6afa2a02c04aae232da751b9367e225a /sci-biology/meme/meme-4.11.2_p2.ebuild
parentnet-im/jabberd2: Drop old vulnerable versions (bug #539534) (diff)
downloadgentoo-a474ab0de01ae126ebfd16f834fbe01951da9ad4.tar.gz
gentoo-a474ab0de01ae126ebfd16f834fbe01951da9ad4.tar.bz2
gentoo-a474ab0de01ae126ebfd16f834fbe01951da9ad4.zip
sci-biology/meme: Version bump to 4.11.2_p2
Gentoo-bug: 599860 * EAPI=6 * Install documentation and examples correctly * Install perl and python modules correctly * Add missing perl runtime dependencies Package-Manager: portage-2.3.2
Diffstat (limited to 'sci-biology/meme/meme-4.11.2_p2.ebuild')
-rw-r--r--sci-biology/meme/meme-4.11.2_p2.ebuild111
1 files changed, 111 insertions, 0 deletions
diff --git a/sci-biology/meme/meme-4.11.2_p2.ebuild b/sci-biology/meme/meme-4.11.2_p2.ebuild
new file mode 100644
index 000000000000..4eb826065500
--- /dev/null
+++ b/sci-biology/meme/meme-4.11.2_p2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools perl-functions python-single-r1 versionator
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P=${PN}_${MY_PV}
+
+DESCRIPTION="The MEME/MAST system - Motif discovery and search"
+HOMEPAGE="http://meme-suite.org/tools/meme"
+SRC_URI="http://meme-suite.org/meme-software/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="meme"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples mpi"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-shells/tcsh
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ sys-libs/zlib
+ app-text/ghostscript-gpl
+ media-gfx/imagemagick
+ dev-lang/perl:=
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Template
+ dev-perl/Log-Log4perl
+ dev-perl/Math-CDF
+ dev-perl/XML-Compile-SOAP
+ dev-perl/XML-Compile-WSDL11
+ dev-perl/XML-Parser
+ dev-perl/XML-Simple
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Time-HiRes
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.11.2_p2-patch1.patch
+ "${FILESDIR}"/${PN}-4.11.2_p2-patch2.patch
+ "${FILESDIR}"/${PN}-4.11.2_p2-fix-build-system.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ perl_set_version
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-logs="${EPREFIX}"/var/log/${PN} \
+ --with-perl=perl \
+ --with-convert=convert \
+ --with-gs=gs \
+ --disable-build-libxml2 \
+ --disable-build-libxslt \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(use_enable examples) \
+ $(use_enable !mpi serial) \
+ --with-perl-dir="${VENDOR_LIB#${EPREFIX}/usr}" \
+ PYTHON="${EPYTHON}"
+
+ # delete bundled libs, just to be sure. These need
+ # to be removed after econf, else AC_OUTPUT will fail
+ rm -r src/{libxml2,lib{,e}xslt} || die
+}
+
+src_test() {
+ # bug #297070
+ emake -j1 test
+}
+
+src_install() {
+ default
+ docompress -x /usr/share/doc/${PF}/examples
+
+ # prefix all binaries with 'meme-', in order
+ # to prevent collisions, bug 455010
+ cd "${ED%/}"/usr/bin/ || die
+ local i
+ for i in *; do
+ if [[ $i != meme-* ]]; then
+ mv {,meme-}"${i}" || die
+ fi
+ done
+
+ diropts -m ugo+rwxt -o root
+ keepdir /var/log/meme
+}