summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/mira/mira-4.0.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/mira/mira-4.0.2.ebuild')
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
new file mode 100644
index 000000000000..3fa476c026a2
--- /dev/null
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MIRA_3RDPARTY_PV="06-07-2012"
+MY_PV="${PV/_}" # convert from mira-4.0_rc2 (Gentoo ebuild filename derived) to mira-4.0rc2 (upstream fromat)
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="
+ http://sourceforge.net/projects/mira-assembler/files/MIRA/stable/"${PN}"-"${MY_PV}".tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+# http://sourceforge.net/projects/mira-assembler/files/MIRA/development/${P}.tar.bz2
+# mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+S="${WORKDIR}"/"${PN}"-"${MY_PV}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+CDEPEND="
+ dev-libs/boost
+ dev-util/google-perftools"
+DEPEND="${CDEPEND}
+ app-editors/vim-core
+ dev-libs/expat"
+RDEPEND="${CDEPEND}"
+
+#DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED
+# THANKS doc/3rdparty/scaffolding_MIRA_BAMBUS.pdf )
+DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED THANKS )
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.4.0.2-boost-1.50.patch \
+ "${FILESDIR}"/${P}-cout.patch
+
+ sed \
+ -e "s:-O[23]::g" \
+ -e "s:-funroll-loops::g" \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-thread=boost_thread-mt
+}
+
+#src_compile() {
+# base_src_compile
+# # TODO: resolve docbook incompatibility for building docs
+# if use doc; then emake -C doc clean docs || die; fi
+#}
+
+src_install() {
+ default
+ dodoc ${DOCS[@]}
+
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,qual2ball,*.pl}
+ dodoc "${WORKDIR}"/3rdparty/{README.txt,midi_screen.fasta}
+}
+
+pkg_postinst() {
+ einfo "Documentation is no longer built, you can find it at:"
+ einfo "http://mira-assembler.sourceforge.net/docs/DefinitiveGuideToMIRA.html"
+}