summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/mothur
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/mothur')
-rw-r--r--sci-biology/mothur/Manifest2
-rw-r--r--sci-biology/mothur/files/mothur-1.27.0-makefile.patch52
-rw-r--r--sci-biology/mothur/files/mothur-1.27.0-overflows.patch93
-rw-r--r--sci-biology/mothur/metadata.xml5
-rw-r--r--sci-biology/mothur/mothur-1.27.0-r1.ebuild44
-rw-r--r--sci-biology/mothur/mothur-1.6.0.ebuild33
6 files changed, 229 insertions, 0 deletions
diff --git a/sci-biology/mothur/Manifest b/sci-biology/mothur/Manifest
new file mode 100644
index 000000000000..e0cf36aefaf6
--- /dev/null
+++ b/sci-biology/mothur/Manifest
@@ -0,0 +1,2 @@
+DIST mothur-1.27.0.zip 7095054 SHA256 7521d0dfc849dc9ef707bf83032e471966914b9833247c49e5d30b8d9281a6c7 SHA512 81821ca95d4ce3f0d1e6aa920c4fe3fddd70f716157312ed0590c1c4ad728e6786bfe79f6badddcfb060ed5d1996cc1b5062c320a59209fef35f68e687ba3dd5 WHIRLPOOL 32e5c9c2be6e593b2dbc64be38c49b4dec3ea048cd3c972cf948136b394608a2dc168be58b7fb500a17fc6a152b7777fcd09b3f9fb3bf60c7dd92d043a4bf361
+DIST mothur-1.6.0.zip 465292 SHA256 75583a204d199ddcf9b845fc0adbaf240d7b1f08584fed5e6465982f68ffe121 SHA512 f775ff64991f00423108f295eca640f5c5d85a38e01b31af44ddf91f8897968e934f79899a21606dfd81fdc3e91751df277237e94d56d74f862e472e8da3386c WHIRLPOOL 31ca8decceb38ebd17f15c5f937df70b501833311cbf1aec794bb174d409a0c01e77abb399347781ad820c06411e56c566382a32818a0c57214aad2ad16cc132
diff --git a/sci-biology/mothur/files/mothur-1.27.0-makefile.patch b/sci-biology/mothur/files/mothur-1.27.0-makefile.patch
new file mode 100644
index 000000000000..52a02585df14
--- /dev/null
+++ b/sci-biology/mothur/files/mothur-1.27.0-makefile.patch
@@ -0,0 +1,52 @@
+ makefile | 14 ++++++--------
+ 1 files changed, 6 insertions(+), 8 deletions(-)
+
+diff --git a/makefile b/makefile
+index db7c904..109488f 100644
+--- a/makefile
++++ b/makefile
+@@ -10,18 +10,18 @@
+ #
+
+ USEMPI ?= no
+-64BIT_VERSION ?= yes
++64BIT_VERSION ?= no
+ USEREADLINE ?= yes
+ CYGWIN_BUILD ?= no
+ USECOMPRESSION ?= no
+ MOTHUR_FILES="\"Enter_your_default_path_here\""
+ RELEASE_DATE = "\"8/8/2012\""
+ VERSION = "\"1.27.0\""
+-FORTAN_COMPILER = gfortran
+-FORTRAN_FLAGS =
++FORTAN_COMPILER = ${FC}
++FORTRAN_FLAGS = ${FCFLAGS}
+
+ # Optimize to level 3:
+-CXXFLAGS += -O3
++#CXXFLAGS += -O3
+
+ ifeq ($(strip $(64BIT_VERSION)),yes)
+ #if you are using centos uncomment the following lines
+@@ -69,7 +69,7 @@ endif
+
+
+ ifeq ($(strip $(USEMPI)),yes)
+- CXX = mpic++
++# CXX = mpic++
+ CXXFLAGS += -DUSE_MPI
+ endif
+
+@@ -95,11 +95,9 @@ OBJECTS=$(patsubst %.cpp,%.o,$(wildcard *.cpp))
+ OBJECTS+=$(patsubst %.c,%.o,$(wildcard *.c))
+ OBJECTS+=$(patsubst %.f,%.o,$(wildcard *.f))
+
+-mothur : fortranSource $(OBJECTS) uchime
++mothur : fortranSource $(OBJECTS)
+ $(CXX) $(LDFLAGS) $(TARGET_ARCH) -o $@ $(OBJECTS) $(LIBS)
+
+- strip mothur
+-
+ uchime:
+ cd uchime_src && ./mk && mv uchime .. && cd ..
+
diff --git a/sci-biology/mothur/files/mothur-1.27.0-overflows.patch b/sci-biology/mothur/files/mothur-1.27.0-overflows.patch
new file mode 100644
index 000000000000..0b612cf7b529
--- /dev/null
+++ b/sci-biology/mothur/files/mothur-1.27.0-overflows.patch
@@ -0,0 +1,93 @@
+ chimerauchimecommand.cpp | 2 +-
+ clearcutcommand.cpp | 32 ++++++++++++++++----------------
+ 2 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/chimerauchimecommand.cpp b/chimerauchimecommand.cpp
+index bd31c19..2070840 100644
+--- a/chimerauchimecommand.cpp
++++ b/chimerauchimecommand.cpp
+@@ -1264,7 +1264,7 @@ int ChimeraUchimeCommand::driver(string outputFName, string filename, string acc
+ }
+
+ if (ucl) {
+- char* tempucl = new char[5];
++ char* tempucl = new char[6];
+ strcpy(tempucl, "--ucl");
+ cPara.push_back(tempucl);
+ }
+diff --git a/clearcutcommand.cpp b/clearcutcommand.cpp
+index 6a0eb25..2e8164e 100644
+--- a/clearcutcommand.cpp
++++ b/clearcutcommand.cpp
+@@ -269,35 +269,35 @@ int ClearcutCommand::execute() {
+
+ vector<char*> cPara;
+
+- char* tempClearcut = new char[8];
++ char* tempClearcut = new char[16];
+ strcpy(tempClearcut, "clearcut");
+ cPara.push_back(tempClearcut);
+
+ //you gave us a distance matrix
+- if (phylipfile != "") { char* temp = new char[10]; strcpy(temp, "--distance"); cPara.push_back(temp); }
++ if (phylipfile != "") { char* temp = new char[16]; strcpy(temp, "--distance"); cPara.push_back(temp); }
+
+ //you gave us a fastafile
+- if (fastafile != "") { char* temp = new char[11]; strcpy(temp, "--alignment"); cPara.push_back(temp); }
++ if (fastafile != "") { char* temp = new char[16]; strcpy(temp, "--alignment"); cPara.push_back(temp); }
+
+- if (version) { char* temp = new char[9]; strcpy(temp, "--version"); cPara.push_back(temp); }
+- if (verbose) { char* temp = new char[9]; strcpy(temp, "--verbose"); cPara.push_back(temp); }
+- if (quiet) { char* temp = new char[7]; strcpy(temp, "--quiet"); cPara.push_back(temp); }
++ if (version) { char* temp = new char[16]; strcpy(temp, "--version"); cPara.push_back(temp); }
++ if (verbose) { char* temp = new char[16]; strcpy(temp, "--verbose"); cPara.push_back(temp); }
++ if (quiet) { char* temp = new char[16]; strcpy(temp, "--quiet"); cPara.push_back(temp); }
+ if (seed != "*") {
+ string tempSeed = "--seed=" + seed;
+ char* temp = new char[tempSeed.length()];
+ strcpy(temp, tempSeed.c_str());
+ cPara.push_back(temp);
+ }
+- if (norandom) { char* temp = new char[10]; strcpy(temp, "--norandom"); cPara.push_back(temp); }
+- if (shuffle) { char* temp = new char[9]; strcpy(temp, "--shuffle"); cPara.push_back(temp); }
+- if (neighbor) { char* temp = new char[10]; strcpy(temp, "--neighbor"); cPara.push_back(temp); }
++ if (norandom) { char* temp = new char[16]; strcpy(temp, "--norandom"); cPara.push_back(temp); }
++ if (shuffle) { char* temp = new char[16]; strcpy(temp, "--shuffle"); cPara.push_back(temp); }
++ if (neighbor) { char* temp = new char[16]; strcpy(temp, "--neighbor"); cPara.push_back(temp); }
+
+ string tempIn = "--in=" + inputFile;
+ char* tempI = new char[tempIn.length()];
+ strcpy(tempI, tempIn.c_str());
+ cPara.push_back(tempI);
+
+- if (stdoutWanted) { char* temp = new char[8]; strcpy(temp, "--stdout"); cPara.push_back(temp); }
++ if (stdoutWanted) { char* temp = new char[16]; strcpy(temp, "--stdout"); cPara.push_back(temp); }
+ else{
+ string tempOut = "--out=" + outputName;
+
+@@ -306,10 +306,10 @@ int ClearcutCommand::execute() {
+ cPara.push_back(temp);
+ }
+
+- if (DNA) { char* temp = new char[5]; strcpy(temp, "--DNA"); cPara.push_back(temp); }
+- if (protein) { char* temp = new char[9]; strcpy(temp, "--protein"); cPara.push_back(temp); }
+- if (jukes) { char* temp = new char[7]; strcpy(temp, "--jukes"); cPara.push_back(temp); }
+- if (kimura) { char* temp = new char[8]; strcpy(temp, "--kimura"); cPara.push_back(temp); }
++ if (DNA) { char* temp = new char[16]; strcpy(temp, "--DNA"); cPara.push_back(temp); }
++ if (protein) { char* temp = new char[16]; strcpy(temp, "--protein"); cPara.push_back(temp); }
++ if (jukes) { char* temp = new char[16]; strcpy(temp, "--jukes"); cPara.push_back(temp); }
++ if (kimura) { char* temp = new char[16]; strcpy(temp, "--kimura"); cPara.push_back(temp); }
+ if (matrixout != "") {
+ string tempMatrix = "--matrixout=" + outputDir + matrixout;
+ char* temp = new char[tempMatrix.length()];
+@@ -326,8 +326,8 @@ int ClearcutCommand::execute() {
+ cPara.push_back(temp);
+ }
+
+- if (expblen) { char* temp = new char[9]; strcpy(temp, "--expblen"); cPara.push_back(temp); }
+- if (expdist) { char* temp = new char[9]; strcpy(temp, "--expdist"); cPara.push_back(temp); }
++ if (expblen) { char* temp = new char[16]; strcpy(temp, "--expblen"); cPara.push_back(temp); }
++ if (expdist) { char* temp = new char[16]; strcpy(temp, "--expdist"); cPara.push_back(temp); }
+
+ char** clearcutParameters;
+ clearcutParameters = new char*[cPara.size()];
diff --git a/sci-biology/mothur/metadata.xml b/sci-biology/mothur/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/mothur/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/mothur/mothur-1.27.0-r1.ebuild b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
new file mode 100644
index 000000000000..3de23de65d51
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic fortran-2 toolchain-funcs
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://www.mothur.org/"
+SRC_URI="http://www.mothur.org/w/images/c/cb/Mothur.${PV}.zip -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="mpi +readline"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ sci-biology/uchime
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/Mothur.source
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ use mpi && export CXX=mpicxx || export CXX=$(tc-getCXX)
+ use amd64 && append-cppflags -DBIT_VERSION
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-overflows.patch
+}
+
+src_compile() {
+ emake USEMPI=$(usex mpi) USEREADLINE=$(usex readline)
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/sci-biology/mothur/mothur-1.6.0.ebuild b/sci-biology/mothur/mothur-1.6.0.ebuild
new file mode 100644
index 000000000000..034f6fae1a65
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://www.mothur.org/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/mothur-v.${PV}"
+
+src_prepare() {
+ sed \
+ -e 's/CC_OPTIONS =.*$/CC_OPTIONS = ${CXXFLAGS} /' \
+ -e 's|CC = g++|CC = '$(tc-getCXX)'|' \
+ -e '/^LNK_OPTIONS/s:$:${LDFLAGS}:g' \
+ -i makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+}