summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-15 17:16:27 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 17:20:52 +0100
commit7b5460f041d22383cf26a2d7cd5b3d784eb68133 (patch)
tree55714e0d06fe5c848c4131a805ab90242cabf418 /sci-biology/mummer
parentnet-libs/liboping: Call fcaps only on files we really have installed (bug #60... (diff)
downloadgentoo-7b5460f041d22383cf26a2d7cd5b3d784eb68133.tar.gz
gentoo-7b5460f041d22383cf26a2d7cd5b3d784eb68133.tar.bz2
gentoo-7b5460f041d22383cf26a2d7cd5b3d784eb68133.zip
sci-biology/mummer: Version bump to 3.9.4_alpha
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology/mummer')
-rw-r--r--sci-biology/mummer/Manifest1
-rw-r--r--sci-biology/mummer/mummer-3.9.4_alpha.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-biology/mummer/Manifest b/sci-biology/mummer/Manifest
index 5e456956d852..8089124a7428 100644
--- a/sci-biology/mummer/Manifest
+++ b/sci-biology/mummer/Manifest
@@ -1,3 +1,4 @@
DIST MUMmer3.20.tar.gz 3155446 SHA256 9c7880b4ce25ef3c6bed9ccdc26f1c4d7e74eb0ef1ce403907790c0f96c0f260 SHA512 7c80bb605d57739809eb1b1cf8a579d72048e510362237d9ba64e21be18cc663769cda5dabc287832e59fb62804df34bc8336c2b42474466e7ee1e126848aecd WHIRLPOOL a08af35aee960bcd6274d3a00b1c1819d23367c81a72fd41c652c3579253b0aeeb5ef66f6dcfed60b4987c3a40830d04cd81745dce8a274cc3de0663dd54ae6f
DIST MUMmer3.21.tar.gz 3155965 SHA256 7fb1456c8c21eab4913a522e4b79bc5c84b7373feb54614a7003b16d47dc23b8 SHA512 61d49e5451e1697003f7acaac690f2ede7ab71766208d3218954527c48be76ddb78d60ff40ae1bdcd4b93d3efaf21b5bd027da3722eab1ae3fa399ee726bc96e WHIRLPOOL 50c7b0d7c00bf85aa8e0f8b80bf55186f8c0a53d26c3e50d2149120bc46f3632de4cb861a4d4265c1e3be731dffb71940344b238fd3e977412134b0e401cb95e
DIST MUMmer3.22.tar.gz 3156338 SHA256 429022a8c6a7ae55fb1dd94dbdac1b21f662d6278668f5531c735911d9fc77da SHA512 37bbb368c679d2e98fa9b9ef10c18008c173c25ee79183eb30e34125b1dc9cd10f005b7bd7c648335a8025509d8e3456fcc7ce497c95fa71c3c5d3ed3685665f WHIRLPOOL 487333ca38a9c59984ed059e8dd620ad3c0a5ae1a537e500c7b8b2d58213ac88960a13c0f25e6e0490d1209c9e73cfe8df0f8a43dbae9fd6a3e9fe3ce42da453
+DIST mummer-3.9.4_alpha.tar.gz 956517 SHA256 fb2f03c729cd078d526d6318f91061f8832c2e8bd0d519ddf3c0b6e656029cfa SHA512 f0b962a69df6918afc7d163b30bcf5bd9eb2be663c8ac685b5e06317953cf12b9d240df8a5bfe8a9410b65cf88176cc7a71eecfc460e51df7ad1b27dc3a10fc2 WHIRLPOOL 8443cde87f868136eaa005db2b5b461a822097778d4c36448602a5cda058dc1dfa10daa08883248ffaba79a1d33240170b94b96548ebb56a01eaa27838d4afd6
diff --git a/sci-biology/mummer/mummer-3.9.4_alpha.ebuild b/sci-biology/mummer/mummer-3.9.4_alpha.ebuild
new file mode 100644
index 000000000000..c9490003fdf9
--- /dev/null
+++ b/sci-biology/mummer/mummer-3.9.4_alpha.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit perl-functions python-r1 toolchain-funcs
+
+MY_PV=${PV//_/}
+
+DESCRIPTION="A rapid whole genome aligner"
+HOMEPAGE="http://mummer.sourceforge.net/"
+SRC_URI="https://github.com/gmarcais/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE="openmp perl python"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig:0
+ )"
+RDEPEND="
+ app-shells/tcsh
+ dev-lang/perl:=
+ python? ( ${PYTHON_DEPS} )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ use python && preamble="python_foreach_impl run_in_build_dir"
+}
+
+src_configure() {
+ perl_set_version
+ configure() {
+ local pythonconf
+ if use python; then
+ pythonconf="--enable-python-binding=$(python_get_sitedir)"
+ else
+ pythonconf="--disable-python-binding"
+ fi
+
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --disable-ruby-binding \
+ $(use_enable perl perl-binding "${VENDOR_LIB}") \
+ $(use_enable openmp) \
+ $(use_enable python swig) \
+ "${pythonconf}"
+ }
+ ${preamble} configure
+}
+
+src_compile() {
+ ${preamble} default
+}
+
+src_install() {
+ ${preamble} default
+ einstalldocs
+
+ # avoid file collision
+ mv "${ED%/}"/usr/bin/{,mummer-}annotate || die
+
+ # move perl module into right place
+ mkdir -p "${D%/}${VENDOR_LIB}" || die
+ mv "${ED%/}"/usr/$(get_libdir)/mummer/Foundation.pm "${D%/}${VENDOR_LIB}" || die
+
+ # no static libs, can purge .la files
+ find "${D}" -name '*.la' -delete || die
+}