summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-08 22:35:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 23:16:34 +0100
commita9691d02216b727d0d148a0048ebf3e425e6d8f4 (patch)
tree805eefef9f90fd326a08aba5875b1b27bb437fb0 /sci-biology/pals/pals-1.0-r1.ebuild
parentsci-biology/clustalw-mpi: Modernise to EAPI 6 (diff)
downloadgentoo-a9691d02216b727d0d148a0048ebf3e425e6d8f4.tar.gz
gentoo-a9691d02216b727d0d148a0048ebf3e425e6d8f4.tar.bz2
gentoo-a9691d02216b727d0d148a0048ebf3e425e6d8f4.zip
sci-biology/pals: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4165
Diffstat (limited to 'sci-biology/pals/pals-1.0-r1.ebuild')
-rw-r--r--sci-biology/pals/pals-1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-biology/pals/pals-1.0-r1.ebuild b/sci-biology/pals/pals-1.0-r1.ebuild
new file mode 100644
index 000000000000..32579b9d0757
--- /dev/null
+++ b/sci-biology/pals/pals-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pairwise Aligner for Long Sequences"
+HOMEPAGE="http://www.drive5.com/pals/"
+SRC_URI="http://www.drive5.com/pals/pals_source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ dobin pals
+}